You are viewing a plain text version of this content. The canonical link for it is here.
- [GitHub] [httpcomponents-core] ok2c commented on a diff in pull request #423: HTTPCORE-756 - Enforced the requirement that "https" URIs must not have an empty host identifier - posted by "ok2c (via GitHub)" <gi...@apache.org> on 2023/09/01 08:42:55 UTC, 0 replies.
- [GitHub] [httpcomponents-core] michael-o commented on pull request #424: HTTPCORE-756 - Implement RFC9110 Content-Type Validation for OPTIONS Requests - posted by "michael-o (via GitHub)" <gi...@apache.org> on 2023/09/01 09:06:43 UTC, 0 replies.
- [GitHub] [httpcomponents-core] reschke commented on a diff in pull request #424: HTTPCORE-756 - Implement RFC9110 Content-Type Validation for OPTIONS Requests - posted by "reschke (via GitHub)" <gi...@apache.org> on 2023/09/01 09:13:08 UTC, 0 replies.
- [GitHub] [httpcomponents-core] reschke commented on pull request #424: HTTPCORE-756 - Implement RFC9110 Content-Type Validation for OPTIONS Requests - posted by "reschke (via GitHub)" <gi...@apache.org> on 2023/09/01 09:15:09 UTC, 0 replies.
- [GitHub] [httpcomponents-core] ok2c commented on pull request #424: HTTPCORE-756 - Implement RFC9110 Content-Type Validation for OPTIONS Requests - posted by "ok2c (via GitHub)" <gi...@apache.org> on 2023/09/01 09:24:00 UTC, 0 replies.
- [GitHub] [httpcomponents-core] ok2c commented on a diff in pull request #424: HTTPCORE-756 - Implement RFC9110 Content-Type Validation for OPTIONS Requests - posted by "ok2c (via GitHub)" <gi...@apache.org> on 2023/09/01 09:29:04 UTC, 2 replies.
- [jira] [Commented] (HTTPCORE-756) HttpCore HTTP Semantics conformance to RFC 9110 - posted by "Julian Reschke (Jira)" <ji...@apache.org> on 2023/09/01 09:42:00 UTC, 15 replies.
- [GitHub] [httpcomponents-core] reschke commented on a diff in pull request #423: HTTPCORE-756 - Enforced the requirement that "https" URIs must not have an empty host identifier - posted by "reschke (via GitHub)" <gi...@apache.org> on 2023/09/01 10:26:05 UTC, 0 replies.
- [GitHub] [httpcomponents-core] arturobernalg commented on a diff in pull request #423: HTTPCORE-756 - Enforced the requirement that "https" URIs must not have an empty host identifier - posted by "arturobernalg (via GitHub)" <gi...@apache.org> on 2023/09/01 10:29:35 UTC, 1 replies.
- [GitHub] [httpcomponents-core] reschke commented on pull request #423: HTTPCORE-756 - Enforced the requirement that "https" URIs must not have an empty host identifier - posted by "reschke (via GitHub)" <gi...@apache.org> on 2023/09/01 11:11:32 UTC, 0 replies.
- [GitHub] [httpcomponents-core] ok2c commented on pull request #423: HTTPCORE-756 - Enforced the requirement that "https" URIs must not have an empty host identifier - posted by "ok2c (via GitHub)" <gi...@apache.org> on 2023/09/01 11:24:08 UTC, 1 replies.
- [GitHub] [httpcomponents-core] arturobernalg commented on a diff in pull request #424: HTTPCORE-756 - Implement RFC9110 Content-Type Validation for OPTIONS Requests - posted by "arturobernalg (via GitHub)" <gi...@apache.org> on 2023/09/01 12:12:33 UTC, 0 replies.
- [GitHub] [httpcomponents-core] arturobernalg opened a new pull request, #426: Refactor testGetWithTimeout for Reliability - posted by "arturobernalg (via GitHub)" <gi...@apache.org> on 2023/09/01 12:46:54 UTC, 0 replies.
- [GitHub] [httpcomponents-core] ok2c commented on a diff in pull request #426: Refactor testGetWithTimeout for Reliability - posted by "ok2c (via GitHub)" <gi...@apache.org> on 2023/09/01 14:01:44 UTC, 1 replies.
- [GitHub] [httpcomponents-core] arturobernalg commented on a diff in pull request #426: Refactor testGetWithTimeout for Reliability - posted by "arturobernalg (via GitHub)" <gi...@apache.org> on 2023/09/01 14:09:49 UTC, 1 replies.
- [GitHub] [httpcomponents-core] thc202 commented on a diff in pull request #426: Refactor testGetWithTimeout for Reliability - posted by "thc202 (via GitHub)" <gi...@apache.org> on 2023/09/01 14:51:42 UTC, 1 replies.
- [GitHub] [httpcomponents-core] arturobernalg commented on pull request #423: HTTPCORE-756 - Enforced the requirement that "https" URIs must not have an empty host identifier - posted by "arturobernalg (via GitHub)" <gi...@apache.org> on 2023/09/01 16:53:12 UTC, 0 replies.
- [jira] [Created] (HTTPCORE-757) AbstractCharDataConsumer jams up with incomplete UTF-8 data - posted by "Simon White (Jira)" <ji...@apache.org> on 2023/09/02 12:06:00 UTC, 0 replies.
- [jira] [Updated] (HTTPCORE-757) AbstractCharDataConsumer jams up with incomplete UTF-8 data - posted by "Simon White (Jira)" <ji...@apache.org> on 2023/09/02 12:07:00 UTC, 2 replies.
- [jira] [Comment Edited] (HTTPCORE-756) HttpCore HTTP Semantics conformance to RFC 9110 - posted by "Arturo Bernal (Jira)" <ji...@apache.org> on 2023/09/02 17:08:00 UTC, 2 replies.
- [jira] [Commented] (HTTPCORE-757) AbstractCharDataConsumer jams up with incomplete UTF-8 data - posted by "Oleg Kalnichevski (Jira)" <ji...@apache.org> on 2023/09/03 10:07:00 UTC, 12 replies.
- [GitHub] [httpcomponents-core] arturobernalg merged pull request #423: HTTPCORE-756 - Enforced the requirement that `https` and `http` URIs must not have an empty host identifier - posted by "arturobernalg (via GitHub)" <gi...@apache.org> on 2023/09/03 16:35:06 UTC, 0 replies.
- [GitHub] [httpcomponents-core] arturobernalg merged pull request #424: HTTPCORE-756 - Implement RFC9110 Content-Type Validation for OPTIONS Requests - posted by "arturobernalg (via GitHub)" <gi...@apache.org> on 2023/09/03 16:41:32 UTC, 0 replies.
- [GitHub] [httpcomponents-core] arturobernalg merged pull request #426: Refactor testGetWithTimeout for Reliability - posted by "arturobernalg (via GitHub)" <gi...@apache.org> on 2023/09/03 16:48:22 UTC, 0 replies.
- [GitHub] [httpcomponents-core] yndu13 opened a new pull request, #427: Supports SOCKS5 proxy with username/password authentication - posted by "yndu13 (via GitHub)" <gi...@apache.org> on 2023/09/04 04:19:23 UTC, 0 replies.
- [GitHub] [httpcomponents-core] yndu13 commented on pull request #427: Support SOCKS5 proxy with username/password authentication - posted by "yndu13 (via GitHub)" <gi...@apache.org> on 2023/09/04 04:28:38 UTC, 2 replies.
- [GitHub] [httpcomponents-core] ok2c commented on pull request #427: Support SOCKS5 proxy with username/password authentication - posted by "ok2c (via GitHub)" <gi...@apache.org> on 2023/09/04 12:00:01 UTC, 1 replies.
- [GitHub] [httpcomponents-core] garydgregory commented on pull request #427: Support SOCKS5 proxy with username/password authentication - posted by "garydgregory (via GitHub)" <gi...@apache.org> on 2023/09/04 12:17:27 UTC, 0 replies.
- [GitHub] [httpcomponents-core] ok2c merged pull request #427: Support SOCKS5 proxy with username/password authentication - posted by "ok2c (via GitHub)" <gi...@apache.org> on 2023/09/04 12:54:20 UTC, 0 replies.
- [GitHub] [httpcomponents-core] arturobernalg opened a new pull request, #428: Add validation for :path pseudo-header in HTTP/2 requests RFC7540 - posted by "arturobernalg (via GitHub)" <gi...@apache.org> on 2023/09/06 20:44:35 UTC, 0 replies.
- [GitHub] [httpcomponents-client] dependabot[bot] opened a new pull request, #481: Bump actions/checkout from 3 to 4 - posted by "dependabot[bot] (via GitHub)" <gi...@apache.org> on 2023/09/08 13:37:37 UTC, 0 replies.
- [GitHub] [httpcomponents-core] dependabot[bot] opened a new pull request, #429: Bump actions/checkout from 3 to 4 - posted by "dependabot[bot] (via GitHub)" <gi...@apache.org> on 2023/09/08 14:26:38 UTC, 0 replies.
- [jira] [Created] (HTTPCLIENT-2297) Documenting HttpClient 4.x status - posted by "Henri Yandell (Jira)" <ji...@apache.org> on 2023/09/09 00:09:00 UTC, 0 replies.
- [jira] [Commented] (HTTPCLIENT-2297) Documenting HttpClient 4.x status - posted by "Michael Osipov (Jira)" <ji...@apache.org> on 2023/09/09 07:13:00 UTC, 5 replies.
- [jira] [Commented] (HTTPCLIENT-2293) HttpClient HTTP Semantics conformance to RFC 9110 - posted by "Arturo Bernal (Jira)" <ji...@apache.org> on 2023/09/13 18:03:00 UTC, 3 replies.
- [GitHub] [httpcomponents-client] arturobernalg opened a new pull request, #482: HTTPCLIENT-2293 Enforce Port Specification for CONNECT Request - posted by "arturobernalg (via GitHub)" <gi...@apache.org> on 2023/09/13 18:13:20 UTC, 0 replies.
- [jira] [Commented] (HTTPCORE-751) Memory Consumption and GC Performance Issues with HttpClient-5.2.1 in HTTP/2 Communication - posted by "Ruslan Sibgatullin (Jira)" <ji...@apache.org> on 2023/09/14 09:42:00 UTC, 2 replies.
- [jira] [Commented] (HTTPCLIENT-2277) HttpClient Cache conformance to RFC 9111 - posted by "ASF subversion and git services (Jira)" <ji...@apache.org> on 2023/09/14 13:32:00 UTC, 6 replies.
- [GitHub] [httpcomponents-core] ok2c commented on a diff in pull request #428: Add validation for :path pseudo-header in HTTP/2 requests RFC7540 - posted by "ok2c (via GitHub)" <gi...@apache.org> on 2023/09/14 13:45:53 UTC, 1 replies.
- [GitHub] [httpcomponents-client] ok2c commented on a diff in pull request #482: HTTPCLIENT-2293 Enforce Port Specification for CONNECT Request - posted by "ok2c (via GitHub)" <gi...@apache.org> on 2023/09/14 13:55:39 UTC, 0 replies.
- [GitHub] [httpcomponents-client] ok2c opened a new pull request, #483: HTTPCLIENT-2277: internal cache API and cache update redesign - posted by "ok2c (via GitHub)" <gi...@apache.org> on 2023/09/14 14:13:39 UTC, 0 replies.
- [GitHub] [httpcomponents-client] ok2c commented on pull request #483: HTTPCLIENT-2277: internal cache API and cache update redesign - posted by "ok2c (via GitHub)" <gi...@apache.org> on 2023/09/14 14:19:51 UTC, 0 replies.
- [jira] [Resolved] (HTTPCORE-757) AbstractCharDataConsumer jams up with incomplete UTF-8 data - posted by "Oleg Kalnichevski (Jira)" <ji...@apache.org> on 2023/09/15 09:20:00 UTC, 0 replies.
- [jira] [Commented] (HTTPCLIENT-2292) SOCKS proxy configuration is not working - posted by "ASF subversion and git services (Jira)" <ji...@apache.org> on 2023/09/15 09:29:00 UTC, 1 replies.
- [jira] [Resolved] (HTTPCLIENT-2292) SOCKS proxy configuration is not working - posted by "Oleg Kalnichevski (Jira)" <ji...@apache.org> on 2023/09/15 09:38:00 UTC, 0 replies.
- [GitHub] [httpcomponents-client] arturobernalg commented on a diff in pull request #482: HTTPCLIENT-2293 Enforce Port Specification for CONNECT Request - posted by "arturobernalg (via GitHub)" <gi...@apache.org> on 2023/09/15 10:50:22 UTC, 0 replies.
- [jira] [Commented] (HTTPCORE-754) StrictConnPool unable to acquire lock under multi threaded application causing DeadlineTimeoutException exception being thrown - posted by "ASF subversion and git services (Jira)" <ji...@apache.org> on 2023/09/15 13:31:00 UTC, 3 replies.
- [jira] [Commented] (HTTPCORE-747) Some flaky tests - posted by "ASF subversion and git services (Jira)" <ji...@apache.org> on 2023/09/15 13:31:00 UTC, 1 replies.
- [jira] [Commented] (HTTPCORE-753) race condition with CapacityWindow resulting in CancelKeyException - posted by "ASF subversion and git services (Jira)" <ji...@apache.org> on 2023/09/15 13:31:00 UTC, 1 replies.
- [GitHub] [httpcomponents-client] arturobernalg merged pull request #482: HTTPCLIENT-2293 Enforce Port Specification for CONNECT Request - posted by "arturobernalg (via GitHub)" <gi...@apache.org> on 2023/09/15 14:41:18 UTC, 0 replies.
- HttpCore 5.2.3 release notes - posted by Oleg Kalnichevski <ol...@apache.org> on 2023/09/16 09:10:14 UTC, 2 replies.
- [GitHub] [httpcomponents-core] arturobernalg opened a new pull request, #430: HTTPCORE-756 - Implement 'If-Range' request validation as per RFC 9110 - posted by "arturobernalg (via GitHub)" <gi...@apache.org> on 2023/09/16 20:41:40 UTC, 0 replies.
- [GitHub] [httpcomponents-client] ok2c merged pull request #483: HTTPCLIENT-2277: internal cache API and cache update redesign - posted by "ok2c (via GitHub)" <gi...@apache.org> on 2023/09/17 08:49:15 UTC, 0 replies.
- [VOTE] Release HttpCore 5.2.3 based on RC1 - posted by Oleg Kalnichevski <ol...@apache.org> on 2023/09/17 09:22:52 UTC, 4 replies.
- [GitHub] [httpcomponents-core] ok2c commented on pull request #430: HTTPCORE-756 - Implement 'If-Range' request validation as per RFC 9110 - posted by "ok2c (via GitHub)" <gi...@apache.org> on 2023/09/17 11:06:36 UTC, 0 replies.
- [GitHub] [httpcomponents-client] ok2c opened a new pull request, #484: HTTPCLIENT-2277: deprecation of obsolete config parameters and removal of oudated or meaningless tests - posted by "ok2c (via GitHub)" <gi...@apache.org> on 2023/09/17 12:52:18 UTC, 0 replies.
- [jira] [Comment Edited] (HTTPCLIENT-2277) HttpClient Cache conformance to RFC 9111 - posted by "Oleg Kalnichevski (Jira)" <ji...@apache.org> on 2023/09/18 08:24:00 UTC, 9 replies.
- [jira] [Created] (HTTPCLIENT-2298) Requests reported as pending longer than expected - posted by "Kristijan Postolov (Jira)" <ji...@apache.org> on 2023/09/18 12:07:00 UTC, 0 replies.
- [GitHub] [httpcomponents-core] arturobernalg commented on pull request #428: Add validation for :path pseudo-header in HTTP/2 requests RFC7540 - posted by "arturobernalg (via GitHub)" <gi...@apache.org> on 2023/09/18 18:23:10 UTC, 0 replies.
- [GitHub] [httpcomponents-core] arturobernalg commented on a diff in pull request #428: Add validation for :path pseudo-header in HTTP/2 requests RFC7540 - posted by "arturobernalg (via GitHub)" <gi...@apache.org> on 2023/09/19 19:03:07 UTC, 0 replies.
- [GitHub] [httpcomponents-core] arturobernalg commented on pull request #430: HTTPCORE-756 - Implement 'If-Range' request validation as per RFC 9110 - posted by "arturobernalg (via GitHub)" <gi...@apache.org> on 2023/09/19 19:10:49 UTC, 0 replies.
- [GitHub] [httpcomponents-core] arturobernalg closed pull request #430: HTTPCORE-756 - Implement 'If-Range' request validation as per RFC 9110 - posted by "arturobernalg (via GitHub)" <gi...@apache.org> on 2023/09/19 19:10:49 UTC, 0 replies.
- [GitHub] [httpcomponents-client] arturobernalg commented on a diff in pull request #484: HTTPCLIENT-2277: deprecation of obsolete config parameters and removal of oudated or meaningless tests - posted by "arturobernalg (via GitHub)" <gi...@apache.org> on 2023/09/19 19:25:24 UTC, 1 replies.
- [GitHub] [httpcomponents-client] ok2c commented on a diff in pull request #484: HTTPCLIENT-2277: deprecation of obsolete config parameters and removal of oudated or meaningless tests - posted by "ok2c (via GitHub)" <gi...@apache.org> on 2023/09/19 20:13:53 UTC, 0 replies.
- [jira] [Created] (HTTPCLIENT-2299) The socketTimeout parameter in ConnectionConfig does not take effect when reusing an existing connection. - posted by "ksewen (Jira)" <ji...@apache.org> on 2023/09/20 06:26:00 UTC, 0 replies.
- [VOTE][RESULT] Release HttpComponents HttpCore 5.2.3 based on RC1 - posted by Oleg Kalnichevski <ol...@apache.org> on 2023/09/20 07:40:41 UTC, 0 replies.
- [GitHub] [httpcomponents-core] arturobernalg merged pull request #428: Add validation for :path pseudo-header in HTTP/2 requests RFC7540 - posted by "arturobernalg (via GitHub)" <gi...@apache.org> on 2023/09/20 16:37:50 UTC, 0 replies.
- [GitHub] [httpcomponents-client] arturobernalg opened a new pull request, #485: HTTPCLIENT-2293 - Implement 'If-Range' request validation as per RFC9110 - posted by "arturobernalg (via GitHub)" <gi...@apache.org> on 2023/09/20 18:10:37 UTC, 0 replies.
- [GitHub] [httpcomponents-client] arturobernalg commented on pull request #485: HTTPCLIENT-2293 - Implement 'If-Range' request validation as per RFC9110 - posted by "arturobernalg (via GitHub)" <gi...@apache.org> on 2023/09/20 18:12:52 UTC, 0 replies.
- [GitHub] [httpcomponents-client] arturobernalg opened a new pull request, #486: HTTPCLIENT-2293 - Implement RFC-compliant TRACE request interceptor - posted by "arturobernalg (via GitHub)" <gi...@apache.org> on 2023/09/20 20:31:39 UTC, 0 replies.
- [GitHub] [httpcomponents-client] arturobernalg commented on pull request #486: HTTPCLIENT-2293 - Implement RFC-compliant TRACE request interceptor - posted by "arturobernalg (via GitHub)" <gi...@apache.org> on 2023/09/20 20:31:58 UTC, 0 replies.
- [GitHub] [httpcomponents-client] arturobernalg merged pull request #484: HTTPCLIENT-2277: deprecation of obsolete config parameters and removal of oudated or meaningless tests - posted by "arturobernalg (via GitHub)" <gi...@apache.org> on 2023/09/21 17:28:40 UTC, 0 replies.
- [jira] [Resolved] (HTTPCLIENT-2297) Documenting HttpClient 4.x status - posted by "Arturo Bernal (Jira)" <ji...@apache.org> on 2023/09/21 18:52:00 UTC, 0 replies.
- [jira] [Updated] (HTTPCLIENT-2297) Documenting HttpClient 4.x status - posted by "Arturo Bernal (Jira)" <ji...@apache.org> on 2023/09/21 19:07:00 UTC, 2 replies.
- [GitHub] [httpcomponents-core] ok2c opened a new pull request, #431: HTTP message support improvements - posted by "ok2c (via GitHub)" <gi...@apache.org> on 2023/09/22 07:33:18 UTC, 0 replies.
- [GitHub] [httpcomponents-core] ok2c commented on pull request #431: HTTP message support improvements - posted by "ok2c (via GitHub)" <gi...@apache.org> on 2023/09/22 07:33:46 UTC, 0 replies.
- [jira] [Updated] (HTTPCLIENT-2299) The socketTimeout parameter in ConnectionConfig does not take effect when reusing an existing connection. - posted by "Oleg Kalnichevski (Jira)" <ji...@apache.org> on 2023/09/22 13:39:00 UTC, 0 replies.
- [jira] [Commented] (HTTPCLIENT-2299) The socketTimeout parameter in ConnectionConfig does not take effect when reusing an existing connection. - posted by "ASF subversion and git services (Jira)" <ji...@apache.org> on 2023/09/22 13:45:00 UTC, 5 replies.
- [GitHub] [httpcomponents-client] dependabot[bot] opened a new pull request, #487: Bump httpcore.version from 5.2.2 to 5.2.3 - posted by "dependabot[bot] (via GitHub)" <gi...@apache.org> on 2023/09/22 13:47:49 UTC, 0 replies.
- [GitHub] [httpcomponents-client] ok2c commented on a diff in pull request #486: HTTPCLIENT-2293 - Implement RFC-compliant TRACE request interceptor - posted by "ok2c (via GitHub)" <gi...@apache.org> on 2023/09/22 13:57:16 UTC, 0 replies.
- [GitHub] [httpcomponents-client] arturobernalg commented on a diff in pull request #486: HTTPCLIENT-2293 - Implement RFC-compliant TRACE request interceptor - posted by "arturobernalg (via GitHub)" <gi...@apache.org> on 2023/09/22 17:00:08 UTC, 0 replies.
- [GitHub] [httpcomponents-core] arturobernalg commented on a diff in pull request #431: HTTP message support improvements - posted by "arturobernalg (via GitHub)" <gi...@apache.org> on 2023/09/22 20:13:34 UTC, 0 replies.
- [jira] [Created] (HTTPCLIENT-2300) AbstractCharDataConsumer throws java.nio.charset.MalformedInputException for an URI that SimpleResponseConsumer can handle - posted by "Michael Lee (Jira)" <ji...@apache.org> on 2023/09/23 05:52:00 UTC, 0 replies.
- [GitHub] [httpcomponents-core] ok2c commented on a diff in pull request #431: HTTP message support improvements - posted by "ok2c (via GitHub)" <gi...@apache.org> on 2023/09/23 08:47:57 UTC, 0 replies.
- [GitHub] [httpcomponents-core] ok2c merged pull request #431: HTTP message support improvements - posted by "ok2c (via GitHub)" <gi...@apache.org> on 2023/09/23 08:53:13 UTC, 0 replies.
- [jira] [Resolved] (HTTPCLIENT-2299) The socketTimeout parameter in ConnectionConfig does not take effect when reusing an existing connection. - posted by "Oleg Kalnichevski (Jira)" <ji...@apache.org> on 2023/09/23 09:06:00 UTC, 0 replies.
- [jira] [Commented] (HTTPCLIENT-2300) AbstractCharDataConsumer throws java.nio.charset.MalformedInputException for an URI that SimpleResponseConsumer can handle - posted by "Oleg Kalnichevski (Jira)" <ji...@apache.org> on 2023/09/23 09:13:00 UTC, 12 replies.
- [jira] [Resolved] (HTTPCLIENT-2294) Link to "Multiplexed HTTP/2 exchanges" broken in HttpClient Examples (Async) - posted by "Oleg Kalnichevski (Jira)" <ji...@apache.org> on 2023/09/23 09:24:00 UTC, 0 replies.
- [GitHub] [httpcomponents-client] arturobernalg merged pull request #485: HTTPCLIENT-2293 - Implement 'If-Range' request validation as per RFC9110 - posted by "arturobernalg (via GitHub)" <gi...@apache.org> on 2023/09/23 14:07:44 UTC, 0 replies.
- [GitHub] [httpcomponents-client] arturobernalg merged pull request #486: HTTPCLIENT-2293 - Implement RFC-compliant TRACE request interceptor - posted by "arturobernalg (via GitHub)" <gi...@apache.org> on 2023/09/23 18:52:03 UTC, 0 replies.
- [jira] [Updated] (HTTPCLIENT-2300) AbstractCharDataConsumer throws java.nio.charset.MalformedInputException for an URI that SimpleResponseConsumer can handle - posted by "Oleg Kalnichevski (Jira)" <ji...@apache.org> on 2023/09/24 07:47:00 UTC, 1 replies.
- [jira] [Commented] (HTTPCLIENT-2298) Requests reported as pending longer than expected - posted by "Oleg Kalnichevski (Jira)" <ji...@apache.org> on 2023/09/24 09:01:00 UTC, 2 replies.
- [jira] [Updated] (HTTPCORE-758) Requests stuck in IOReactor queue due to fatal exceptions while creating IO dispatchers - posted by "Karthik Bandi (Jira)" <ji...@apache.org> on 2023/09/25 05:09:00 UTC, 4 replies.
- [jira] [Created] (HTTPCORE-758) Requests stuck in IOReactor queue due to fatal exceptions while creating IO dispatchers - posted by "Karthik Bandi (Jira)" <ji...@apache.org> on 2023/09/25 05:09:00 UTC, 0 replies.
- [jira] [Commented] (HTTPCORE-758) Requests stuck in IOReactor queue due to fatal exceptions while creating IO dispatchers - posted by "Karthik Bandi (Jira)" <ji...@apache.org> on 2023/09/25 05:17:00 UTC, 7 replies.
- [jira] [Comment Edited] (HTTPCORE-758) Requests stuck in IOReactor queue due to fatal exceptions while creating IO dispatchers - posted by "Karthik Bandi (Jira)" <ji...@apache.org> on 2023/09/25 05:21:00 UTC, 0 replies.
- [jira] [Resolved] (HTTPCORE-758) Requests stuck in IOReactor queue due to fatal exceptions while creating IO dispatchers - posted by "Oleg Kalnichevski (Jira)" <ji...@apache.org> on 2023/09/25 06:40:00 UTC, 0 replies.
- [GitHub] [httpcomponents-core] karthik-119 opened a new pull request, #432: Fix exception handling when creating IO Dispatchers - posted by "karthik-119 (via GitHub)" <gi...@apache.org> on 2023/09/25 09:30:35 UTC, 0 replies.
- [GitHub] [httpcomponents-core] ok2c merged pull request #432: Fix exception handling when creating IO Dispatchers - posted by "ok2c (via GitHub)" <gi...@apache.org> on 2023/09/25 09:59:23 UTC, 0 replies.
- [ANNOUNCEMENT] HttpComponents Core 5.2.3 GA released - posted by Oleg Kalnichevski <ol...@apache.org> on 2023/09/25 10:11:40 UTC, 0 replies.
- [jira] [Closed] (HTTPCORE-758) Requests stuck in IOReactor queue due to fatal exceptions while creating IO dispatchers - posted by "Karthik Bandi (Jira)" <ji...@apache.org> on 2023/09/25 11:08:00 UTC, 0 replies.
- [GitHub] [httpcomponents-client] snehanie opened a new pull request, #488: Update MemcachedHttpCacheStorage.java - posted by "snehanie (via GitHub)" <gi...@apache.org> on 2023/09/25 21:29:36 UTC, 0 replies.
- [GitHub] [httpcomponents-core] karthik-119 opened a new pull request, #433: HTTPCORE-758-Fix exception handling when creating IO Dispatchers - posted by "karthik-119 (via GitHub)" <gi...@apache.org> on 2023/09/26 06:18:35 UTC, 0 replies.
- [GitHub] [httpcomponents-core] ok2c closed pull request #433: HTTPCORE-758-Fix exception handling when creating IO Dispatchers - posted by "ok2c (via GitHub)" <gi...@apache.org> on 2023/09/26 14:06:44 UTC, 0 replies.
- [GitHub] [httpcomponents-core] ok2c commented on pull request #433: HTTPCORE-758-Fix exception handling when creating IO Dispatchers - posted by "ok2c (via GitHub)" <gi...@apache.org> on 2023/09/26 14:06:44 UTC, 0 replies.
- [jira] [Resolved] (HTTPCLIENT-2300) AbstractCharDataConsumer throws java.nio.charset.MalformedInputException for an URI that SimpleResponseConsumer can handle - posted by "Oleg Kalnichevski (Jira)" <ji...@apache.org> on 2023/09/26 14:47:00 UTC, 0 replies.
- [GitHub] [httpcomponents-client] arturobernalg commented on pull request #488: Update MemcachedHttpCacheStorage.java - posted by "arturobernalg (via GitHub)" <gi...@apache.org> on 2023/09/26 16:58:41 UTC, 0 replies.
- [GitHub] [httpcomponents-client] ok2c commented on pull request #487: Bump httpcore.version from 5.2.2 to 5.2.3 - posted by "ok2c (via GitHub)" <gi...@apache.org> on 2023/09/27 13:50:37 UTC, 0 replies.
- [GitHub] [httpcomponents-client] dependabot[bot] commented on pull request #487: Bump httpcore.version from 5.2.2 to 5.2.3 - posted by "dependabot[bot] (via GitHub)" <gi...@apache.org> on 2023/09/27 13:52:11 UTC, 0 replies.
- [GitHub] [httpcomponents-client] dependabot[bot] closed pull request #487: Bump httpcore.version from 5.2.2 to 5.2.3 - posted by "dependabot[bot] (via GitHub)" <gi...@apache.org> on 2023/09/27 13:52:14 UTC, 0 replies.
- [GitHub] [httpcomponents-client] arturobernalg opened a new pull request, #489: HTTPCLIENT-2293: Disallow Automatic Retries on 403 Forbidden Status in HttpRequestRetryExec - posted by "arturobernalg (via GitHub)" <gi...@apache.org> on 2023/09/27 20:54:35 UTC, 0 replies.
- [GitHub] [httpcomponents-client] arturobernalg commented on pull request #489: HTTPCLIENT-2293: Disallow Automatic Retries on 403 Forbidden Status - posted by "arturobernalg (via GitHub)" <gi...@apache.org> on 2023/09/27 21:45:54 UTC, 1 replies.
- [GitHub] [httpcomponents-client] ok2c commented on pull request #489: HTTPCLIENT-2293: Disallow Automatic Retries on 403 Forbidden Status - posted by "ok2c (via GitHub)" <gi...@apache.org> on 2023/09/28 07:52:16 UTC, 0 replies.
- [jira] [Created] (HTTPCLIENT-2301) BasicHttpClientConnectionManager returns response of previous requests - posted by "Pierre N. (Jira)" <ji...@apache.org> on 2023/09/28 09:56:00 UTC, 0 replies.
- [jira] [Updated] (HTTPCLIENT-2301) BasicHttpClientConnectionManager returns response of previous requests - posted by "Pierre N. (Jira)" <ji...@apache.org> on 2023/09/28 09:58:00 UTC, 5 replies.
- [GitHub] [httpcomponents-core] ok2c opened a new pull request, #434: HTTPCORE-756: server-side request / response protocol conformance checks - posted by "ok2c (via GitHub)" <gi...@apache.org> on 2023/09/28 14:18:36 UTC, 0 replies.
- [GitHub] [httpcomponents-core] ok2c commented on pull request #434: HTTPCORE-756: server-side request / response protocol conformance checks - posted by "ok2c (via GitHub)" <gi...@apache.org> on 2023/09/28 14:18:56 UTC, 0 replies.
- [jira] [Commented] (HTTPCLIENT-2301) BasicHttpClientConnectionManager returns response of previous requests - posted by "Oleg Kalnichevski (Jira)" <ji...@apache.org> on 2023/09/28 14:29:00 UTC, 1 replies.
- [jira] [Comment Edited] (HTTPCLIENT-2301) BasicHttpClientConnectionManager returns response of previous requests - posted by "Pierre N. (Jira)" <ji...@apache.org> on 2023/09/28 15:01:00 UTC, 2 replies.
- [GitHub] [httpcomponents-client] arturobernalg closed pull request #489: HTTPCLIENT-2293: Disallow Automatic Retries on 403 Forbidden Status - posted by "arturobernalg (via GitHub)" <gi...@apache.org> on 2023/09/28 18:53:49 UTC, 0 replies.
- [jira] [Created] (HTTPCORE-759) Content-Length missing on null entity request content - posted by "Billy Jaime Beltran (Jira)" <ji...@apache.org> on 2023/09/29 09:34:00 UTC, 0 replies.
- [jira] [Updated] (HTTPCORE-759) Content-Length missing on null entity request content - posted by "Billy Jaime Beltran (Jira)" <ji...@apache.org> on 2023/09/29 09:35:00 UTC, 0 replies.
- [jira] [Commented] (HTTPCORE-759) Content-Length missing on null entity request content - posted by "Michael Osipov (Jira)" <ji...@apache.org> on 2023/09/29 11:12:00 UTC, 5 replies.
- [GitHub] [httpcomponents-core] chrysophylax opened a new pull request, #435: HTTPCORE-759 Content-Length missing on null entity request content - posted by "chrysophylax (via GitHub)" <gi...@apache.org> on 2023/09/29 11:33:23 UTC, 0 replies.
- [jira] [Comment Edited] (HTTPCORE-759) Content-Length missing on null entity request content - posted by "Arturo Bernal (Jira)" <ji...@apache.org> on 2023/09/29 11:36:00 UTC, 1 replies.
- [GitHub] [httpcomponents-core] ok2c commented on a diff in pull request #435: HTTPCORE-759 Content-Length missing on null entity request content - posted by "ok2c (via GitHub)" <gi...@apache.org> on 2023/09/29 11:36:57 UTC, 3 replies.
- [GitHub] [httpcomponents-core] ok2c commented on pull request #435: HTTPCORE-759 Content-Length missing on null entity request content - posted by "ok2c (via GitHub)" <gi...@apache.org> on 2023/09/29 11:38:44 UTC, 0 replies.
- [GitHub] [httpcomponents-core] reschke commented on a diff in pull request #435: HTTPCORE-759 Content-Length missing on null entity request content - posted by "reschke (via GitHub)" <gi...@apache.org> on 2023/09/29 11:42:23 UTC, 2 replies.
- [GitHub] [httpcomponents-core] chrysophylax commented on a diff in pull request #435: HTTPCORE-759 Content-Length missing on null entity request content - posted by "chrysophylax (via GitHub)" <gi...@apache.org> on 2023/09/29 11:45:58 UTC, 1 replies.
- [GitHub] [httpcomponents-core] chrysophylax commented on pull request #435: HTTPCORE-759 Content-Length missing on null entity request content - posted by "chrysophylax (via GitHub)" <gi...@apache.org> on 2023/09/29 12:51:09 UTC, 0 replies.
- [GitHub] [httpcomponents-core] ok2c merged pull request #435: HTTPCORE-759 Content-Length missing on null entity request content - posted by "ok2c (via GitHub)" <gi...@apache.org> on 2023/09/29 13:21:29 UTC, 0 replies.
- [jira] [Resolved] (HTTPCORE-759) Content-Length missing on null entity request content - posted by "Oleg Kalnichevski (Jira)" <ji...@apache.org> on 2023/09/29 13:23:00 UTC, 0 replies.
- [GitHub] [httpcomponents-client] ok2c closed pull request #488: Update MemcachedHttpCacheStorage.java - posted by "ok2c (via GitHub)" <gi...@apache.org> on 2023/09/29 13:27:35 UTC, 0 replies.
- [GitHub] [httpcomponents-client] ok2c commented on pull request #488: Update MemcachedHttpCacheStorage.java - posted by "ok2c (via GitHub)" <gi...@apache.org> on 2023/09/29 13:27:35 UTC, 0 replies.
- [GitHub] [httpcomponents-core] dependabot[bot] opened a new pull request, #436: Bump io.reactivex.rxjava3:rxjava from 3.1.6 to 3.1.8 - posted by "dependabot[bot] (via GitHub)" <gi...@apache.org> on 2023/09/29 14:37:44 UTC, 0 replies.
- [GitHub] [httpcomponents-core] dependabot[bot] commented on pull request #420: Bump io.reactivex.rxjava3:rxjava from 3.1.6 to 3.1.7 - posted by "dependabot[bot] (via GitHub)" <gi...@apache.org> on 2023/09/29 14:37:47 UTC, 0 replies.
- [GitHub] [httpcomponents-core] dependabot[bot] closed pull request #420: Bump io.reactivex.rxjava3:rxjava from 3.1.6 to 3.1.7 - posted by "dependabot[bot] (via GitHub)" <gi...@apache.org> on 2023/09/29 14:37:48 UTC, 0 replies.
- [GitHub] [httpcomponents-client] snehanie commented on pull request #488: Update MemcachedHttpCacheStorage.java - posted by "snehanie (via GitHub)" <gi...@apache.org> on 2023/09/29 16:02:52 UTC, 0 replies.
- [GitHub] [httpcomponents-core] arturobernalg merged pull request #434: HTTPCORE-756: server-side request / response protocol conformance checks - posted by "arturobernalg (via GitHub)" <gi...@apache.org> on 2023/09/30 20:14:15 UTC, 0 replies.