You are viewing a plain text version of this content. The canonical link for it is here.
- Re: [PR] Bump the all group with 2 updates [httpcomponents-client] - posted by "dependabot[bot] (via GitHub)" <gi...@apache.org> on 2026/09/01 13:52:43 UTC, 1 replies.
- [PR] Bump the all group across 1 directory with 11 updates [httpcomponents-client] - posted by "dependabot[bot] (via GitHub)" <gi...@apache.org> on 2026/09/01 13:53:07 UTC, 0 replies.
- [PR] Bump actions/setup-java from 5 to 6 [httpcomponents-core] - posted by "dependabot[bot] (via GitHub)" <gi...@apache.org> on 2026/09/01 14:33:04 UTC, 1 replies.
- [PR] RFC 9651: Structured Field Values for HTTP [httpcomponents-core] - posted by "arturobernalg (via GitHub)" <gi...@apache.org> on 2026/09/03 16:25:19 UTC, 18 replies.
- Re: [PR] Add support for Compression Dictionary Transport (RFC 9842) [httpcomponents-client] - posted by "ok2c (via GitHub)" <gi...@apache.org> on 2026/09/04 08:24:02 UTC, 8 replies.
- [PR] Header iterator memory optimization in HeaderGroup [httpcomponents-core] - posted by "ok2c (via GitHub)" <gi...@apache.org> on 2026/09/04 17:40:02 UTC, 5 replies.
- [PR] RFC 8336: the ORIGIN HTTP/2 frame [httpcomponents-core] - posted by "arturobernalg (via GitHub)" <gi...@apache.org> on 2026/09/07 16:47:46 UTC, 0 replies.
- Re: [PR] HTTP/2: Implement ORIGIN frame (RFC 8336) and enforce Origin Set [httpcomponents-core] - posted by "arturobernalg (via GitHub)" <gi...@apache.org> on 2026/09/07 16:48:38 UTC, 0 replies.
- Re: v4.4 affected by CVE-2026-54399? - posted by Billy McCarthy via dev <de...@hc.apache.org> on 2026/09/08 10:56:47 UTC, 2 replies.
- [PR] Fix URIBuilder encoding policy documentation and null reset [httpcomponents-core] - posted by "prafgup (via GitHub)" <gi...@apache.org> on 2026/09/11 23:34:41 UTC, 2 replies.
- [jira] [Created] (HTTPCLIENT-2432) Connection permanently marked leased when ResponseEntityProxy.cleanup() fails on a dead socket - posted by "Alekseev Victor (Jira)" <ji...@apache.org> on 2026/09/14 07:37:00 UTC, 0 replies.
- [jira] [Commented] (HTTPCLIENT-2432) Connection permanently marked leased when ResponseEntityProxy.cleanup() fails on a dead socket - posted by "Alekseev Victor (Jira)" <ji...@apache.org> on 2026/09/14 07:39:00 UTC, 6 replies.
- [jira] [Updated] (HTTPCLIENT-2432) Connection permanently marked leased when ResponseEntityProxy.cleanup() fails on a dead socket - posted by "Alekseev Victor (Jira)" <ji...@apache.org> on 2026/09/14 07:50:00 UTC, 1 replies.
- [PR] HTTPCLIENT-2432: fix connection-pool leak in ResponseEntityProxy.cleanup() when disconnectEndpoint() throws [httpcomponents-client] - posted by "krocodl (via GitHub)" <gi...@apache.org> on 2026/09/14 07:56:33 UTC, 4 replies.
- [jira] [Resolved] (HTTPCLIENT-2432) Connection permanently marked leased when ResponseEntityProxy.cleanup() fails on a dead socket - posted by "Alekseev Victor (Jira)" <ji...@apache.org> on 2026/09/14 08:04:00 UTC, 1 replies.
- [jira] [Reopened] (HTTPCLIENT-2432) Connection permanently marked leased when ResponseEntityProxy.cleanup() fails on a dead socket - posted by "Alekseev Victor (Jira)" <ji...@apache.org> on 2026/09/14 08:04:00 UTC, 0 replies.
- HttpCore 5.5-beta3 soon? - posted by Oleg Kalnichevski <ol...@apache.org> on 2026/09/16 17:06:44 UTC, 1 replies.
- [PR] RFC 9421: HTTP Message Signatures [httpcomponents-core] - posted by "arturobernalg (via GitHub)" <gi...@apache.org> on 2026/09/17 03:51:59 UTC, 1 replies.
- [jira] [Created] (HTTPCLIENT-2433) Async HTTP/2 authentication challenge replay corrupts repeatable FileEntityProducer request body - posted by "Matthias (Jira)" <ji...@apache.org> on 2026/09/17 09:46:00 UTC, 0 replies.
- [PR] HTTPCLIENT-2433: Prevent concurrent HTTP/2 request body replay [httpcomponents-client] - posted by "mkurz (via GitHub)" <gi...@apache.org> on 2026/09/17 11:56:12 UTC, 12 replies.
- [jira] [Created] (HTTPCORE-799) FileEntityProducer and PathEntityProducer retain stale buffered data after an interrupted write - posted by "Matthias (Jira)" <ji...@apache.org> on 2026/09/17 12:04:00 UTC, 0 replies.
- [PR] HTTPCORE-799: Reset async entity producer state after interrupted writes [httpcomponents-core] - posted by "mkurz (via GitHub)" <gi...@apache.org> on 2026/09/17 12:57:10 UTC, 3 replies.
- [jira] [Updated] (HTTPCORE-799) Async entity producers retain stale state after interrupted writes - posted by "Matthias (Jira)" <ji...@apache.org> on 2026/09/17 13:03:00 UTC, 2 replies.
- [jira] [Updated] (HTTPCLIENT-2433) Async HTTP/2 authentication challenge replay corrupts repeatable FileEntityProducer request body - posted by "Matthias (Jira)" <ji...@apache.org> on 2026/09/17 13:08:00 UTC, 1 replies.
- [jira] [Commented] (HTTPCORE-799) Async entity producers retain stale state after interrupted writes - posted by "ASF subversion and git services (Jira)" <ji...@apache.org> on 2026/09/17 13:23:00 UTC, 1 replies.
- [jira] [Resolved] (HTTPCORE-799) Async entity producers retain stale state after interrupted writes - posted by "Oleg Kalnichevski (Jira)" <ji...@apache.org> on 2026/09/17 13:31:00 UTC, 0 replies.
- [jira] [Created] (HTTPCLIENT-2434) Improve Idle connection management customization - posted by "Jacques-Etienne Beaudet (Jira)" <ji...@apache.org> on 2026/09/17 19:56:00 UTC, 0 replies.
- [jira] [Updated] (HTTPCLIENT-2434) Improve Idle connection management customization - posted by "Jacques-Etienne Beaudet (Jira)" <ji...@apache.org> on 2026/09/17 19:57:00 UTC, 1 replies.
- [PR] HTTPCLIENT-2434 - Improve idle connection eviction configuration. [httpcomponents-client] - posted by "arturobernalg (via GitHub)" <gi...@apache.org> on 2026/09/18 08:37:43 UTC, 4 replies.
- [jira] [Commented] (HTTPCLIENT-2434) Improve Idle connection management customization - posted by "Arturo Bernal (Jira)" <ji...@apache.org> on 2026/09/18 08:39:00 UTC, 9 replies.
- [jira] [Commented] (HTTPCLIENT-2433) Async HTTP/2 authentication challenge replay corrupts repeatable FileEntityProducer request body - posted by "ASF subversion and git services (Jira)" <ji...@apache.org> on 2026/09/18 09:42:00 UTC, 2 replies.
- [jira] [Resolved] (HTTPCLIENT-2433) Async HTTP/2 authentication challenge replay corrupts repeatable FileEntityProducer request body - posted by "Oleg Kalnichevski (Jira)" <ji...@apache.org> on 2026/09/18 14:55:00 UTC, 0 replies.
- [jira] [Created] (HTTPCORE-800) HttpException.clean() incorrectly handles/escapes control characters like newline - posted by "Revathy Ramalingam (Jira)" <ji...@apache.org> on 2026/09/19 09:12:00 UTC, 0 replies.
- [jira] [Updated] (HTTPCORE-800) HttpException.clean() incorrectly handles/escapes control characters like newline - posted by "Oleg Kalnichevski (Jira)" <ji...@apache.org> on 2026/09/19 09:26:00 UTC, 1 replies.
- [jira] [Commented] (HTTPCORE-800) HttpException.clean() incorrectly handles/escapes control characters like newline - posted by "Oleg Kalnichevski (Jira)" <ji...@apache.org> on 2026/09/19 09:27:00 UTC, 5 replies.
- [PR] Preserve idle timeout when copying connection configuration [httpcomponents-client] - posted by "arturobernalg (via GitHub)" <gi...@apache.org> on 2026/09/19 09:57:02 UTC, 1 replies.
- [PR] HTTPCORE-800: Fix hexadecimal encoding of control characters [httpcomponents-core] - posted by "arturobernalg (via GitHub)" <gi...@apache.org> on 2026/09/19 10:12:42 UTC, 2 replies.
- Re: [PR] RFC10015 support in TlsCiphers [httpcomponents-core] - posted by "ok2c (via GitHub)" <gi...@apache.org> on 2026/09/20 08:12:42 UTC, 0 replies.
- [jira] [Resolved] (HTTPCORE-800) HttpException.clean() incorrectly handles/escapes control characters like newline - posted by "Oleg Kalnichevski (Jira)" <ji...@apache.org> on 2026/09/20 08:18:00 UTC, 0 replies.
- HttpCore 5.4.4 release notes - posted by Oleg Kalnichevski <ol...@apache.org> on 2026/09/20 08:29:16 UTC, 1 replies.
- HttpCore 5.5-beta3 release notes - posted by Oleg Kalnichevski <ol...@apache.org> on 2026/09/20 09:14:07 UTC, 1 replies.
- [VOTE] Release HttpCore 5.4.4 based on RC1 - posted by Oleg Kalnichevski <ol...@apache.org> on 2026/09/20 19:52:57 UTC, 3 replies.
- [VOTE] Release HttpCore 5.5-beta3 based on RC1 - posted by Oleg Kalnichevski <ol...@apache.org> on 2026/09/20 20:55:10 UTC, 3 replies.
- Re: [PR] RFC 7639 ALPN [httpcomponents-client] - posted by "arturobernalg (via GitHub)" <gi...@apache.org> on 2026/09/21 12:02:45 UTC, 0 replies.
- Re: [PR] Bump actions/setup-java from 5 to 5.6.0 [httpcomponents-client] - posted by "ok2c (via GitHub)" <gi...@apache.org> on 2026/09/21 12:38:44 UTC, 0 replies.
- Re: [PR] HTTPCLIENT-2358 Implement a mutual authentication capable SPNEGO scheme [httpcomponents-client] - posted by "ok2c (via GitHub)" <gi...@apache.org> on 2026/09/21 12:39:41 UTC, 0 replies.
- [jira] [Commented] (HTTPCLIENT-2358) Implement a mutual authentication capable SPNEGO scheme - posted by "Oleg Kalnichevski (Jira)" <ji...@apache.org> on 2026/09/21 12:45:00 UTC, 0 replies.
- [jira] [Resolved] (HTTPCLIENT-2358) Implement a mutual authentication capable SPNEGO scheme - posted by "Oleg Kalnichevski (Jira)" <ji...@apache.org> on 2026/09/21 12:45:00 UTC, 0 replies.
- [jira] [Resolved] (HTTPCLIENT-2402) Handle SecurityManager removal - posted by "Oleg Kalnichevski (Jira)" <ji...@apache.org> on 2026/09/21 12:54:00 UTC, 0 replies.
- [jira] [Resolved] (HTTPCLIENT-2434) Improve Idle connection management customization - posted by "Arturo Bernal (Jira)" <ji...@apache.org> on 2026/09/21 13:32:00 UTC, 0 replies.
- [jira] [Closed] (HTTPCLIENT-2434) Improve Idle connection management customization - posted by "Arturo Bernal (Jira)" <ji...@apache.org> on 2026/09/21 13:32:00 UTC, 0 replies.
- [PR] Limit write chunk size in BasicAsyncEntityProducer [httpcomponents-core] - posted by "yhzdys (via GitHub)" <gi...@apache.org> on 2026/09/23 02:55:38 UTC, 4 replies.
- [PR] FC 9530 Digest Fields support [httpcomponents-core] - posted by "arturobernalg (via GitHub)" <gi...@apache.org> on 2026/09/23 18:53:14 UTC, 1 replies.
- [VOTE][RESULT] Release HttpCore 5.4.4 based on RC1 - posted by Oleg Kalnichevski <ol...@apache.org> on 2026/09/24 08:34:54 UTC, 0 replies.
- [VOTE][RESULT] Release HttpCore 5.5-beta3 based on RC1 - posted by Oleg Kalnichevski <ol...@apache.org> on 2026/09/24 08:35:54 UTC, 0 replies.
- Re: [PR] Bump org.apache.logging.log4j:log4j-core from 2.25.3 to 2.25.4 [httpcomponents-core] - posted by "ok2c (via GitHub)" <gi...@apache.org> on 2026/09/24 10:18:36 UTC, 0 replies.
- Re: [PR] Limit write chunk size in IOSessionImpl [httpcomponents-core] - posted by "yhzdys (via GitHub)" <gi...@apache.org> on 2026/09/24 10:47:29 UTC, 1 replies.
- [ANNOUNCEMENT] HttpComponents Core 5.4.4 GA released - posted by Oleg Kalnichevski <ol...@apache.org> on 2026/09/24 12:07:07 UTC, 0 replies.
- [ANNOUNCEMENT] HttpComponents Core 5.5-beta3 released - posted by Oleg Kalnichevski <ol...@apache.org> on 2026/09/24 12:12:35 UTC, 0 replies.
- [PR] Optimize HPACK Huffman decoding with a byte-oriented DFA. [httpcomponents-core] - posted by "arturobernalg (via GitHub)" <gi...@apache.org> on 2026/09/26 16:58:46 UTC, 1 replies.
- [VOTE][LAZY] Release HC Parent 15 based on RC1 - posted by Oleg Kalnichevski <ol...@apache.org> on 2026/09/27 08:46:30 UTC, 3 replies.
- [PR] Improve HPACK decoding conformance with RFC 9113 and RFC 7541. [httpcomponents-core] - posted by "arturobernalg (via GitHub)" <gi...@apache.org> on 2026/09/27 10:41:14 UTC, 1 replies.
- [PR] Fix HPACK encoder buffer expansion for multibyte values. [httpcomponents-core] - posted by "arturobernalg (via GitHub)" <gi...@apache.org> on 2026/09/28 11:15:31 UTC, 2 replies.
- [PR] Limit HPACK encoder table size [httpcomponents-core] - posted by "arturobernalg (via GitHub)" <gi...@apache.org> on 2026/09/28 11:53:32 UTC, 2 replies.
- [PR] Optimize HPACK full match lookup [httpcomponents-core] - posted by "arturobernalg (via GitHub)" <gi...@apache.org> on 2026/09/28 12:51:42 UTC, 3 replies.
- [PR] Optimize message list traversal [httpcomponents-core] - posted by "arturobernalg (via GitHub)" <gi...@apache.org> on 2026/09/29 04:08:10 UTC, 1 replies.
- [PR] Fix H2 stream flow control overflow [httpcomponents-core] - posted by "arturobernalg (via GitHub)" <gi...@apache.org> on 2026/09/29 11:04:31 UTC, 1 replies.
- [PR] Reject H2 DATA on reserved streams [httpcomponents-core] - posted by "arturobernalg (via GitHub)" <gi...@apache.org> on 2026/09/29 12:16:48 UTC, 2 replies.
- [PR] Send RST_STREAM for a cancelled half-closed stream [httpcomponents-core] - posted by "rp-arielrodriguez (via GitHub)" <gi...@apache.org> on 2026/09/29 18:51:33 UTC, 12 replies.
- [PR] Fail unprocessed local streams on GOAWAY [httpcomponents-core] - posted by "rp-arielrodriguez (via GitHub)" <gi...@apache.org> on 2026/09/29 22:13:02 UTC, 4 replies.
- [PR] Reject malformed HTTP/2 response headers [httpcomponents-core] - posted by "arturobernalg (via GitHub)" <gi...@apache.org> on 2026/09/30 10:07:00 UTC, 0 replies.
- [PR] Correct handling of unsigned HTTP/2 SETTINGS values [httpcomponents-core] - posted by "arturobernalg (via GitHub)" <gi...@apache.org> on 2026/09/30 12:15:18 UTC, 0 replies.
- [PR] HTTP/2: Correct pushed response message handling [httpcomponents-core] - posted by "arturobernalg (via GitHub)" <gi...@apache.org> on 2026/09/30 15:49:40 UTC, 0 replies.
- Re: [PR] Content compression executors no longer remove headers from the original response message [httpcomponents-client] - posted by "semyon-levin-workato (via GitHub)" <gi...@apache.org> on 2026/09/30 15:53:11 UTC, 2 replies.
- [PR] Improved handling of idle sessions by AbstractIOSessionPool / H2ConnPool [httpcomponents-core] - posted by "ok2c (via GitHub)" <gi...@apache.org> on 2026/09/30 17:01:59 UTC, 0 replies.