You are viewing a plain text version of this content. The canonical link for it is here.
- Re: HttpClient 5.7-alpha1 release notes - posted by Arturo Bernal <ab...@apache.org> on 2026/08/01 05:32:25 UTC, 1 replies.
- [PR] Mark the SSE and WebSocket modules as experimental [httpcomponents-client] - posted by "arturobernalg (via GitHub)" <gi...@apache.org> on 2026/08/01 09:40:14 UTC, 2 replies.
- [PR] Bump actions/setup-java from 5 to 5.6.0 [httpcomponents-client] - posted by "dependabot[bot] (via GitHub)" <gi...@apache.org> on 2026/08/01 13:22:27 UTC, 0 replies.
- [PR] Bump the all group with 2 updates [httpcomponents-client] - posted by "dependabot[bot] (via GitHub)" <gi...@apache.org> on 2026/08/01 13:23:01 UTC, 0 replies.
- [PR] Bump actions/checkout from 6 to 7 [httpcomponents-core] - posted by "dependabot[bot] (via GitHub)" <gi...@apache.org> on 2026/08/01 14:12:33 UTC, 1 replies.
- RFC 10015 Deprecating Obsolete Key Exchange Methods in TLS 1.2 and DTLS 1.2 - posted by Gary Gregory <ga...@gmail.com> on 2026/08/02 01:14:09 UTC, 4 replies.
- [PR] Add Java 25 (LTS) to GH CI builds. [httpcomponents-core] - posted by "garydgregory (via GitHub)" <gi...@apache.org> on 2026/08/02 12:54:24 UTC, 2 replies.
- Re: (httpcomponents-core) branch master updated: Tabs -> spaces (was not picked up by a local default Maven build). - posted by Oleg Kalnichevski <ol...@apache.org> on 2026/08/02 13:15:44 UTC, 2 replies.
- [VOTE] Release HttpClient 5.7-alpha1 based on RC1 - posted by Oleg Kalnichevski <ol...@apache.org> on 2026/08/02 13:54:21 UTC, 3 replies.
- [PR] RFC10015 support in TlsCiphers [httpcomponents-core] - posted by "garydgregory (via GitHub)" <gi...@apache.org> on 2026/08/02 14:45:09 UTC, 12 replies.
- Called off; Re: [VOTE] Release HttpClient 5.7-alpha1 based on RC1 - posted by Oleg Kalnichevski <ol...@apache.org> on 2026/08/03 07:25:26 UTC, 0 replies.
- [VOTE] Release HttpClient 5.7-alpha1 based on RC2 - posted by Oleg Kalnichevski <ol...@apache.org> on 2026/08/03 08:11:37 UTC, 2 replies.
- HttpClient 5.6.4 release notes - posted by Oleg Kalnichevski <ol...@apache.org> on 2026/08/06 08:33:50 UTC, 1 replies.
- [VOTE] Release HttpClient 5.6.4 based on RC1 - posted by Oleg Kalnichevski <ol...@apache.org> on 2026/08/06 12:31:05 UTC, 3 replies.
- Called off; Re: [VOTE] Release HttpClient 5.7-alpha1 based on RC2 - posted by Oleg Kalnichevski <ol...@apache.org> on 2026/08/07 08:20:07 UTC, 0 replies.
- [VOTE] Release HttpClient 5.7-alpha1 based on RC3 - posted by Oleg Kalnichevski <ol...@apache.org> on 2026/08/07 08:41:49 UTC, 5 replies.
- CVE-2026-64607 announced? - posted by Gary Gregory <ga...@gmail.com> on 2026/08/07 15:31:28 UTC, 1 replies.
- [VOTE][RESULT] Release HttpComponents HttpClient 5.6.4 based on RC1 - posted by Oleg Kalnichevski <ol...@apache.org> on 2026/08/09 09:08:48 UTC, 0 replies.
- [ANNOUNCEMENT] HttpComponents Client 5.6.4 Released - posted by Oleg Kalnichevski <ol...@apache.org> on 2026/08/10 10:13:03 UTC, 0 replies.
- Re: [PR] Add pooled ByteBuffer allocator with size classes [httpcomponents-core] - posted by "arturobernalg (via GitHub)" <gi...@apache.org> on 2026/08/11 09:24:58 UTC, 1 replies.
- [PR] Increase default HTTP/1.1 buffer size to 32 KiB [httpcomponents-core] - posted by "arturobernalg (via GitHub)" <gi...@apache.org> on 2026/08/11 12:09:44 UTC, 5 replies.
- [PR] RFC 9211: optional Cache-Status response header [httpcomponents-client] - posted by "arturobernalg (via GitHub)" <gi...@apache.org> on 2026/08/11 18:50:32 UTC, 6 replies.
- Re: [PR] Upgrade Conscrypt [httpcomponents-core] - posted by "rschmitt (via GitHub)" <gi...@apache.org> on 2026/08/11 19:13:44 UTC, 0 replies.
- [PR] Use simplified toString() implementation to avoid possible deadlocks [httpcomponents-core] - posted by "turbanoff (via GitHub)" <gi...@apache.org> on 2026/08/12 11:28:06 UTC, 1 replies.
- [PR] Honor qualified Cache-Control: private="field" in a shared cache (RFC9111 section 5.2.2.7) [httpcomponents-client] - posted by "arturobernalg (via GitHub)" <gi...@apache.org> on 2026/08/12 15:12:29 UTC, 7 replies.
- [PR] RFC 6265bis compliance for the cookie implementation [httpcomponents-client] - posted by "arturobernalg (via GitHub)" <gi...@apache.org> on 2026/08/13 07:13:16 UTC, 6 replies.
- CVE-2026-64607: Apache HttpComponents Client: Connection Leak on Content-Encoding Decode Error Leads to Pool Exhaustion DoS - posted by Oleg Kalnichevski <ol...@apache.org> on 2026/08/13 08:52:34 UTC, 0 replies.
- CVE-2026-71290: Apache HttpComponents Client: TLS hostname verification silently disabled on the async transport (default config, MITM) - posted by Oleg Kalnichevski <ol...@apache.org> on 2026/08/13 08:56:11 UTC, 0 replies.
- [VOTE][RESULT] Release HttpComponents HttpClient 5.7-alpha1 based on RC3 - posted by Oleg Kalnichevski <ol...@apache.org> on 2026/08/13 09:04:06 UTC, 0 replies.
- Release post-mortem; Re: [VOTE] Release HttpClient 5.7-alpha1 based on RC3 - posted by Oleg Kalnichevski <ol...@apache.org> on 2026/08/13 09:57:47 UTC, 0 replies.
- [PR] Deprecate the never-cache-responses-with-query options and HTTP/1.0 r… [httpcomponents-client] - posted by "arturobernalg (via GitHub)" <gi...@apache.org> on 2026/08/13 18:45:07 UTC, 0 replies.
- [PR] Fix resource leaking on error in AsyncCachingExec [httpcomponents-client] - posted by "Jouramie (via GitHub)" <gi...@apache.org> on 2026/08/13 18:57:48 UTC, 2 replies.
- [jira] [Created] (HTTPCORE-797) Possible infloop in SSLContexts.createDefault() - posted by "Filipp Gunbin (Jira)" <ji...@apache.org> on 2026/08/13 19:43:00 UTC, 0 replies.
- [jira] [Commented] (HTTPCORE-797) Possible infloop in SSLContexts.createDefault() - posted by "ASF subversion and git services (Jira)" <ji...@apache.org> on 2026/08/14 09:06:00 UTC, 1 replies.
- [jira] [Updated] (HTTPCORE-797) Possible infloop in SSLContexts.createDefault() - posted by "Oleg Kalnichevski (Jira)" <ji...@apache.org> on 2026/08/14 09:08:00 UTC, 0 replies.
- [jira] [Resolved] (HTTPCORE-797) Possible infloop in SSLContexts.createDefault() - posted by "Oleg Kalnichevski (Jira)" <ji...@apache.org> on 2026/08/14 09:08:00 UTC, 0 replies.
- Re: [PR] Deprecate the never-cache-responses-with-query options and HTTP/1.0 response caching [httpcomponents-client] - posted by "ok2c (via GitHub)" <gi...@apache.org> on 2026/08/14 09:33:58 UTC, 5 replies.
- [PR] Verify the server authentication (rspauth) provided in the Digest Authentication-Info response per RFC 7616 [httpcomponents-client] - posted by "arturobernalg (via GitHub)" <gi...@apache.org> on 2026/08/14 10:28:21 UTC, 3 replies.
- Re: [PR] RFC 7639 ALPN [httpcomponents-client] - posted by "ok2c (via GitHub)" <gi...@apache.org> on 2026/08/14 11:30:51 UTC, 1 replies.
- [PR] Add WebSocket RFCs to the standards compliance list [httpcomponents-client] - posted by "arturobernalg (via GitHub)" <gi...@apache.org> on 2026/08/15 09:51:22 UTC, 1 replies.
- [PR] Add a model and parser for the RFC 9209 Proxy-Status response field [httpcomponents-core] - posted by "arturobernalg (via GitHub)" <gi...@apache.org> on 2026/08/15 16:47:06 UTC, 6 replies.
- [PR] treat malformed s-maxage as absent in shared-cache auth check [httpcomponents-client] - posted by "dxbjavid (via GitHub)" <gi...@apache.org> on 2026/08/16 19:10:26 UTC, 8 replies.
- [ANNOUNCEMENT] HttpComponents Client 5.7-alpha1 Released - posted by Oleg Kalnichevski <ol...@apache.org> on 2026/08/17 12:41:16 UTC, 0 replies.
- [PR] Add a model and parser for the RFC 9209 Proxy-Status response field [httpcomponents-client] - posted by "arturobernalg (via GitHub)" <gi...@apache.org> on 2026/08/18 17:11:01 UTC, 2 replies.
- [PR] decode punycode public suffixes in PublicSuffixMatcher.verify [httpcomponents-client] - posted by "dxbjavid (via GitHub)" <gi...@apache.org> on 2026/08/19 17:54:22 UTC, 8 replies.
- [jira] [Created] (HTTPCLIENT-2429) Improve support for custom transport layers - posted by "Arturo Bernal (Jira)" <ji...@apache.org> on 2026/08/20 12:33:00 UTC, 0 replies.
- [jira] [Created] (HTTPCLIENT-2430) Brotli decompression fails for large payloads - posted by "Jonny Carter (Jira)" <ji...@apache.org> on 2026/08/21 05:16:00 UTC, 0 replies.
- [PR] Fix Brotli decompression hang with large input buffers [httpcomponents-client] - posted by "arturobernalg (via GitHub)" <gi...@apache.org> on 2026/08/21 06:48:09 UTC, 3 replies.
- [jira] [Commented] (HTTPCLIENT-2430) Brotli decompression fails for large payloads - posted by "Arturo Bernal (Jira)" <ji...@apache.org> on 2026/08/21 06:49:00 UTC, 3 replies.
- [jira] [Assigned] (HTTPCLIENT-2430) Brotli decompression fails for large payloads - posted by "Arturo Bernal (Jira)" <ji...@apache.org> on 2026/08/21 07:15:00 UTC, 0 replies.
- [jira] [Updated] (HTTPCLIENT-2430) Brotli decompression fails for large payloads - posted by "Arturo Bernal (Jira)" <ji...@apache.org> on 2026/08/21 07:15:00 UTC, 0 replies.
- [jira] [Created] (HTTPCLIENT-2431) Add support for Compression Dictionary Transport (RFC 9842) - posted by "Arturo Bernal (Jira)" <ji...@apache.org> on 2026/08/21 07:37:00 UTC, 0 replies.
- [jira] [Assigned] (HTTPCLIENT-2431) Add support for Compression Dictionary Transport (RFC 9842) - posted by "Arturo Bernal (Jira)" <ji...@apache.org> on 2026/08/21 11:28:00 UTC, 0 replies.
- [jira] [Comment Edited] (HTTPCLIENT-2430) Brotli decompression fails for large payloads - posted by "Jonny Carter (Jira)" <ji...@apache.org> on 2026/08/21 16:54:00 UTC, 0 replies.
- [PR] dd support for Compression Dictionary Transport (RFC 9842) [httpcomponents-client] - posted by "arturobernalg (via GitHub)" <gi...@apache.org> on 2026/08/21 18:01:54 UTC, 1 replies.
- [PR] Use Brotli4jLoader.isAvailable() instead of relying on class presence. [httpcomponents-client] - posted by "arturobernalg (via GitHub)" <gi...@apache.org> on 2026/08/22 06:48:16 UTC, 1 replies.
- [jira] [Resolved] (HTTPCLIENT-2430) Brotli decompression fails for large payloads - posted by "Arturo Bernal (Jira)" <ji...@apache.org> on 2026/08/22 06:50:00 UTC, 0 replies.
- [jira] [Created] (HTTPCORE-798) Make socket channel creation customizable in the connecting I/O reactor - posted by "Arturo Bernal (Jira)" <ji...@apache.org> on 2026/08/22 12:15:00 UTC, 0 replies.
- [PR] HTTPCORE-798: Make socket channel creation customizable [httpcomponents-core] - posted by "arturobernalg (via GitHub)" <gi...@apache.org> on 2026/08/22 12:17:35 UTC, 4 replies.
- [PR] HTTPCLIENT-2429: Improve support for custom transport layers [httpcomponents-client] - posted by "arturobernalg (via GitHub)" <gi...@apache.org> on 2026/08/22 15:16:08 UTC, 0 replies.
- [PR] Add support for Compression Dictionary Transport (RFC 9842) [httpcomponents-client] - posted by "arturobernalg (via GitHub)" <gi...@apache.org> on 2026/08/24 06:49:53 UTC, 7 replies.
- [jira] [Commented] (HTTPCORE-798) Make socket channel creation customizable in the connecting I/O reactor - posted by "ASF subversion and git services (Jira)" <ji...@apache.org> on 2026/08/24 14:16:00 UTC, 0 replies.
- [jira] [Commented] (HTTPCLIENT-2409) Content-Length header not removed/modified when decompressing - posted by "Veit Guna (Jira)" <ji...@apache.org> on 2026/08/25 17:11:00 UTC, 0 replies.
- [jira] [Updated] (HTTPCORE-798) Make socket channel creation customizable in the connecting I/O reactor - posted by "Arturo Bernal (Jira)" <ji...@apache.org> on 2026/08/26 08:52:00 UTC, 0 replies.
- [jira] [Resolved] (HTTPCORE-798) Make socket channel creation customizable in the connecting I/O reactor - posted by "Arturo Bernal (Jira)" <ji...@apache.org> on 2026/08/26 08:52:00 UTC, 0 replies.
- [jira] [Closed] (HTTPCORE-798) Make socket channel creation customizable in the connecting I/O reactor - posted by "Arturo Bernal (Jira)" <ji...@apache.org> on 2026/08/26 08:52:00 UTC, 0 replies.
- [PR] Percent codec optimization [httpcomponents-core] - posted by "ok2c (via GitHub)" <gi...@apache.org> on 2026/08/27 17:16:19 UTC, 1 replies.
- Re: [PR] PercentCodec decoder to disallow non-ASCII characters in input [httpcomponents-core] - posted by "ok2c (via GitHub)" <gi...@apache.org> on 2026/08/28 13:29:44 UTC, 1 replies.