You are viewing a plain text version of this content. The canonical link for it is here.
- [jira] [Created] (HTTPCLIENT-2425) RequestConfig#responseTimeout is not enforced for HTTP/2 streams - posted by "yhzdys (Jira)" <ji...@apache.org> on 2026/07/01 05:22:00 UTC, 0 replies.
- [jira] [Commented] (HTTPCLIENT-2423) Support trace context header propagation in httpclient5-observation - posted by "ASF subversion and git services (Jira)" <ji...@apache.org> on 2026/07/01 13:24:00 UTC, 0 replies.
- Re: [PR] Add support for HTTP QUERY method [httpcomponents-client] - posted by "ok2c (via GitHub)" <gi...@apache.org> on 2026/07/01 13:53:45 UTC, 0 replies.
- [jira] [Commented] (HTTPCLIENT-2425) RequestConfig#responseTimeout is not enforced for HTTP/2 streams - posted by "Oleg Kalnichevski (Jira)" <ji...@apache.org> on 2026/07/01 20:00:00 UTC, 0 replies.
- [jira] [Resolved] (HTTPCLIENT-2425) RequestConfig#responseTimeout is not enforced for HTTP/2 streams - posted by "Oleg Kalnichevski (Jira)" <ji...@apache.org> on 2026/07/01 20:01:00 UTC, 0 replies.
- [jira] [Created] (HTTPCLIENT-2426) NullPointerException in InflatingGzipDataConsumer kills I/O reactor when following redirects with Content-Encoding: gzip - posted by "Szczepanski Dominik (Jira)" <ji...@apache.org> on 2026/07/02 07:01:00 UTC, 0 replies.
- [jira] [Updated] (HTTPCLIENT-2426) NullPointerException in InflatingGzipDataConsumer kills I/O reactor when following redirects with Content-Encoding: gzip - posted by "Szczepanski Dominik (Jira)" <ji...@apache.org> on 2026/07/02 07:03:00 UTC, 2 replies.
- [PR] HTTPCLIENT-2426: Do not wrap a discarded (null) response body in a content decoder [httpcomponents-client] - posted by "arturobernalg (via GitHub)" <gi...@apache.org> on 2026/07/02 07:39:37 UTC, 4 replies.
- [jira] [Commented] (HTTPCLIENT-2426) NullPointerException in InflatingGzipDataConsumer kills I/O reactor when following redirects with Content-Encoding: gzip - posted by "Arturo Bernal (Jira)" <ji...@apache.org> on 2026/07/02 07:40:00 UTC, 5 replies.
- [PR] Restrict trigger push branch for GitHub Workflow [httpcomponents-client] - posted by "apupier (via GitHub)" <gi...@apache.org> on 2026/07/02 08:02:03 UTC, 1 replies.
- Re: [PR] Restrict trigger push branch for GitHub Workflow [httpcomponents-core] - posted by "ok2c (via GitHub)" <gi...@apache.org> on 2026/07/03 06:46:11 UTC, 3 replies.
- [jira] [Closed] (HTTPCLIENT-2426) NullPointerException in InflatingGzipDataConsumer kills I/O reactor when following redirects with Content-Encoding: gzip - posted by "Arturo Bernal (Jira)" <ji...@apache.org> on 2026/07/03 11:42:00 UTC, 0 replies.
- [jira] [Resolved] (HTTPCLIENT-2426) NullPointerException in InflatingGzipDataConsumer kills I/O reactor when following redirects with Content-Encoding: gzip - posted by "Arturo Bernal (Jira)" <ji...@apache.org> on 2026/07/03 11:42:00 UTC, 0 replies.
- [jira] [Comment Edited] (HTTPCLIENT-2426) NullPointerException in InflatingGzipDataConsumer kills I/O reactor when following redirects with Content-Encoding: gzip - posted by "Arturo Bernal (Jira)" <ji...@apache.org> on 2026/07/03 11:42:00 UTC, 0 replies.
- [jira] [Created] (HTTPCLIENT-2427) ManagedHttpClientConnection.getSSLSession() throws unexpected org.apache.http.impl.conn.ConnectionShutdownException - posted by "Konrad Windszus (Jira)" <ji...@apache.org> on 2026/07/03 11:51:00 UTC, 0 replies.
- [jira] [Updated] (HTTPCLIENT-2427) ManagedHttpClientConnection.getSSLSession() throws unexpected org.apache.http.impl.conn.ConnectionShutdownException - posted by "Konrad Windszus (Jira)" <ji...@apache.org> on 2026/07/03 11:52:00 UTC, 1 replies.
- [jira] [Commented] (HTTPCLIENT-2427) ManagedHttpClientConnection.getSSLSession() throws unexpected org.apache.http.impl.conn.ConnectionShutdownException - posted by "Arturo Bernal (Jira)" <ji...@apache.org> on 2026/07/03 12:10:00 UTC, 0 replies.
- [jira] [Resolved] (HTTPCLIENT-2427) ManagedHttpClientConnection.getSSLSession() throws unexpected org.apache.http.impl.conn.ConnectionShutdownException - posted by "Oleg Kalnichevski (Jira)" <ji...@apache.org> on 2026/07/03 16:17:00 UTC, 0 replies.
- HttpClient 5.7-alpha1 soon? - posted by Oleg Kalnichevski <ol...@apache.org> on 2026/07/04 10:23:02 UTC, 2 replies.
- Re: [PR] RFC 7639 ALPN [httpcomponents-client] - posted by "ok2c (via GitHub)" <gi...@apache.org> on 2026/07/04 10:38:16 UTC, 0 replies.
- [PR] Added application/x-www-form-urlencoded support to the Jakarta REST client backed by a collection of NameValuePair [httpcomponents-client] - posted by "arturobernalg (via GitHub)" <gi...@apache.org> on 2026/07/04 17:35:07 UTC, 7 replies.
- [PR] escape quotes and strip line breaks in rfc7578 multipart parameters [httpcomponents-client] - posted by "dxbjavid (via GitHub)" <gi...@apache.org> on 2026/07/05 11:45:40 UTC, 2 replies.
- v4.4 affected by CVE-2026-54399? - posted by Marcel Stör <ma...@frightanic.com> on 2026/07/06 17:31:57 UTC, 5 replies.
- [jira] [Commented] (HTTPCORE-730) High CPU Utilization if data is not read from SharedInputBuffer when the internal buffer is completely full - posted by "ASF subversion and git services (Jira)" <ji...@apache.org> on 2026/07/06 22:46:00 UTC, 0 replies.
- [jira] [Commented] (HTTPCORE-695) Unhandled CancelledKeyException during processPendingInterestOps leads to a shutdown of the underlying IOReactor - posted by "ASF subversion and git services (Jira)" <ji...@apache.org> on 2026/07/06 22:46:00 UTC, 0 replies.
- [jira] [Commented] (HTTPCORE-720) High CPU usage noticed for Slow writing clients - posted by "ASF subversion and git services (Jira)" <ji...@apache.org> on 2026/07/06 22:46:00 UTC, 0 replies.
- [jira] [Commented] (HTTPCORE-658) Closing a connection triggers a javax.net.debug error to be logged - posted by "ASF subversion and git services (Jira)" <ji...@apache.org> on 2026/07/06 22:46:00 UTC, 0 replies.
- [jira] [Commented] (HTTPCORE-660) RuntimeException: HostnameVerifier, socket reset for TTL - Not Handled by SSIOSession - posted by "ASF subversion and git services (Jira)" <ji...@apache.org> on 2026/07/06 22:46:00 UTC, 0 replies.
- [jira] [Commented] (HTTPCORE-687) High CPU usage noticed for requests with newline characters - posted by "ASF subversion and git services (Jira)" <ji...@apache.org> on 2026/07/06 22:46:00 UTC, 0 replies.
- [jira] [Commented] (HTTPCORE-716) High CPU usage noticed for HTTPS GET requests with large payload - posted by "ASF subversion and git services (Jira)" <ji...@apache.org> on 2026/07/06 22:46:00 UTC, 0 replies.
- [PR] Add QUERY method caching support [httpcomponents-client] - posted by "desiderantes (via GitHub)" <gi...@apache.org> on 2026/07/08 15:14:09 UTC, 5 replies.
- [PR] Migrate JSON bindings to Jackson 3 [httpcomponents-core] - posted by "arturobernalg (via GitHub)" <gi...@apache.org> on 2026/07/10 13:03:47 UTC, 5 replies.
- [PR] Harden WebSocket transport and permessage-deflate for RFC 6455/7692 conformance [httpcomponents-client] - posted by "arturobernalg (via GitHub)" <gi...@apache.org> on 2026/07/12 13:50:23 UTC, 2 replies.
- [PR] compare scheme in redirect same-authority check [httpcomponents-client] - posted by "dxbjavid (via GitHub)" <gi...@apache.org> on 2026/07/13 18:11:05 UTC, 10 replies.
- [PR] Do not store a response when the request specifies Cache-Control: no-store (RFC 9111 5.2.1.5) [httpcomponents-client] - posted by "arturobernalg (via GitHub)" <gi...@apache.org> on 2026/07/14 13:59:10 UTC, 3 replies.
- [PR] Added support for request body to the cache key generator [httpcomponents-client] - posted by "ok2c (via GitHub)" <gi...@apache.org> on 2026/07/15 16:00:52 UTC, 9 replies.
- [PR] Bump com.fasterxml.jackson.core:jackson-databind from 2.21.1 to 2.21.5 [httpcomponents-client] - posted by "dependabot[bot] (via GitHub)" <gi...@apache.org> on 2026/07/15 16:09:21 UTC, 2 replies.
- Re: [PR] Bump com.fasterxml.jackson.core:jackson-databind from 2.21.1 to 2.22.0 [httpcomponents-client] - posted by "dependabot[bot] (via GitHub)" <gi...@apache.org> on 2026/07/15 16:09:22 UTC, 1 replies.
- [PR] Upgrade Conscrypt [httpcomponents-core] - posted by "rschmitt (via GitHub)" <gi...@apache.org> on 2026/07/15 21:53:10 UTC, 0 replies.
- [PR] Bump com.fasterxml.jackson.core:jackson-databind from 2.21.3 to 2.21.5 in /httpcore5-jackson2 [httpcomponents-core] - posted by "dependabot[bot] (via GitHub)" <gi...@apache.org> on 2026/07/16 08:25:37 UTC, 2 replies.
- Re: [PR] Bump com.fasterxml.jackson.core:jackson-databind from 2.21.3 to 2.22.0 in /httpcore5-jackson2 [httpcomponents-core] - posted by "dependabot[bot] (via GitHub)" <gi...@apache.org> on 2026/07/16 08:25:39 UTC, 1 replies.
- Reactive client integration test failures - posted by Oleg Kalnichevski <ol...@apache.org> on 2026/07/16 13:40:09 UTC, 0 replies.
- [PR] HTTP cache support for the QUERY method (RFC 10008) [httpcomponents-client] - posted by "hunghhdev (via GitHub)" <gi...@apache.org> on 2026/07/16 15:02:51 UTC, 11 replies.
- [PR] Do not call the backend when an only-if-cached request cannot be served from cache (RFC 9111 5.2.1.7) [httpcomponents-client] - posted by "hunghhdev (via GitHub)" <gi...@apache.org> on 2026/07/16 15:51:29 UTC, 2 replies.
- [PR] reject negative 64-bit payload length in WebSocketFrameReader [httpcomponents-client] - posted by "dxbjavid (via GitHub)" <gi...@apache.org> on 2026/07/18 10:17:26 UTC, 2 replies.
- Re: [PR] Bump actions/dependency-review-action from 4 to 5 [httpcomponents-client] - posted by "ok2c (via GitHub)" <gi...@apache.org> on 2026/07/19 08:11:38 UTC, 0 replies.
- Re: [PR] Bump the all group across 1 directory with 18 updates [httpcomponents-client] - posted by "ok2c (via GitHub)" <gi...@apache.org> on 2026/07/19 08:17:41 UTC, 5 replies.
- [PR] Bump the all group across 1 directory with 19 updates [httpcomponents-client] - posted by "dependabot[bot] (via GitHub)" <gi...@apache.org> on 2026/07/19 08:19:43 UTC, 6 replies.
- Re: [PR] HTTPCLIENT-2358 Implement a mutual authentication capable SPNEGO scheme [httpcomponents-client] - posted by "ok2c (via GitHub)" <gi...@apache.org> on 2026/07/19 08:23:45 UTC, 2 replies.
- [PR] Bump the all group across 1 directory with 17 updates [httpcomponents-client] - posted by "dependabot[bot] (via GitHub)" <gi...@apache.org> on 2026/07/19 08:42:27 UTC, 4 replies.
- [PR] Bump the all group across 1 directory with 16 updates [httpcomponents-client] - posted by "dependabot[bot] (via GitHub)" <gi...@apache.org> on 2026/07/19 10:37:27 UTC, 1 replies.
- Re: [PR] Bump actions/dependency-review-action from 4 to 5 [httpcomponents-core] - posted by "ok2c (via GitHub)" <gi...@apache.org> on 2026/07/19 10:48:25 UTC, 0 replies.
- [jira] [Resolved] (HTTPCLIENT-2420) Support max response size and handle slow responders - posted by "Oleg Kalnichevski (Jira)" <ji...@apache.org> on 2026/07/21 08:10:00 UTC, 0 replies.
- [jira] [Created] (HTTPCLIENT-2428) Improve capacity management by inflating AsyncDataConsumers - posted by "Oleg Kalnichevski (Jira)" <ji...@apache.org> on 2026/07/21 08:21:00 UTC, 0 replies.
- [jira] [Updated] (HTTPCLIENT-2428) Improve capacity management by inflating AsyncDataConsumers - posted by "Oleg Kalnichevski (Jira)" <ji...@apache.org> on 2026/07/21 08:24:00 UTC, 1 replies.
- [PR] Deprecate EntityUtils#toByteArray / EntityUtils#toString methods with no maxResultLength constraint [httpcomponents-core] - posted by "ok2c (via GitHub)" <gi...@apache.org> on 2026/07/21 11:45:34 UTC, 1 replies.
- [PR] Document nullable IOSession return values [httpcomponents-core] - posted by "arturobernalg (via GitHub)" <gi...@apache.org> on 2026/07/22 11:40:37 UTC, 1 replies.
- [PR] Extended HttpCacheEntry and related classes to store the enclosed request body [httpcomponents-client] - posted by "hunghhdev (via GitHub)" <gi...@apache.org> on 2026/07/22 15:35:49 UTC, 2 replies.
- [PR] H2 stream handlers to make sure content-length header value equals the sum of data payload [httpcomponents-core] - posted by "ok2c (via GitHub)" <gi...@apache.org> on 2026/07/23 11:27:33 UTC, 4 replies.
- [jira] [Assigned] (HTTPCLIENT-2428) Improve capacity management by inflating AsyncDataConsumers - posted by "Arturo Bernal (Jira)" <ji...@apache.org> on 2026/07/23 13:41:00 UTC, 0 replies.
- [PR] HTTPCLIENT-2428: adjust reactor capacity in inflating AsyncDataConsumers [httpcomponents-client] - posted by "arturobernalg (via GitHub)" <gi...@apache.org> on 2026/07/24 06:38:15 UTC, 3 replies.
- Request for HttpClient 5.6.x patch release including HTTPCLIENT-2426 - posted by Michael Paul via dev <de...@hc.apache.org> on 2026/07/24 12:10:34 UTC, 1 replies.
- [PR] Exclude httpclient5-jakarta-rest-client from the reactor on toolchains below its target Java version [httpcomponents-client] - posted by "arturobernalg (via GitHub)" <gi...@apache.org> on 2026/07/24 12:22:12 UTC, 1 replies.
- [jira] [Commented] (HTTPCLIENT-2428) Improve capacity management by inflating AsyncDataConsumers - posted by "ASF subversion and git services (Jira)" <ji...@apache.org> on 2026/07/25 10:44:00 UTC, 0 replies.
- [jira] [Resolved] (HTTPCLIENT-2428) Improve capacity management by inflating AsyncDataConsumers - posted by "Arturo Bernal (Jira)" <ji...@apache.org> on 2026/07/25 10:49:00 UTC, 0 replies.
- [jira] [Closed] (HTTPCLIENT-2428) Improve capacity management by inflating AsyncDataConsumers - posted by "Arturo Bernal (Jira)" <ji...@apache.org> on 2026/07/25 10:49:00 UTC, 0 replies.
- [PR] Upgraded jakarta.ws.s-api to version 4.0.0 [httpcomponents-client] - posted by "ok2c (via GitHub)" <gi...@apache.org> on 2026/07/25 13:10:57 UTC, 1 replies.
- HttpClient 5.6.3 release notes - posted by Oleg Kalnichevski <ol...@apache.org> on 2026/07/27 08:41:39 UTC, 1 replies.
- [VOTE] Release HttpClient 5.6.3 based on RC1 - posted by Oleg Kalnichevski <ol...@apache.org> on 2026/07/27 13:56:57 UTC, 3 replies.
- [PR] reject control characters in bearer token in BearerScheme [httpcomponents-client] - posted by "dxbjavid (via GitHub)" <gi...@apache.org> on 2026/07/28 06:53:50 UTC, 2 replies.
- JDK 27 Rampdown Phase is Closing - Default G1 in All Environments - posted by David Delabassee via dev <de...@hc.apache.org> on 2026/07/28 09:13:13 UTC, 0 replies.
- [VOTE][RESULT] Release HttpComponents HttpClient 5.6.3 based on RC1 - posted by Oleg Kalnichevski <ol...@apache.org> on 2026/07/30 15:49:35 UTC, 0 replies.
- [ANNOUNCEMENT] HttpComponents Client 5.6.3 Released - posted by Oleg Kalnichevski <ol...@apache.org> on 2026/07/31 08:27:22 UTC, 0 replies.
- HttpClient 5.7-alpha1 release notes - posted by Oleg Kalnichevski <ol...@apache.org> on 2026/07/31 17:16:17 UTC, 0 replies.