You are viewing a plain text version of this content. The canonical link for it is here.
- (sis) branch geoapi-4.0 updated: feat(Geometry): review affine,matrix,similarity transforms. Follow the same pattern as Tuple and Vector, prepare Transform interface for Vector API and HAT Kernels - posted by js...@apache.org on 2026/03/04 14:29:01 UTC, 0 replies.
- (sis) branch geoapi-4.0 updated: feat(Geometry): math Matrix extends geoapi Matrix, cleaning Similarity classes - posted by js...@apache.org on 2026/03/05 13:42:27 UTC, 0 replies.
- (sis) branch geoapi-4.0 updated: feat(Geometry): add scene animation classes - posted by js...@apache.org on 2026/03/05 14:15:56 UTC, 0 replies.
- (sis) branch geoapi-4.0 updated: feat(Geometry): add readonly super interface for Tuple,Vector,Matrix,Affine,Similarity - posted by js...@apache.org on 2026/03/06 15:57:12 UTC, 0 replies.
- (sis) branch geoapi-4.0 updated: feat(Geometry): replace Affine.toMatrix(buffer) by Matrix.setFromAffine(affine) - posted by js...@apache.org on 2026/03/09 15:45:24 UTC, 0 replies.
- (sis) branch geoapi-4.0 updated: Fix version of visual indications of which tiles are loaded in the JavaFX application. - posted by de...@apache.org on 2026/03/13 05:26:05 UTC, 0 replies.
- (sis) branch geoapi-4.0 updated: feat(Math): remove several matrix static methods, now part of matrix classes - posted by js...@apache.org on 2026/03/13 13:36:07 UTC, 0 replies.
- (sis) branch geoapi-4.0 updated: Requires PostgreSQL 18 instead of 15 for enabling the use of collation. - posted by de...@apache.org on 2026/03/17 14:51:31 UTC, 0 replies.
- (sis) branch geoapi-4.0 updated: chore(geoapi): update geoapi submodule - posted by js...@apache.org on 2026/03/18 08:33:23 UTC, 0 replies.
- (sis) branch geoapi-4.0 updated: feat(Geometry): add shortcut methods on Similarity - posted by js...@apache.org on 2026/03/20 10:17:53 UTC, 0 replies.
- (sis) branch geoapi-4.0 updated (cf8c06ee86 -> 0d285f701b) - posted by de...@apache.org on 2026/03/24 17:10:51 UTC, 0 replies.
- (sis) 01/03: Fix wrong tooltip associated to button for switching between grid coverage visual and table of values. Opportunistic documentation fixes. - posted by de...@apache.org on 2026/03/24 17:10:52 UTC, 0 replies.
- (sis) 02/03: Provides a message saying that a CRS is missing instead of letting the exception propagate. - posted by de...@apache.org on 2026/03/24 17:10:53 UTC, 0 replies.
- (sis) 03/03: Fix a ClassCastException in the result of optimizing an `equal` filter when the operands are two Boolean values. - posted by de...@apache.org on 2026/03/24 17:10:54 UTC, 0 replies.
- (sis) branch geoapi-4.0 updated: For an expression such as `equal(function("isNaN", …), literal(true))`, simplify to a more direct filter such as `function("isNaN", …)`. - posted by de...@apache.org on 2026/03/25 11:07:42 UTC, 0 replies.
- (sis) branch geoapi-4.0 updated: Pyramid levels should be ordered from coarsest to finest resolution. https://issues.apache.org/jira/browse/SIS-628 - posted by de...@apache.org on 2026/03/25 17:22:33 UTC, 0 replies.
- (sis) branch geoapi-4.0 updated: Rename `GridCoverageResource.getResolutions()` as `getAvailableResolutions()`. Keep the old method as a deprecated method. This is for compatibility. - posted by de...@apache.org on 2026/03/25 21:02:27 UTC, 0 replies.
- (sis) branch geoapi-4.0 updated: Use shorter name in `TileMatrixSet` identifier. The identifier now hides the image identifier. - posted by de...@apache.org on 2026/03/25 21:45:18 UTC, 0 replies.
- (sis) branch geoapi-4.0 updated: Consolidation of `ResourceTree` making a better usage of JavaFX events. This work is needed for reusing some properties in a future widget for configuring map items. - posted by de...@apache.org on 2026/03/26 21:03:57 UTC, 0 replies.
- (sis) branch geoapi-4.0 updated: Adjustment in documentation, formatting and checks for null values. Removal of a new method which is not going to be used after all. - posted by de...@apache.org on 2026/03/28 14:36:12 UTC, 0 replies.
- (sis) branch geoapi-4.0 updated (e49c660ef2 -> 48633f0377) - posted by de...@apache.org on 2026/03/30 09:10:44 UTC, 0 replies.
- (sis) 01/03: Allows `Containers.derivedList(…)` to return a list which supports addition of elements. - posted by de...@apache.org on 2026/03/30 09:10:45 UTC, 0 replies.
- (sis) 02/03: Avoid misleading classname as display name of a data store. - posted by de...@apache.org on 2026/03/30 09:10:46 UTC, 0 replies.
- (sis) 03/03: Adds a "Layers" panel and move the "Visual indication of tile loading" checkbox as a map item. This is the beginning of a `MapContextView` widget as a tree view with a configuration panel. - posted by de...@apache.org on 2026/03/30 09:10:47 UTC, 0 replies.
- (sis) branch geoapi-4.0 updated: Move the widget for configuring the isoline as a `MapItem` to show in `MapContextView`. - posted by de...@apache.org on 2026/03/30 12:21:14 UTC, 0 replies.
- (sis) branch geoapi-4.0 updated: Move to `MapContextview` the widgets controlling the coverage appearence. Move to the status bar the label which was showing the CRS name. - posted by de...@apache.org on 2026/03/30 15:59:30 UTC, 0 replies.
- (sis) branch geoapi-4.0 updated: Consolidation of the handling of CRS shown in the status bar. - posted by de...@apache.org on 2026/03/31 13:56:32 UTC, 0 replies.
- (sis) branch geoapi-3.1 updated (8c45b25f06 -> 76ac26bca2) - posted by de...@apache.org on 2026/03/31 14:13:27 UTC, 0 replies.
- (sis) 01/01: Merge branch 'geoapi-4.0' into geoapi-3.1. Contains (non-exhaustive list): - posted by de...@apache.org on 2026/03/31 14:13:28 UTC, 0 replies.
- (sis) branch main updated (8ef62b01f5 -> 01e0369fc4) - posted by de...@apache.org on 2026/03/31 15:18:41 UTC, 0 replies.
- (sis) 01/01: Merge branch 'geoapi-3.1'. Contains (non-exhaustive list): - posted by de...@apache.org on 2026/03/31 15:18:42 UTC, 0 replies.
- (sis) branch geoapi-4.0 updated: Post-merge automatic reorganization of imports order. - posted by de...@apache.org on 2026/03/31 15:23:35 UTC, 0 replies.
- (sis) branch geoapi-3.1 updated (76ac26bca2 -> a175b926cf) - posted by de...@apache.org on 2026/03/31 15:26:57 UTC, 0 replies.
- (sis) 01/01: Merge of automatic reorganization of imports order. - posted by de...@apache.org on 2026/03/31 15:26:58 UTC, 1 replies.
- (sis) branch main updated (01e0369fc4 -> 73383b6907) - posted by de...@apache.org on 2026/03/31 15:29:39 UTC, 0 replies.
- (sis) branch geoapi-4.0 updated (19892f6617 -> 7a507877d4) - posted by de...@apache.org on 2026/03/31 16:34:50 UTC, 0 replies.
- (sis) 01/03: Fix some grammar errors in documentations. - posted by de...@apache.org on 2026/03/31 16:34:51 UTC, 0 replies.
- (sis) 02/03: Reduce the logging level from `WARNING` to `CONFIG` for a property not supported by the XML factory. - posted by de...@apache.org on 2026/03/31 16:34:52 UTC, 0 replies.
- (sis) 03/03: Use a little bit more of modern Java features in the GUI module. - posted by de...@apache.org on 2026/03/31 16:34:53 UTC, 0 replies.