You are viewing a plain text version of this content. The canonical link for it is here.
- Re: [PR] added useLocalAuthorityResolver() to ServerBootstrap and AsyncServerBootStrap classes [httpcomponents-core] - posted by "ok2c (via GitHub)" <gi...@apache.org> on 2025/10/01 07:10:38 UTC, 8 replies.
- Re: [PR] HTTP/2: implement RFC 9218 Extensible Prioritization Scheme for HTTP. [httpcomponents-core] - posted by "arturobernalg (via GitHub)" <gi...@apache.org> on 2025/10/01 09:15:33 UTC, 14 replies.
- [PR] HTTPCORE: Add RFC 7639 ALPN header codec and constant [httpcomponents-core] - posted by "arturobernalg (via GitHub)" <gi...@apache.org> on 2025/10/02 06:47:01 UTC, 5 replies.
- [PR] Remove unreachable break after throw in TUNNEL_PROXY branch [httpcomponents-client] - posted by "arturobernalg (via GitHub)" <gi...@apache.org> on 2025/10/02 17:29:17 UTC, 1 replies.
- [PR] added setAuthorityResolver() methods to AsyncServerBootstrap / ServerBootstrap [httpcomponents-core] - posted by "cdw8j (via GitHub)" <gi...@apache.org> on 2025/10/02 22:29:25 UTC, 1 replies.
- Re: [PR] Stale check command for async connections [httpcomponents-core] - posted by "rschmitt (via GitHub)" <gi...@apache.org> on 2025/10/03 01:36:04 UTC, 0 replies.
- [PR] Bump junit.version from 5.13.3 to 6.0.0 [httpcomponents-client] - posted by "dependabot[bot] (via GitHub)" <gi...@apache.org> on 2025/10/03 13:02:21 UTC, 5 replies.
- Re: [PR] Bump org.junit:junit-bom from 5.13.3 to 5.13.4 [httpcomponents-client] - posted by "dependabot[bot] (via GitHub)" <gi...@apache.org> on 2025/10/03 13:02:23 UTC, 1 replies.
- [PR] Bump org.junit:junit-bom from 5.13.3 to 6.0.0 [httpcomponents-core] - posted by "dependabot[bot] (via GitHub)" <gi...@apache.org> on 2025/10/03 14:02:13 UTC, 3 replies.
- Re: [PR] Bump org.junit:junit-bom from 5.13.3 to 5.13.4 [httpcomponents-core] - posted by "dependabot[bot] (via GitHub)" <gi...@apache.org> on 2025/10/03 14:02:14 UTC, 1 replies.
- [PR] Removed unused H2 priority related code. To be moved to client [httpcomponents-core] - posted by "ok2c (via GitHub)" <gi...@apache.org> on 2025/10/04 07:12:03 UTC, 2 replies.
- Re: [PR] Add SCRAM-SHA-256 (RFC 7804) [httpcomponents-client] - posted by "michael-o (via GitHub)" <gi...@apache.org> on 2025/10/05 07:42:34 UTC, 2 replies.
- Re: [PR] Add experimental RouteSegmentedConnPool (OFFLOCK) [httpcomponents-core] - posted by "ok2c (via GitHub)" <gi...@apache.org> on 2025/10/05 12:58:19 UTC, 1 replies.
- Re: [PR] Add async Brotli support (compress/decompress). [httpcomponents-client] - posted by "arturobernalg (via GitHub)" <gi...@apache.org> on 2025/10/05 13:25:16 UTC, 0 replies.
- [VOTE] Release HttpCore 5.4-alpha1 based on RC1 - posted by Oleg Kalnichevski <ol...@apache.org> on 2025/10/05 20:01:35 UTC, 3 replies.
- [PR] RFC 7639 ALPN [httpcomponents-client] - posted by "arturobernalg (via GitHub)" <gi...@apache.org> on 2025/10/06 10:01:54 UTC, 0 replies.
- Re: [PR] Add TestConnectionClosureRace [httpcomponents-client] - posted by "rschmitt (via GitHub)" <gi...@apache.org> on 2025/10/07 16:55:30 UTC, 1 replies.
- [PR] ConnectionConfig: Add idleTimeout [httpcomponents-client] - posted by "rschmitt (via GitHub)" <gi...@apache.org> on 2025/10/07 17:29:44 UTC, 3 replies.
- [PR] Accept leading zeros in IPv4-mapped IPv6 [httpcomponents-core] - posted by "arturobernalg (via GitHub)" <gi...@apache.org> on 2025/10/08 13:11:37 UTC, 1 replies.
- Re: [PR] HTTPCLIENT-2386: Fix TLS handshake timeout handling [httpcomponents-core] - posted by "arturobernalg (via GitHub)" <gi...@apache.org> on 2025/10/08 13:54:19 UTC, 0 replies.
- [VOTE][RESULT] Release HttpComponents HttpCore 5.4-alpha1 based on RC1 - posted by Oleg Kalnichevski <ol...@apache.org> on 2025/10/09 10:09:52 UTC, 0 replies.
- Re: [PR] Bump actions/setup-java from 4 to 5 [httpcomponents-core] - posted by "ok2c (via GitHub)" <gi...@apache.org> on 2025/10/09 12:42:02 UTC, 0 replies.
- Re: [PR] Bump actions/checkout from 4 to 5 [httpcomponents-core] - posted by "ok2c (via GitHub)" <gi...@apache.org> on 2025/10/09 12:42:16 UTC, 0 replies.
- Re: [PR] Bump io.reactivex.rxjava3:rxjava from 3.1.10 to 3.1.12 [httpcomponents-core] - posted by "ok2c (via GitHub)" <gi...@apache.org> on 2025/10/09 12:49:29 UTC, 0 replies.
- Re: [PR] Bump commons-cli:commons-cli from 1.9.0 to 1.10.0 [httpcomponents-core] - posted by "ok2c (via GitHub)" <gi...@apache.org> on 2025/10/09 12:51:39 UTC, 0 replies.
- Re: [PR] Bump log4j.version from 2.25.0 to 2.25.2 [httpcomponents-core] - posted by "ok2c (via GitHub)" <gi...@apache.org> on 2025/10/09 12:52:04 UTC, 3 replies.
- [jira] [Created] (HTTPCLIENT-2400) URLEncodedUtils.encodeFormFields() has incorrect javadoc - posted by "Joakim Erdfelt (Jira)" <ji...@apache.org> on 2025/10/09 14:06:00 UTC, 0 replies.
- [PR] HTTP/2: Implement ORIGIN frame (RFC 8336) and enforce Origin Set [httpcomponents-core] - posted by "arturobernalg (via GitHub)" <gi...@apache.org> on 2025/10/09 14:26:40 UTC, 0 replies.
- [PR] Avoid setting TCP socket options on Unix domain sockets [httpcomponents-client] - posted by "rschmitt (via GitHub)" <gi...@apache.org> on 2025/10/10 04:41:48 UTC, 3 replies.
- [PR] PoolingAsyncClientConnectionManager: Use `StaleCheckCommand` [httpcomponents-client] - posted by "rschmitt (via GitHub)" <gi...@apache.org> on 2025/10/10 04:56:37 UTC, 1 replies.
- [PR] Bump github/codeql-action from 3 to 4 [httpcomponents-client] - posted by "dependabot[bot] (via GitHub)" <gi...@apache.org> on 2025/10/10 13:01:47 UTC, 2 replies.
- [PR] Bump github/codeql-action from 3 to 4 [httpcomponents-core] - posted by "dependabot[bot] (via GitHub)" <gi...@apache.org> on 2025/10/10 14:01:40 UTC, 1 replies.
- [PR] RFC6874 - IPv6 zone IDs in URIs [httpcomponents-core] - posted by "arturobernalg (via GitHub)" <gi...@apache.org> on 2025/10/10 14:02:10 UTC, 15 replies.
- [PR] Bump org.junit:junit-bom from 5.13.3 to 5.14.0 [httpcomponents-core] - posted by "dependabot[bot] (via GitHub)" <gi...@apache.org> on 2025/10/10 14:02:13 UTC, 1 replies.
- Re: [PR] [HTTPCLIENT-2178] Implement Happy Eyeballs V2 (RFC 8305) [httpcomponents-client] - posted by "arturobernalg (via GitHub)" <gi...@apache.org> on 2025/10/10 17:15:23 UTC, 1 replies.
- [PR] RequestConfig: Un-deprecate #setProxy [httpcomponents-client] - posted by "rschmitt (via GitHub)" <gi...@apache.org> on 2025/10/11 01:24:30 UTC, 1 replies.
- Client 5.6 test findings - posted by Ryan Schmitt <rs...@apache.org> on 2025/10/11 02:32:14 UTC, 7 replies.
- Re: [PR] HTTPCLIENT-2394: Virtual threads support for classic client [httpcomponents-client] - posted by "rschmitt (via GitHub)" <gi...@apache.org> on 2025/10/11 15:58:31 UTC, 5 replies.
- [jira] [Closed] (HTTPCLIENT-2358) Implement a mutual authentication capable SPNEGO scheme - posted by "Arturo Bernal (Jira)" <ji...@apache.org> on 2025/10/11 18:58:00 UTC, 0 replies.
- Re: [PR] Add RFC 8297 (103 Early Hints) support to HttpClient5 (classic & async) [httpcomponents-client] - posted by "ok2c (via GitHub)" <gi...@apache.org> on 2025/10/11 19:00:40 UTC, 7 replies.
- [jira] [Commented] (HTTPCLIENT-2358) Implement a mutual authentication capable SPNEGO scheme - posted by "Istvan Toth (Jira)" <ji...@apache.org> on 2025/10/12 07:12:00 UTC, 2 replies.
- [jira] [Reopened] (HTTPCLIENT-2358) Implement a mutual authentication capable SPNEGO scheme - posted by "Arturo Bernal (Jira)" <ji...@apache.org> on 2025/10/12 07:24:00 UTC, 0 replies.
- [PR] Use reflection for Commons Compress codecs to avoid hard dep. [httpcomponents-client] - posted by "arturobernalg (via GitHub)" <gi...@apache.org> on 2025/10/12 09:38:35 UTC, 13 replies.
- [jira] [Closed] (HTTPCLIENT-2394) Virtual Thread (JDK 21) support for classic CloseableHttpClient — disabled by default - posted by "Arturo Bernal (Jira)" <ji...@apache.org> on 2025/10/12 09:43:00 UTC, 0 replies.
- [PR] Asyn brotli reflection [httpcomponents-client] - posted by "arturobernalg (via GitHub)" <gi...@apache.org> on 2025/10/12 17:20:05 UTC, 4 replies.
- [ANNOUNCEMENT] HttpComponents Core 5.4-alpha1 released - posted by Oleg Kalnichevski <ol...@apache.org> on 2025/10/13 10:21:14 UTC, 0 replies.
- [jira] [Resolved] (HTTPCORE-669) I found use H2C ,the capture packet doesn't contain Upgrade header - posted by "Oleg Kalnichevski (Jira)" <ji...@apache.org> on 2025/10/13 10:26:00 UTC, 0 replies.
- [jira] [Created] (HTTPCLIENT-2401) RequestUpgrade interceptor tries to upgrade the connection when using proxies - posted by "Lakatos Gyula (Jira)" <ji...@apache.org> on 2025/10/14 15:32:00 UTC, 0 replies.
- [PR] HTTPCLIENT-2401: Do not attempt RFC 2817 TLS upgrade on proxied routes [httpcomponents-client] - posted by "arturobernalg (via GitHub)" <gi...@apache.org> on 2025/10/14 17:47:54 UTC, 1 replies.
- [jira] [Commented] (HTTPCLIENT-2401) RequestUpgrade interceptor tries to upgrade the connection when using proxies - posted by "Oleg Kalnichevski (Jira)" <ji...@apache.org> on 2025/10/14 18:19:00 UTC, 9 replies.
- [jira] [Comment Edited] (HTTPCLIENT-2401) RequestUpgrade interceptor tries to upgrade the connection when using proxies - posted by "Lakatos Gyula (Jira)" <ji...@apache.org> on 2025/10/14 20:25:00 UTC, 4 replies.
- [jira] [Closed] (HTTPCLIENT-2401) RequestUpgrade interceptor tries to upgrade the connection when using proxies - posted by "Lakatos Gyula (Jira)" <ji...@apache.org> on 2025/10/15 07:38:00 UTC, 0 replies.
- [PR] Add tests to check that an entity's contents is closed or not when an [httpcomponents-client] - posted by "garydgregory (via GitHub)" <gi...@apache.org> on 2025/10/15 21:48:39 UTC, 2 replies.
- [PR] add experimental RFC 9218 Priority header support. [httpcomponents-client] - posted by "arturobernalg (via GitHub)" <gi...@apache.org> on 2025/10/16 12:02:06 UTC, 10 replies.
- Re: [PR] Add RFC 8297 (103 Early Hints) support to HttpClient5 (async) [httpcomponents-client] - posted by "arturobernalg (via GitHub)" <gi...@apache.org> on 2025/10/16 13:57:48 UTC, 1 replies.
- [PR] Bump otel.version from 1.52.0 to 1.55.0 [httpcomponents-client] - posted by "dependabot[bot] (via GitHub)" <gi...@apache.org> on 2025/10/17 13:01:46 UTC, 2 replies.
- Re: [PR] HTTPCLIENT-2358 Implement a mutual authentication capable SPNEGO scheme [httpcomponents-client] - posted by "ok2c (via GitHub)" <gi...@apache.org> on 2025/10/17 13:54:49 UTC, 10 replies.
- [jira] [Commented] (HTTPCLIENT-1482) ability to expect-continue only if potentially stale - posted by "Oleg Kalnichevski (Jira)" <ji...@apache.org> on 2025/10/19 10:12:00 UTC, 9 replies.
- HttpClient 5.6-alpha1 release notes - posted by Oleg Kalnichevski <ol...@apache.org> on 2025/10/19 16:29:01 UTC, 2 replies.
- [PR] Content compression executors no longer remove headers from the original response message [httpcomponents-client] - posted by "ok2c (via GitHub)" <gi...@apache.org> on 2025/10/19 17:00:29 UTC, 2 replies.
- [jira] [Reopened] (HTTPCLIENT-1482) ability to expect-continue only if potentially stale - posted by "Nathan Bryant (Jira)" <ji...@apache.org> on 2025/10/20 01:18:00 UTC, 0 replies.
- [jira] [Created] (HTTPCLIENT-2402) Handle SecurityManager removal in SPNEGO tests - posted by "Istvan Toth (Jira)" <ji...@apache.org> on 2025/10/20 11:12:00 UTC, 0 replies.
- [jira] [Updated] (HTTPCLIENT-2402) Handle SecurityManager removal - posted by "Istvan Toth (Jira)" <ji...@apache.org> on 2025/10/20 11:21:00 UTC, 4 replies.
- [jira] [Comment Edited] (HTTPCLIENT-1482) ability to expect-continue only if potentially stale - posted by "Nathan Bryant (Jira)" <ji...@apache.org> on 2025/10/20 11:52:00 UTC, 0 replies.
- [jira] [Resolved] (HTTPCLIENT-1482) ability to expect-continue only if potentially stale - posted by "Oleg Kalnichevski (Jira)" <ji...@apache.org> on 2025/10/20 12:23:00 UTC, 0 replies.
- [PR] Ensure connection is closed immediately upon socket timeout [httpcomponents-core] - posted by "aldexis (via GitHub)" <gi...@apache.org> on 2025/10/20 14:04:41 UTC, 12 replies.
- [PR] Demo for Java 22+ Async SPNEGO breakage [httpcomponents-client] - posted by "stoty (via GitHub)" <gi...@apache.org> on 2025/10/20 14:47:13 UTC, 0 replies.
- [jira] [Commented] (HTTPCLIENT-2402) Handle SecurityManager removal - posted by "Istvan Toth (Jira)" <ji...@apache.org> on 2025/10/20 17:44:00 UTC, 9 replies.
- [jira] [Created] (HTTPCLIENT-2403) Mutual authentication check not always performed for proxies - posted by "Istvan Toth (Jira)" <ji...@apache.org> on 2025/10/21 08:34:00 UTC, 0 replies.
- [jira] [Updated] (HTTPCLIENT-2403) Mutual authentication check not performed for proxies - posted by "Istvan Toth (Jira)" <ji...@apache.org> on 2025/10/21 08:39:00 UTC, 1 replies.
- [PR] HTTPCLIENT-2403: Mutual authentication check not performed for proxies [httpcomponents-client] - posted by "stoty (via GitHub)" <gi...@apache.org> on 2025/10/21 08:39:49 UTC, 4 replies.
- [jira] [Commented] (HTTPCLIENT-2400) URLEncodedUtils.encodeFormFields() has incorrect javadoc - posted by "Oleg Kalnichevski (Jira)" <ji...@apache.org> on 2025/10/21 12:38:00 UTC, 0 replies.
- [jira] [Resolved] (HTTPCLIENT-2400) URLEncodedUtils.encodeFormFields() has incorrect javadoc - posted by "Oleg Kalnichevski (Jira)" <ji...@apache.org> on 2025/10/21 12:38:00 UTC, 0 replies.
- [jira] [Comment Edited] (HTTPCLIENT-2402) Handle SecurityManager removal - posted by "Istvan Toth (Jira)" <ji...@apache.org> on 2025/10/21 15:15:00 UTC, 4 replies.
- [jira] [Commented] (HTTPCLIENT-2403) Mutual authentication check not performed for proxies - posted by "ASF subversion and git services (Jira)" <ji...@apache.org> on 2025/10/21 15:20:00 UTC, 4 replies.
- [jira] [Resolved] (HTTPCLIENT-2403) Mutual authentication check not performed for proxies - posted by "Oleg Kalnichevski (Jira)" <ji...@apache.org> on 2025/10/21 16:45:00 UTC, 0 replies.
- [VOTE] Release HttpClient 5.6-alpha1 based on RC1 - posted by Oleg Kalnichevski <ol...@apache.org> on 2025/10/21 20:45:13 UTC, 8 replies.
- [PR] Removed AccessController#doPrivileged [httpcomponents-client] - posted by "ok2c (via GitHub)" <gi...@apache.org> on 2025/10/22 11:51:46 UTC, 2 replies.
- Timeout test failures; Re: [VOTE] Release HttpClient 5.6-alpha1 based on RC1 - posted by Oleg Kalnichevski <ol...@apache.org> on 2025/10/22 13:04:02 UTC, 2 replies.
- [jira] [Commented] (HTTPCLIENT-2386) httpClient5 socketTimeoutException in dataChannel with connectTimeout value - posted by "Jens Popp (Jira)" <ji...@apache.org> on 2025/10/23 06:49:00 UTC, 0 replies.
- [jira] [Created] (HTTPCLIENT-2404) Provide comprehensive timeout configuration documentation with interaction matrix and override behavior - posted by "Jens Popp (Jira)" <ji...@apache.org> on 2025/10/23 07:08:00 UTC, 0 replies.
- [jira] [Commented] (HTTPCLIENT-2404) Provide comprehensive timeout configuration documentation with interaction matrix and override behavior - posted by "Oleg Kalnichevski (Jira)" <ji...@apache.org> on 2025/10/23 09:04:00 UTC, 4 replies.
- [jira] [Updated] (HTTPCLIENT-2404) Provide comprehensive timeout configuration documentation with interaction matrix and override behavior - posted by "Oleg Kalnichevski (Jira)" <ji...@apache.org> on 2025/10/23 09:05:00 UTC, 0 replies.
- [jira] [Comment Edited] (HTTPCLIENT-2386) httpClient5 socketTimeoutException in dataChannel with connectTimeout value - posted by "Jens Popp (Jira)" <ji...@apache.org> on 2025/10/24 09:27:00 UTC, 2 replies.
- [VOTE][RESULT] Release HttpComponents HttpClient 5.6-alpha1 based on RC1 - posted by Oleg Kalnichevski <ol...@apache.org> on 2025/10/26 09:05:09 UTC, 0 replies.
- TLS timeout integration test failures; Re: [VOTE] Release HttpClient 5.6-alpha1 based on RC1 - posted by Oleg Kalnichevski <ol...@apache.org> on 2025/10/26 09:26:31 UTC, 1 replies.
- New feature examples and content for HttpClient 5.6 - posted by Oleg Kalnichevski <ol...@apache.org> on 2025/10/26 15:05:34 UTC, 0 replies.
- Re: [PR] Bump actions/checkout from 4 to 5 [httpcomponents-client] - posted by "ok2c (via GitHub)" <gi...@apache.org> on 2025/10/26 15:07:20 UTC, 0 replies.
- Re: [PR] Bump commons-io:commons-io from 2.19.0 to 2.20.0 [httpcomponents-client] - posted by "ok2c (via GitHub)" <gi...@apache.org> on 2025/10/26 15:14:20 UTC, 0 replies.
- Re: [PR] Bump org.apache.commons:commons-compress from 1.27.1 to 1.28.0 [httpcomponents-client] - posted by "ok2c (via GitHub)" <gi...@apache.org> on 2025/10/26 15:15:50 UTC, 0 replies.
- Re: [PR] Bump log4j.version from 2.25.0 to 2.25.1 [httpcomponents-client] - posted by "ok2c (via GitHub)" <gi...@apache.org> on 2025/10/26 15:18:48 UTC, 1 replies.
- Re: [PR] Bump io.reactivex.rxjava3:rxjava from 3.1.10 to 3.1.12 [httpcomponents-client] - posted by "ok2c (via GitHub)" <gi...@apache.org> on 2025/10/26 15:19:34 UTC, 0 replies.
- [ANNOUNCEMENT] HttpComponents Client 5.6-alpha1 Released - posted by Oleg Kalnichevski <ol...@apache.org> on 2025/10/27 18:00:25 UTC, 0 replies.
- [jira] [Created] (HTTPCORE-787) URIBuilder.getPath() should escape each segment - posted by "Jared Jacobs (Jira)" <ji...@apache.org> on 2025/10/30 20:59:00 UTC, 0 replies.
- [jira] [Commented] (HTTPCORE-787) URIBuilder.getPath() should escape each segment - posted by "Oleg Kalnichevski (Jira)" <ji...@apache.org> on 2025/10/31 07:47:00 UTC, 1 replies.
- [jira] [Resolved] (HTTPCORE-787) URIBuilder.getPath() should escape each segment - posted by "Oleg Kalnichevski (Jira)" <ji...@apache.org> on 2025/10/31 07:48:00 UTC, 0 replies.
- [PR] Bump com.github.luben:zstd-jni from 1.5.7-4 to 1.5.7-6 [httpcomponents-client] - posted by "dependabot[bot] (via GitHub)" <gi...@apache.org> on 2025/10/31 13:02:09 UTC, 0 replies.
- [PR] Bump io.opentelemetry:opentelemetry-bom from 1.49.0 to 1.55.0 [httpcomponents-client] - posted by "dependabot[bot] (via GitHub)" <gi...@apache.org> on 2025/10/31 13:02:17 UTC, 0 replies.
- [PR] Bump org.ehcache.modules:ehcache-api from 3.10.8 to 3.11.1 [httpcomponents-client] - posted by "dependabot[bot] (via GitHub)" <gi...@apache.org> on 2025/10/31 13:02:31 UTC, 0 replies.
- [PR] Bump micrometer.tracing.version from 1.5.2 to 1.5.5 [httpcomponents-client] - posted by "dependabot[bot] (via GitHub)" <gi...@apache.org> on 2025/10/31 13:02:41 UTC, 0 replies.
- [PR] Bump micrometer.version from 1.15.2 to 1.15.5 [httpcomponents-client] - posted by "dependabot[bot] (via GitHub)" <gi...@apache.org> on 2025/10/31 13:03:02 UTC, 0 replies.
- [jira] [Created] (HTTPCLIENT-2405) ConnectionReuse uses connectTimeout as readTimeout on reused connection - posted by "Henrik Dohlmann (Jira)" <ji...@apache.org> on 2025/10/31 15:44:00 UTC, 0 replies.