You are viewing a plain text version of this content. The canonical link for it is here.
- [jira] [Assigned] (HTTPCLIENT-2305) Proposal: SSLConnectionSocketFactory refactor to allow custom timer metrics on socket.connect - posted by "Carter Kozak (Jira)" <ji...@apache.org> on 2023/11/01 15:10:00 UTC, 0 replies.
- [jira] [Commented] (HTTPCLIENT-2305) Proposal: SSLConnectionSocketFactory refactor to allow custom timer metrics on socket.connect - posted by "Oleg Kalnichevski (Jira)" <ji...@apache.org> on 2023/11/01 17:38:00 UTC, 6 replies.
- [PR] HTTPCLIENT-2305: SSLConnectionSocketFactory allows socket.connect to be decorated [httpcomponents-client] - posted by "carterkozak (via GitHub)" <gi...@apache.org> on 2023/11/01 18:43:27 UTC, 3 replies.
- [jira] [Updated] (HTTPCLIENT-2305) Proposal: SSLConnectionSocketFactory refactor to allow custom timer metrics on socket.connect - posted by "Carter Kozak (Jira)" <ji...@apache.org> on 2023/11/01 19:39:00 UTC, 0 replies.
- [PR] slf4j-api in httpcomponets-testing module is set to a wrong dependency scope. [httpcomponents-client] - posted by "HappyHacker123 (via GitHub)" <gi...@apache.org> on 2023/11/02 08:36:51 UTC, 5 replies.
- Re: [PR] Add Zstd support to ContentCompressionExec. [httpcomponents-client] - posted by "ok2c (via GitHub)" <gi...@apache.org> on 2023/11/02 10:55:17 UTC, 3 replies.
- [jira] [Closed] (HTTPCLIENT-2305) Proposal: SSLConnectionSocketFactory refactor to allow custom timer metrics on socket.connect - posted by "Carter Kozak (Jira)" <ji...@apache.org> on 2023/11/02 14:23:00 UTC, 0 replies.
- [jira] [Resolved] (HTTPCLIENT-2305) Proposal: SSLConnectionSocketFactory refactor to allow custom timer metrics on socket.connect - posted by "Carter Kozak (Jira)" <ji...@apache.org> on 2023/11/02 14:23:00 UTC, 0 replies.
- [jira] [Created] (HTTPCORE-761) support params TCP_KEEPIDLE/TCP_KEEPINTERVAL/TCP_KEEPCOUNT in Socket - posted by "kkewwei (Jira)" <ji...@apache.org> on 2023/11/03 06:28:00 UTC, 0 replies.
- [jira] [Updated] (HTTPCORE-761) support params TCP_KEEPIDLE/TCP_KEEPINTERVAL/TCP_KEEPCOUNT in Socket - posted by "kkewwei (Jira)" <ji...@apache.org> on 2023/11/03 06:31:00 UTC, 3 replies.
- [jira] [Commented] (HTTPCORE-761) support params TCP_KEEPIDLE/TCP_KEEPINTERVAL/TCP_KEEPCOUNT in Socket - posted by "Oleg Kalnichevski (Jira)" <ji...@apache.org> on 2023/11/03 09:42:00 UTC, 4 replies.
- [jira] [Comment Edited] (HTTPCORE-761) support params TCP_KEEPIDLE/TCP_KEEPINTERVAL/TCP_KEEPCOUNT in Socket - posted by "kkewwei (Jira)" <ji...@apache.org> on 2023/11/03 13:14:00 UTC, 1 replies.
- [PR] HTTPCLIENT-2277: RFC 9111 conformance improvements / bug fixes [httpcomponents-client] - posted by "ok2c (via GitHub)" <gi...@apache.org> on 2023/11/04 10:14:55 UTC, 7 replies.
- [PR] HTTPCLIENT-2301. Fix stale connection handling in BasicHttpClientConnectionManager [httpcomponents-client] - posted by "arturobernalg (via GitHub)" <gi...@apache.org> on 2023/11/04 18:42:43 UTC, 8 replies.
- [PR] HTTPCORE-761: support ExtendedSocketOption in socket [httpcomponents-core] - posted by "kkewwei (via GitHub)" <gi...@apache.org> on 2023/11/05 14:03:25 UTC, 6 replies.
- [jira] [Resolved] (HTTPCORE-761) support params TCP_KEEPIDLE/TCP_KEEPINTERVAL/TCP_KEEPCOUNT in Socket - posted by "Oleg Kalnichevski (Jira)" <ji...@apache.org> on 2023/11/06 11:38:00 UTC, 0 replies.
- [jira] [Commented] (HTTPCLIENT-2301) BasicHttpClientConnectionManager returns response of previous requests - posted by "ASF subversion and git services (Jira)" <ji...@apache.org> on 2023/11/09 16:18:00 UTC, 0 replies.
- [jira] [Assigned] (HTTPCLIENT-2301) BasicHttpClientConnectionManager returns response of previous requests - posted by "Arturo Bernal (Jira)" <ji...@apache.org> on 2023/11/09 16:18:00 UTC, 0 replies.
- [jira] [Resolved] (HTTPCLIENT-2301) BasicHttpClientConnectionManager returns response of previous requests - posted by "Arturo Bernal (Jira)" <ji...@apache.org> on 2023/11/09 16:19:00 UTC, 0 replies.
- [jira] [Updated] (HTTPCLIENT-2301) BasicHttpClientConnectionManager returns response of previous requests - posted by "Arturo Bernal (Jira)" <ji...@apache.org> on 2023/11/09 16:19:00 UTC, 0 replies.
- [PR] Bump org.junit:junit-bom from 5.9.3 to 5.10.1 [httpcomponents-client] - posted by "dependabot[bot] (via GitHub)" <gi...@apache.org> on 2023/11/10 13:23:04 UTC, 1 replies.
- Re: [PR] Bump org.junit:junit-bom from 5.9.3 to 5.10.0 [httpcomponents-client] - posted by "dependabot[bot] (via GitHub)" <gi...@apache.org> on 2023/11/10 13:23:06 UTC, 1 replies.
- [jira] [Commented] (HTTPCLIENT-2277) HttpClient Cache conformance to RFC 9111 - posted by "ASF subversion and git services (Jira)" <ji...@apache.org> on 2023/11/16 19:05:00 UTC, 14 replies.
- [jira] [Resolved] (HTTPCLIENT-2277) HttpClient Cache conformance to RFC 9111 - posted by "Oleg Kalnichevski (Jira)" <ji...@apache.org> on 2023/11/16 19:08:00 UTC, 0 replies.
- Development plans / releases in the coming weeks - posted by Oleg Kalnichevski <ol...@apache.org> on 2023/11/17 09:04:39 UTC, 2 replies.
- HttpClient 5.2.2 release notes - posted by Oleg Kalnichevski <ol...@apache.org> on 2023/11/18 11:01:01 UTC, 1 replies.
- Apache HttpClient performance benchmark - posted by Oleg Kalnichevski <ol...@apache.org> on 2023/11/18 15:10:00 UTC, 0 replies.
- [VOTE] Release HttpClient 5.2.2 based on RC1 - posted by Oleg Kalnichevski <ol...@apache.org> on 2023/11/19 09:02:14 UTC, 4 replies.
- [PR] SEE OTHER redirect handling fix [httpcomponents-client] - posted by "ok2c (via GitHub)" <gi...@apache.org> on 2023/11/19 10:27:42 UTC, 2 replies.
- Re: [PR] Bump com.googlecode.maven-download-plugin:download-maven-plugin from 1.6.8 to 1.7.1 [httpcomponents-client] - posted by "ok2c (via GitHub)" <gi...@apache.org> on 2023/11/19 10:46:31 UTC, 0 replies.
- [PR] Implement Password Validation in BasicScheme. [httpcomponents-client] - posted by "arturobernalg (via GitHub)" <gi...@apache.org> on 2023/11/19 18:51:48 UTC, 1 replies.
- [jira] [Created] (HTTPCLIENT-2306) What is different in PoolingHttpClientConnectionManager from MultiThreadedHttpConnectionManager? - posted by "harsha vardhan sai T (Jira)" <ji...@apache.org> on 2023/11/20 16:01:00 UTC, 0 replies.
- [PR] Enforce UTF-8 Encoding in BasicSchemeFactory for RFC 7617 Compliance [httpcomponents-client] - posted by "arturobernalg (via GitHub)" <gi...@apache.org> on 2023/11/20 20:21:03 UTC, 8 replies.
- [jira] [Resolved] (HTTPCLIENT-2306) What is different in PoolingHttpClientConnectionManager from MultiThreadedHttpConnectionManager? - posted by "Oleg Kalnichevski (Jira)" <ji...@apache.org> on 2023/11/21 09:55:00 UTC, 0 replies.
- [jira] [Commented] (HTTPCLIENT-2306) What is different in PoolingHttpClientConnectionManager from MultiThreadedHttpConnectionManager? - posted by "Oleg Kalnichevski (Jira)" <ji...@apache.org> on 2023/11/21 09:55:00 UTC, 0 replies.
- HTTPcore5-h2 (5.2.2) Frame Size Regression: Issues with File Uploads Beyond 16KB - posted by Sandeep Gaur <sa...@gmail.com> on 2023/11/22 12:11:37 UTC, 6 replies.
- [jira] [Created] (HTTPCORE-762) HTTPcore5-h2 (5.2.2) Frame Size Regression: Issues with File Uploads Beyond 16KB - posted by "Sandeep_gaur (Jira)" <ji...@apache.org> on 2023/11/22 14:37:00 UTC, 0 replies.
- [jira] [Updated] (HTTPCORE-762) HTTPcore5-h2 (5.2.2) Frame Size Regression: Issues with File Uploads Beyond 16KB - posted by "Oleg Kalnichevski (Jira)" <ji...@apache.org> on 2023/11/22 15:28:00 UTC, 0 replies.
- [jira] [Commented] (HTTPCORE-762) HTTPcore5-h2 (5.2.2) Frame Size Regression: Issues with File Uploads Beyond 16KB - posted by "ASF subversion and git services (Jira)" <ji...@apache.org> on 2023/11/22 15:38:00 UTC, 3 replies.
- [jira] [Resolved] (HTTPCORE-762) HTTPcore5-h2 (5.2.2) Frame Size Regression: Issues with File Uploads Beyond 16KB - posted by "Oleg Kalnichevski (Jira)" <ji...@apache.org> on 2023/11/22 16:17:00 UTC, 0 replies.
- [VOTE][RESULT] Release HttpComponents HttpClient 5.2.2 based on RC1 - posted by Oleg Kalnichevski <ol...@apache.org> on 2023/11/23 08:20:25 UTC, 0 replies.
- [PR] Fixes Invalid Proxy exception when using a SSL client without Proxy [httpcomponents-client] - posted by "ctabin (via GitHub)" <gi...@apache.org> on 2023/11/23 12:22:02 UTC, 3 replies.
- [jira] [Created] (HTTPCLIENT-2307) getting "Invalid Proxy" when no proxy set - posted by "Jim Sellers (Jira)" <ji...@apache.org> on 2023/11/23 14:54:00 UTC, 0 replies.
- [jira] [Resolved] (HTTPCLIENT-2307) getting "Invalid Proxy" when no proxy set - posted by "Oleg Kalnichevski (Jira)" <ji...@apache.org> on 2023/11/23 15:02:00 UTC, 0 replies.
- HttpCore 5.2.4 release notes - posted by Oleg Kalnichevski <ol...@apache.org> on 2023/11/23 15:07:07 UTC, 1 replies.
- [PR] Enforce Support for UTF-8 Encoding Scheme in Digest Authentication as per RFC 7616 [httpcomponents-client] - posted by "arturobernalg (via GitHub)" <gi...@apache.org> on 2023/11/23 21:46:14 UTC, 0 replies.
- [PR] Implement Support for Userhash Parameter in Digest Authentication as per RFC 7616 [httpcomponents-client] - posted by "arturobernalg (via GitHub)" <gi...@apache.org> on 2023/11/23 21:46:18 UTC, 0 replies.
- [jira] [Created] (HTTPCLIENT-2308) Non-Proxied SSL Connection Failures in 5.2.2 - posted by "Jim Gajnak (Jira)" <ji...@apache.org> on 2023/11/24 12:09:00 UTC, 0 replies.
- [jira] [Updated] (HTTPCLIENT-2308) "Invalid Proxy" SSL Connection Failures in 5.2.2 - posted by "Jim Gajnak (Jira)" <ji...@apache.org> on 2023/11/24 12:12:00 UTC, 0 replies.
- [jira] [Resolved] (HTTPCLIENT-2308) "Invalid Proxy" SSL Connection Failures in 5.2.2 - posted by "Oleg Kalnichevski (Jira)" <ji...@apache.org> on 2023/11/24 12:53:00 UTC, 0 replies.
- [jira] [Created] (HTTPCLIENT-2309) Proxy url set via HttpClientBuilder is not working - posted by "Marcin DÄ…browski (Jira)" <ji...@apache.org> on 2023/11/24 13:08:00 UTC, 0 replies.
- [jira] [Commented] (HTTPCLIENT-2309) Proxy url set via HttpClientBuilder is not working - posted by "Arturo Bernal (Jira)" <ji...@apache.org> on 2023/11/24 13:25:00 UTC, 6 replies.
- [jira] [Resolved] (HTTPCLIENT-2309) Proxy url set via HttpClientBuilder is not working - posted by "Oleg Kalnichevski (Jira)" <ji...@apache.org> on 2023/11/24 13:27:00 UTC, 1 replies.
- [jira] [Reopened] (HTTPCLIENT-2309) Proxy url set via HttpClientBuilder is not working - posted by "Marcin DÄ…browski (Jira)" <ji...@apache.org> on 2023/11/24 13:43:00 UTC, 0 replies.
- [PR] Add validation to prevent both 'username' and 'username*' in DigestScheme headers. [httpcomponents-client] - posted by "arturobernalg (via GitHub)" <gi...@apache.org> on 2023/11/24 16:29:42 UTC, 0 replies.
- [VOTE] Release HttpCore 5.2.4 based on RC1 - posted by Oleg Kalnichevski <ol...@apache.org> on 2023/11/24 19:12:07 UTC, 6 replies.
- [PR] Implement username* validation and decoding in DigestScheme [httpcomponents-client] - posted by "arturobernalg (via GitHub)" <gi...@apache.org> on 2023/11/24 22:32:46 UTC, 0 replies.
- [jira] [Created] (HTTPCLIENT-2310) HttpRequestInterceptor doesn't catch a CONNECT request - posted by "Marian (Jira)" <ji...@apache.org> on 2023/11/25 09:09:00 UTC, 0 replies.
- [jira] [Commented] (HTTPCLIENT-2292) SOCKS proxy configuration is not working - posted by "Misagh Moayyed (Jira)" <ji...@apache.org> on 2023/11/26 20:25:00 UTC, 2 replies.
- [jira] [Comment Edited] (HTTPCLIENT-2292) SOCKS proxy configuration is not working - posted by "Misagh Moayyed (Jira)" <ji...@apache.org> on 2023/11/26 20:27:00 UTC, 1 replies.
- [PR] HTTPCLIENT-2292: fix regression leading to invalid proxy [httpcomponents-client] - posted by "mmoayyed (via GitHub)" <gi...@apache.org> on 2023/11/26 20:38:02 UTC, 4 replies.
- [jira] [Updated] (HTTPCLIENT-2292) SOCKS proxy configuration is not working - posted by "Gary D. Gregory (Jira)" <ji...@apache.org> on 2023/11/27 15:25:00 UTC, 0 replies.
- [VOTE][RESULT] Release HttpComponents HttpCore 5.2.4 based on RC1 - posted by Oleg Kalnichevski <ol...@apache.org> on 2023/11/27 18:27:13 UTC, 0 replies.
- [PR] Invalid Argument Exception thrown when null proxy passed to Socket contrctor [httpcomponents-client] - posted by "SquirrelGrip (via GitHub)" <gi...@apache.org> on 2023/11/28 06:59:21 UTC, 2 replies.
- [PR] Fixed a problem when a null proxy is passed to the constructor of a Socket. [httpcomponents-client] - posted by "SquirrelGrip (via GitHub)" <gi...@apache.org> on 2023/11/28 07:11:41 UTC, 2 replies.
- HttpClient 5.2.3 release notes - posted by Oleg Kalnichevski <ol...@apache.org> on 2023/11/28 10:40:54 UTC, 2 replies.
- [jira] [Commented] (HTTPCLIENT-2310) HttpRequestInterceptor doesn't catch a CONNECT request - posted by "Oleg Kalnichevski (Jira)" <ji...@apache.org> on 2023/11/28 12:32:00 UTC, 4 replies.
- [jira] [Updated] (HTTPCLIENT-2310) HttpRequestInterceptor doesn't catch a CONNECT request - posted by "Oleg Kalnichevski (Jira)" <ji...@apache.org> on 2023/11/28 12:32:00 UTC, 3 replies.
- [jira] [Commented] (HTTPCLIENT-2307) getting "Invalid Proxy" when no proxy set - posted by "ASF subversion and git services (Jira)" <ji...@apache.org> on 2023/11/28 12:35:00 UTC, 0 replies.
- [VOTE] Release HttpClient 5.2.3 based on RC1 - posted by Oleg Kalnichevski <ol...@apache.org> on 2023/11/28 15:08:15 UTC, 4 replies.
- [jira] [Commented] (HTTPCLIENT-1347) gzip responses doubly cached - posted by "ASF subversion and git services (Jira)" <ji...@apache.org> on 2023/11/28 16:38:00 UTC, 0 replies.
- Re: (httpcomponents-client) branch 5.3.x created (now 370e9f33f) - posted by Oleg Kalnichevski <ol...@apache.org> on 2023/11/28 17:05:49 UTC, 1 replies.
- [jira] [Commented] (HTTPCLIENT-1378) CacheableRequestPolicy and ResponseCachingPolicy Have Overlapping Functionality - posted by "Arturo Bernal (Jira)" <ji...@apache.org> on 2023/11/28 22:00:00 UTC, 0 replies.
- [jira] [Resolved] (HTTPCLIENT-1378) CacheableRequestPolicy and ResponseCachingPolicy Have Overlapping Functionality - posted by "Oleg Kalnichevski (Jira)" <ji...@apache.org> on 2023/11/29 08:31:00 UTC, 0 replies.
- [PR] Improve debug logging around nott reusable connections [httpcomponents-client] - posted by "nfawcett (via GitHub)" <gi...@apache.org> on 2023/11/29 10:21:26 UTC, 0 replies.
- [jira] [Created] (HTTPCLIENT-2311) Http Client not working anymore with SSL configuration - posted by "Hakan Altindag (Jira)" <ji...@apache.org> on 2023/11/29 10:53:00 UTC, 0 replies.
- [jira] [Updated] (HTTPCLIENT-2311) Http Client not working anymore with SSL configuration - posted by "Hakan Altindag (Jira)" <ji...@apache.org> on 2023/11/29 10:58:00 UTC, 1 replies.
- [jira] [Resolved] (HTTPCLIENT-2311) Http Client not working anymore with SSL configuration - posted by "Gary D. Gregory (Jira)" <ji...@apache.org> on 2023/11/29 11:26:00 UTC, 0 replies.
- [jira] [Commented] (HTTPCLIENT-2311) Http Client not working anymore with SSL configuration - posted by "Gary D. Gregory (Jira)" <ji...@apache.org> on 2023/11/29 11:28:00 UTC, 0 replies.
- Re: [PR] Improve debug logging around connections that cannot be reused [httpcomponents-client] - posted by "ok2c (via GitHub)" <gi...@apache.org> on 2023/11/29 12:21:23 UTC, 1 replies.
- [jira] [Updated] (HTTPCLIENT-2310) Async client incorrectly pipes CONNECT requests through the main request protocol chain - posted by "Oleg Kalnichevski (Jira)" <ji...@apache.org> on 2023/11/29 14:02:00 UTC, 0 replies.
- [PR] HTTPCLIENT-2310: Async Connect exec handler incorrectly pipes CONNECT requests through the main request protocol chain [httpcomponents-client] - posted by "ok2c (via GitHub)" <gi...@apache.org> on 2023/11/30 12:41:09 UTC, 0 replies.
- [jira] [Commented] (HTTPCLIENT-2310) Async client incorrectly pipes CONNECT requests through the main request protocol chain - posted by "Oleg Kalnichevski (Jira)" <ji...@apache.org> on 2023/11/30 12:45:00 UTC, 4 replies.