You are viewing a plain text version of this content. The canonical link for it is here.
Posted to commits@commons.apache.org by tn...@apache.org on 2012/08/23 22:38:21 UTC
svn commit: r1376686 - in
/commons/proper/codec/trunk/src/main/java/org/apache/commons/codec:
Decoder.java Encoder.java net/BCodec.java net/QCodec.java
net/QuotedPrintableCodec.java net/RFC1522Codec.java net/URLCodec.java
Author: tn
Date: Thu Aug 23 20:38:20 2012
New Revision: 1376686
URL: http://svn.apache.org/viewvc?rev=1376686&view=rev
Log:
Javadoc cleanup, removal of leading paragraph.
Modified:
commons/proper/codec/trunk/src/main/java/org/apache/commons/codec/Decoder.java
commons/proper/codec/trunk/src/main/java/org/apache/commons/codec/Encoder.java
commons/proper/codec/trunk/src/main/java/org/apache/commons/codec/net/BCodec.java
commons/proper/codec/trunk/src/main/java/org/apache/commons/codec/net/QCodec.java
commons/proper/codec/trunk/src/main/java/org/apache/commons/codec/net/QuotedPrintableCodec.java
commons/proper/codec/trunk/src/main/java/org/apache/commons/codec/net/RFC1522Codec.java
commons/proper/codec/trunk/src/main/java/org/apache/commons/codec/net/URLCodec.java
Modified: commons/proper/codec/trunk/src/main/java/org/apache/commons/codec/Decoder.java
URL: http://svn.apache.org/viewvc/commons/proper/codec/trunk/src/main/java/org/apache/commons/codec/Decoder.java?rev=1376686&r1=1376685&r2=1376686&view=diff
==============================================================================
--- commons/proper/codec/trunk/src/main/java/org/apache/commons/codec/Decoder.java (original)
+++ commons/proper/codec/trunk/src/main/java/org/apache/commons/codec/Decoder.java Thu Aug 23 20:38:20 2012
@@ -18,14 +18,12 @@
package org.apache.commons.codec;
/**
- * <p>Provides the highest level of abstraction for Decoders.
- * This is the sister interface of {@link Encoder}. All
- * Decoders implement this common generic interface.</p>
- *
- * <p>Allows a user to pass a generic Object to any Decoder
- * implementation in the codec package.</p>
- *
- * <p>One of the two interfaces at the center of the codec package.</p>
+ * Provides the highest level of abstraction for Decoders.
+ * <p>
+ * This is the sister interface of {@link Encoder}. All Decoders implement this common generic interface.
+ * Allows a user to pass a generic Object to any Decoder implementation in the codec package.
+ * <p>
+ * One of the two interfaces at the center of the codec package.
*
* @version $Id$
*/
Modified: commons/proper/codec/trunk/src/main/java/org/apache/commons/codec/Encoder.java
URL: http://svn.apache.org/viewvc/commons/proper/codec/trunk/src/main/java/org/apache/commons/codec/Encoder.java?rev=1376686&r1=1376685&r2=1376686&view=diff
==============================================================================
--- commons/proper/codec/trunk/src/main/java/org/apache/commons/codec/Encoder.java (original)
+++ commons/proper/codec/trunk/src/main/java/org/apache/commons/codec/Encoder.java Thu Aug 23 20:38:20 2012
@@ -18,10 +18,11 @@
package org.apache.commons.codec;
/**
- * <p>Provides the highest level of abstraction for Encoders.
- * This is the sister interface of {@link Decoder}. Every implementation of
- * Encoder provides this common generic interface which allows a user to pass a
- * generic Object to any Encoder implementation in the codec package.</p>
+ * Provides the highest level of abstraction for Encoders.
+ * <p>
+ * This is the sister interface of {@link Decoder}. Every implementation of Encoder provides this
+ * common generic interface which allows a user to pass a generic Object to any Encoder implementation
+ * in the codec package.
*
* @version $Id$
*/
Modified: commons/proper/codec/trunk/src/main/java/org/apache/commons/codec/net/BCodec.java
URL: http://svn.apache.org/viewvc/commons/proper/codec/trunk/src/main/java/org/apache/commons/codec/net/BCodec.java?rev=1376686&r1=1376685&r2=1376686&view=diff
==============================================================================
--- commons/proper/codec/trunk/src/main/java/org/apache/commons/codec/net/BCodec.java (original)
+++ commons/proper/codec/trunk/src/main/java/org/apache/commons/codec/net/BCodec.java Thu Aug 23 20:38:20 2012
@@ -29,18 +29,14 @@ import org.apache.commons.codec.StringEn
import org.apache.commons.codec.binary.Base64;
/**
- * <p>
- * Identical to the Base64 encoding defined by <a href="http://www.ietf.org/rfc/rfc1521.txt">RFC
- * 1521</a> and allows a character set to be specified.
- * </p>
- *
+ * Identical to the Base64 encoding defined by <a href="http://www.ietf.org/rfc/rfc1521.txt">RFC 1521</a>
+ * and allows a character set to be specified.
* <p>
* <a href="http://www.ietf.org/rfc/rfc1522.txt">RFC 1522</a> describes techniques to allow the encoding of non-ASCII
* text in various portions of a RFC 822 [2] message header, in a manner which is unlikely to confuse existing message
* handling software.
- * </p>
- *
- * <p>This class is immutable and thread-safe.</p>
+ * <p>
+ * This class is immutable and thread-safe.
*
* @see <a href="http://www.ietf.org/rfc/rfc1522.txt">MIME (Multipurpose Internet Mail Extensions) Part Two: Message
* Header Extensions for Non-ASCII Text</a>
Modified: commons/proper/codec/trunk/src/main/java/org/apache/commons/codec/net/QCodec.java
URL: http://svn.apache.org/viewvc/commons/proper/codec/trunk/src/main/java/org/apache/commons/codec/net/QCodec.java?rev=1376686&r1=1376685&r2=1376686&view=diff
==============================================================================
--- commons/proper/codec/trunk/src/main/java/org/apache/commons/codec/net/QCodec.java (original)
+++ commons/proper/codec/trunk/src/main/java/org/apache/commons/codec/net/QCodec.java Thu Aug 23 20:38:20 2012
@@ -29,18 +29,14 @@ import org.apache.commons.codec.StringDe
import org.apache.commons.codec.StringEncoder;
/**
- * <p>
- * Similar to the Quoted-Printable content-transfer-encoding defined in <a
- * href="http://www.ietf.org/rfc/rfc1521.txt">RFC 1521</a> and designed to allow text containing mostly ASCII
+ * Similar to the Quoted-Printable content-transfer-encoding defined in
+ * <a href="http://www.ietf.org/rfc/rfc1521.txt">RFC 1521</a> and designed to allow text containing mostly ASCII
* characters to be decipherable on an ASCII terminal without decoding.
- * </p>
- *
* <p>
* <a href="http://www.ietf.org/rfc/rfc1522.txt">RFC 1522</a> describes techniques to allow the encoding of non-ASCII
* text in various portions of a RFC 822 [2] message header, in a manner which is unlikely to confuse existing message
* handling software.
- * </p>
- *
+ * <p>
* This class is conditionally thread-safe.
* The instance field {@link #encodeBlanks} is mutable {@link #setEncodeBlanks(boolean)}
* but is not volatile, and accesses are not synchronised.
Modified: commons/proper/codec/trunk/src/main/java/org/apache/commons/codec/net/QuotedPrintableCodec.java
URL: http://svn.apache.org/viewvc/commons/proper/codec/trunk/src/main/java/org/apache/commons/codec/net/QuotedPrintableCodec.java?rev=1376686&r1=1376685&r2=1376686&view=diff
==============================================================================
--- commons/proper/codec/trunk/src/main/java/org/apache/commons/codec/net/QuotedPrintableCodec.java (original)
+++ commons/proper/codec/trunk/src/main/java/org/apache/commons/codec/net/QuotedPrintableCodec.java Thu Aug 23 20:38:20 2012
@@ -33,9 +33,7 @@ import org.apache.commons.codec.StringEn
import org.apache.commons.codec.binary.StringUtils;
/**
- * <p>
* Codec for the Quoted-Printable section of <a href="http://www.ietf.org/rfc/rfc1521.txt">RFC 1521</a>.
- * </p>
* <p>
* The Quoted-Printable encoding is intended to represent data that largely consists of octets that correspond to
* printable characters in the ASCII character set. It encodes the data in such a way that the resulting octets are
@@ -43,19 +41,15 @@ import org.apache.commons.codec.binary.S
* data remains largely recognizable by humans. A body which is entirely ASCII may also be encoded in Quoted-Printable
* to ensure the integrity of the data should the message pass through a character- translating, and/or line-wrapping
* gateway.
- * </p>
- *
* <p>
* Note:
- * </p>
* <p>
* Rules #3, #4, and #5 of the quoted-printable spec are not implemented yet because the complete quoted-printable spec
* does not lend itself well into the byte[] oriented codec framework. Complete the codec once the streamable codec
* framework is ready. The motivation behind providing the codec in a partial form is that it can already come in handy
* for those applications that do not require quoted-printable line formatting (rules #3, #4, #5), for instance Q codec.
- * </p>
- *
- * <p>This class is immutable and thread-safe.</p>
+ * <p>
+ * This class is immutable and thread-safe.
*
* @see <a href="http://www.ietf.org/rfc/rfc1521.txt"> RFC 1521 MIME (Multipurpose Internet Mail Extensions) Part One:
* Mechanisms for Specifying and Describing the Format of Internet Message Bodies </a>
Modified: commons/proper/codec/trunk/src/main/java/org/apache/commons/codec/net/RFC1522Codec.java
URL: http://svn.apache.org/viewvc/commons/proper/codec/trunk/src/main/java/org/apache/commons/codec/net/RFC1522Codec.java?rev=1376686&r1=1376685&r2=1376686&view=diff
==============================================================================
--- commons/proper/codec/trunk/src/main/java/org/apache/commons/codec/net/RFC1522Codec.java (original)
+++ commons/proper/codec/trunk/src/main/java/org/apache/commons/codec/net/RFC1522Codec.java Thu Aug 23 20:38:20 2012
@@ -25,23 +25,16 @@ import org.apache.commons.codec.EncoderE
import org.apache.commons.codec.binary.StringUtils;
/**
- * <p>
* Implements methods common to all codecs defined in RFC 1522.
- * </p>
- *
* <p>
- * <a href="http://www.ietf.org/rfc/rfc1522.txt">RFC 1522</a>
- * describes techniques to allow the encoding of non-ASCII text in
- * various portions of a RFC 822 [2] message header, in a manner which
+ * <a href="http://www.ietf.org/rfc/rfc1522.txt">RFC 1522</a> describes techniques to allow the
+ * encoding of non-ASCII text in various portions of a RFC 822 [2] message header, in a manner which
* is unlikely to confuse existing message handling software.
- * </p>
-
- * @see <a href="http://www.ietf.org/rfc/rfc1522.txt">
- * MIME (Multipurpose Internet Mail Extensions) Part Two:
- * Message Header Extensions for Non-ASCII Text</a>
- * </p>
+ * <p>
+ * This class is immutable and thread-safe.
*
- * <p>This class is immutable and thread-safe.</p>
+ * @see <a href="http://www.ietf.org/rfc/rfc1522.txt">MIME (Multipurpose Internet Mail Extensions) Part Two:
+ * Message Header Extensions for Non-ASCII Text</a>
*
* @since 1.3
* @version $Id$
Modified: commons/proper/codec/trunk/src/main/java/org/apache/commons/codec/net/URLCodec.java
URL: http://svn.apache.org/viewvc/commons/proper/codec/trunk/src/main/java/org/apache/commons/codec/net/URLCodec.java?rev=1376686&r1=1376685&r2=1376686&view=diff
==============================================================================
--- commons/proper/codec/trunk/src/main/java/org/apache/commons/codec/net/URLCodec.java (original)
+++ commons/proper/codec/trunk/src/main/java/org/apache/commons/codec/net/URLCodec.java Thu Aug 23 20:38:20 2012
@@ -31,22 +31,16 @@ import org.apache.commons.codec.StringEn
import org.apache.commons.codec.binary.StringUtils;
/**
- * <p>Implements the 'www-form-urlencoded' encoding scheme,
- * also misleadingly known as URL encoding.</p>
- *
- * <p>For more detailed information please refer to
- * <a href="http://www.w3.org/TR/html4/interact/forms.html#h-17.13.4.1">
- * Chapter 17.13.4 'Form content types'</a> of the
- * <a href="http://www.w3.org/TR/html4/">HTML 4.01 Specification<a></p>
- *
+ * Implements the 'www-form-urlencoded' encoding scheme, also misleadingly known as URL encoding.
* <p>
- * This codec is meant to be a replacement for standard Java classes
- * {@link java.net.URLEncoder} and {@link java.net.URLDecoder}
- * on older Java platforms, as these classes in Java versions below
+ * This codec is meant to be a replacement for standard Java classes {@link java.net.URLEncoder} and
+ * {@link java.net.URLDecoder} on older Java platforms, as these classes in Java versions below
* 1.4 rely on the platform's default charset encoding.
- * </p>
+ * <p>
+ * This class is immutable and thread-safe.
*
- * <p>This class is immutable and thread-safe.</p>
+ * @see <a href="http://www.w3.org/TR/html4/interact/forms.html#h-17.13.4.1">Chapter 17.13.4 'Form content types'</a>
+ * of the <a href="http://www.w3.org/TR/html4/">HTML 4.01 Specification<a>
*
* @since 1.2
* @version $Id$