You are viewing a plain text version of this content. The canonical link for it is here.
Posted to solr-dev@lucene.apache.org by "Yonik Seeley (JIRA)" <ji...@apache.org> on 2009/03/21 22:14:50 UTC

[jira] Commented: (SOLR-1079) Rename omitTf to omitTermFreqAndPositions

    [ https://issues.apache.org/jira/browse/SOLR-1079?page=com.atlassian.jira.plugin.system.issuetabpanels:comment-tabpanel&focusedCommentId=12688078#action_12688078 ] 

Yonik Seeley commented on SOLR-1079:
------------------------------------

We need to get the latest lucene libs and adjust our code, but I'd vote for keeping our schema flag as "omitTf" for the following reasons:

- omitTermFreqAndPositions is looong
- it's not comprehensive anyway - omitTermFreqAndPositionsAndPayloads? ;-P
- and still... some people may not realize that phrase queries need positions, or that things that don't look like phrase queries may get turned into phrase queries (foo-bar and WDF for example).
- most Solr users don't *need* to know what it does... we default non-text fields to use omitTf... text fields should always default to that.
- almost no one will have pre-conceived notions about what "omitTf"  will do anyway... they will need to look at the description. Hence this is really only a documentation problem, not a naming problem.

On the other side of the coin.... if we do the correct defaults (which I believe we do) then omitTermFreqAndPositions  would  rarely appear in anyone's schema anyway.  Only the most advanced user would choose to change the defaults and for them a consistency with lucene naming may be desired?

After all that, I guess I should have argued against Lucene renaming omitTf... and at this point Solr should probably just follow suit?



> Rename omitTf to omitTermFreqAndPositions
> -----------------------------------------
>
>                 Key: SOLR-1079
>                 URL: https://issues.apache.org/jira/browse/SOLR-1079
>             Project: Solr
>          Issue Type: Improvement
>          Components: documentation, update
>            Reporter: Shalin Shekhar Mangar
>            Assignee: Shalin Shekhar Mangar
>            Priority: Minor
>             Fix For: 1.4
>
>
> LUCENE-1561 has renamed omitTf.
> See http://www.lucidimagination.com/search/document/376c1c12dd464164/lucene_1561_and_omittf

-- 
This message is automatically generated by JIRA.
-
You can reply to this email to add a comment to the issue online.