You are viewing a plain text version of this content. The canonical link for it is here.
Posted to dev@avro.apache.org by "Mikhail Koviazin (Jira)" <ji...@apache.org> on 2024/02/20 20:07:00 UTC
[jira] [Created] (AVRO-3944) Fix CMake warning
Mikhail Koviazin created AVRO-3944:
--------------------------------------
Summary: Fix CMake warning
Key: AVRO-3944
URL: https://issues.apache.org/jira/browse/AVRO-3944
Project: Apache Avro
Issue Type: Task
Components: c++
Reporter: Mikhail Koviazin
Assignee: Mikhail Koviazin
Currently cmake_minimum_version is set to 3.1. This triggers the warning at least with cmake 3.27.9:
{code:java}
CMake Deprecation Warning at CMakeLists.txt:19 (cmake_minimum_required):
Compatibility with CMake < 3.5 will be removed from a future version of
CMake. Update the VERSION argument <min> value or use a ...<max> suffix to tell
CMake that the project does not need compatibility with older versions.
{code}
Updating cmake_minimum_version to 3.5 should be safe since 3.5.0 was released in 2016, and is available on all supported distros according to [https://pkgs.org/search/?q=cmake&on=name] .
--
This message was sent by Atlassian Jira
(v8.20.10#820010)