You are viewing a plain text version of this content. The canonical link for it is here.
Posted to issues@cordova.apache.org by "Kai Schätzl (JIRA)" <ji...@apache.org> on 2016/05/17 13:27:13 UTC

[jira] [Commented] (CB-11214) prompt() defaultText on Android sets placeholder text instead of default text

    [ https://issues.apache.org/jira/browse/CB-11214?page=com.atlassian.jira.plugin.system.issuetabpanels:comment-tabpanel&focusedCommentId=15286607#comment-15286607 ] 

Kai Schätzl commented on CB-11214:
----------------------------------

Compare https://issues.apache.org/jira/browse/CB-11281 that I just submitted. I read your bug report before that and may have misunderstood it, thus submitting "my" bug as a different one. However, after reading your's again I think this might be the same issue, just on another platform. What do you consider the correct behavior? Use the defaultText as the value for input1 or use "" for it if the user doesn't enter anything by himself?

> prompt() defaultText on Android sets placeholder text instead of default text
> -----------------------------------------------------------------------------
>
>                 Key: CB-11214
>                 URL: https://issues.apache.org/jira/browse/CB-11214
>             Project: Apache Cordova
>          Issue Type: Bug
>          Components: Plugin Dialogs
>         Environment: Android
>            Reporter: Chris Armstrong
>              Labels: Android, easyfix, triaged
>
> On Android, a string passed for the defaultText parameter to prompt() is instead used as the placeholder text (i.e. the text shown when the box is empty). This behaviour is inconsistent with other platforms and incorrect compared to the documentation.
> The offending code (from line 282):
> {{
>     public synchronized void prompt(final String message, final String title, final JSONArray buttonLabels, final String defaultText, final CallbackContext callbackContext) {
> ...
>                 promptInput.setHint(defaultText);
> }}
> Instead of EditText.setHint(), EditText.setText() should be called with the default text.



--
This message was sent by Atlassian JIRA
(v6.3.4#6332)

---------------------------------------------------------------------
To unsubscribe, e-mail: issues-unsubscribe@cordova.apache.org
For additional commands, e-mail: issues-help@cordova.apache.org