You are viewing a plain text version of this content. The canonical link for it is here.
Posted to issues@ignite.apache.org by "Mikhail Efremov (Jira)" <ji...@apache.org> on 2026/03/02 06:18:00 UTC
[jira] [Created] (IGNITE-28023) Improve code and logging on client's transaction handling
Mikhail Efremov created IGNITE-28023:
----------------------------------------
Summary: Improve code and logging on client's transaction handling
Key: IGNITE-28023
URL: https://issues.apache.org/jira/browse/IGNITE-28023
Project: Ignite
Issue Type: Bug
Reporter: Mikhail Efremov
*Description*
Code in {{DirectTxUtils}} is hard to read and analyse and in particular logs in {{#writeTx}} in {{else}} case on {{tx0.channel() != out.clientChannel()}} doesn't provide any context why this happens and why we can not retry this tx automatically. {{WriteContext}} violates incapsulation and it's not clear for example why not marked as {{@Nullable}} {{firstReqFut}} field inside the {{#writeTx}} method is checked on {{null}} value.
*Motivation*
We should maintain code clean, readable and explainable, logs should be better for user.
*Definition of Done*
# Code is refactored, incapsulation should be improved.
# Logs are enriched with a context of the situation.
# If possible we should automatically retry at least implicit transactions.
--
This message was sent by Atlassian Jira
(v8.20.10#820010)