You are viewing a plain text version of this content. The canonical link for it is here.
Posted to hdfs-issues@hadoop.apache.org by "Dongming Liang (JIRA)" <ji...@apache.org> on 2015/03/26 17:44:54 UTC

[jira] [Commented] (HDFS-4838) HDFS should use the new methods added in HADOOP-9574

    [ https://issues.apache.org/jira/browse/HDFS-4838?page=com.atlassian.jira.plugin.system.issuetabpanels:comment-tabpanel&focusedCommentId=14382190#comment-14382190 ] 

Dongming Liang commented on HDFS-4838:
--------------------------------------

I'll pick this up.

> HDFS should use the new methods added in HADOOP-9574
> ----------------------------------------------------
>
>                 Key: HDFS-4838
>                 URL: https://issues.apache.org/jira/browse/HDFS-4838
>             Project: Hadoop HDFS
>          Issue Type: Improvement
>            Reporter: Jian He
>
> HADOOP-9574 copies addPersistedDelegationToken in hdfs.DelegationTokenSecretManager to common.AbstractDelegationTokenSecretManager. HDFS code should be removed and should instead use the code in common.
> Also, Is it possible to rename logUpdateMasterKey to storeNewMasterKey AND logExpireToken to removeStoredToken for persisting and recovering keys/tokens?
> These methods are likely to be common methods and be used by overridden secretManager.



--
This message was sent by Atlassian JIRA
(v6.3.4#6332)