You are viewing a plain text version of this content. The canonical link for it is here.
Posted to issues@maven.apache.org by "Petar Tahchiev (JIRA)" <ji...@apache.org> on 2016/08/12 11:11:20 UTC
[jira] [Assigned] (ARCHETYPE-495) rename
ArchetypeGenerator.generateArchetype() to
ProjectGenerator.generateProject()
[ https://issues.apache.org/jira/browse/ARCHETYPE-495?page=com.atlassian.jira.plugin.system.issuetabpanels:all-tabpanel ]
Petar Tahchiev reassigned ARCHETYPE-495:
----------------------------------------
Assignee: Petar Tahchiev
> rename ArchetypeGenerator.generateArchetype() to ProjectGenerator.generateProject()
> -----------------------------------------------------------------------------------
>
> Key: ARCHETYPE-495
> URL: https://issues.apache.org/jira/browse/ARCHETYPE-495
> Project: Maven Archetype
> Issue Type: Improvement
> Components: Generator
> Affects Versions: 2.4
> Reporter: Hervé Boutemy
> Assignee: Petar Tahchiev
> Fix For: 2.5
>
>
> {{ArchetypeGenerator.generateArchetype()}} is really misleading: it's not about generating an archetype, but about generating *a project from* an archetype
> this API cause strong confusion in the archetype lifecycle: sample project -> archetype project -> archetype artifact -> generated project
--
This message was sent by Atlassian JIRA
(v6.3.4#6332)