You are viewing a plain text version of this content. The canonical link for it is here.
Posted to dev@isis.apache.org by "Daniel Keir Haywood (Jira)" <ji...@apache.org> on 2021/03/05 10:22:00 UTC

[jira] [Resolved] (ISIS-2564) Rationalize mixee interfaces; fix derivation of sequence for EntityChanges

     [ https://issues.apache.org/jira/browse/ISIS-2564?page=com.atlassian.jira.plugin.system.issuetabpanels:all-tabpanel ]

Daniel Keir Haywood resolved ISIS-2564.
---------------------------------------
    Resolution: Fixed

> Rationalize mixee interfaces; fix derivation of sequence for EntityChanges
> --------------------------------------------------------------------------
>
>                 Key: ISIS-2564
>                 URL: https://issues.apache.org/jira/browse/ISIS-2564
>             Project: Isis
>          Issue Type: Improvement
>            Reporter: Daniel Keir Haywood
>            Assignee: Daniel Keir Haywood
>            Priority: Minor
>             Fix For: 2.0.0-M5
>
>
> A number of HasXxx had been moved to the commons module, but these are intended for domain objects to implement in order that they can participate as mixees for framework-provided mixins.
> Also, make more explicit the roles around interactions and transactions:
>  * HasUniqueId to HasInteractionId
>  * rename RepresentsInteractionMemberExecution to HasTransactionId (because the sequence here was for transactions, not nested executions).
> In course of this, discovered that the derivation of getSequence for EntityChanges was wrong, and should use SequenceType of TRANSACTION.  Fix, and renames the Sequence enum to SequenceType and change the internal Interaction#next to use SequenceType rather than an untyped string.  



--
This message was sent by Atlassian Jira
(v8.3.4#803005)