You are viewing a plain text version of this content. The canonical link for it is here.
Posted to jira@kafka.apache.org by "Chia-Ping Tsai (Jira)" <ji...@apache.org> on 2024/05/07 06:12:00 UTC
[jira] [Commented] (KAFKA-16677) Replace ClusterType#ALL and ClusterType#DEFAULT by Array
[ https://issues.apache.org/jira/browse/KAFKA-16677?page=com.atlassian.jira.plugin.system.issuetabpanels:comment-tabpanel&focusedCommentId=17844148#comment-17844148 ]
Chia-Ping Tsai commented on KAFKA-16677:
----------------------------------------
For another, we can simplify the code (https://github.com/apache/kafka/blob/trunk/tools/src/test/java/org/apache/kafka/tools/consumer/group/ConsumerGroupCommandTestUtils.java#L77)
{code:java}
// Some comments here
ClusterConfig raftWithNewGroupCoordinator = ClusterConfig.defaultBuilder()
.setTypes(Arrays.asList(KRAFT, CO_KRAFT))
.setName("newGroupCoordinator")
.setServerProperties(serverProperties)
.build();
{code}
> Replace ClusterType#ALL and ClusterType#DEFAULT by Array
> --------------------------------------------------------
>
> Key: KAFKA-16677
> URL: https://issues.apache.org/jira/browse/KAFKA-16677
> Project: Kafka
> Issue Type: Improvement
> Reporter: Chia-Ping Tsai
> Assignee: Chia-Ping Tsai
> Priority: Minor
>
> Both ClusterType#ALL and ClusterType#DEFAULT are a kind of "tag" instead of true "type". It seems to me they can be removed by using Array. For example:
> ClusterType#ALL -> {Type.ZK, Type.KRAFT, Type.CO_KRAFT}
> ClusterType#DEFAULT -> {}
> There are two benefits
> 1. That is more readable for "ALL type".
> 2. We don't throw the awkward "exception" when seeing "DEFAULT".
--
This message was sent by Atlassian Jira
(v8.20.10#820010)