You are viewing a plain text version of this content. The canonical link for it is here.
Posted to commits@pinot.apache.org by ja...@apache.org on 2026/05/12 07:19:54 UTC
(pinot) branch master updated (5fd31838a1e -> 7fe517afce7)
This is an automated email from the ASF dual-hosted git repository.
Jackie-Jiang pushed a change to branch master
in repository https://gitbox.apache.org/repos/asf/pinot.git
from 5fd31838a1e [pinot-server/ proactive-query-killing] (1/2) add initial SPI implementation for supporting query killing based on Scan Cost (#18102)
add 7fe517afce7 refactor: rename MapDataSource getKeyXXX → getXXX for clarity (#18437)
No new revisions were added by this update.
Summary of changes:
.../core/operator/blocks/ProjectionBlock.java | 2 +-
.../transform/function/ItemTransformFunction.java | 2 +-
.../local/segment/index/map/BaseMapDataSource.java | 10 +++---
.../segment/index/map/ImmutableMapDataSource.java | 4 +--
.../segment/spi/datasource/MapDataSource.java | 36 +++++++++-------------
5 files changed, 23 insertions(+), 31 deletions(-)
---------------------------------------------------------------------
To unsubscribe, e-mail: commits-unsubscribe@pinot.apache.org
For additional commands, e-mail: commits-help@pinot.apache.org