You are viewing a plain text version of this content. The canonical link for it is here.
Posted to issues@cxf.apache.org by "Dan Diephouse (JIRA)" <ji...@apache.org> on 2007/04/23 05:55:17 UTC

[jira] Closed: (CXF-260) Clean up Soap headers usage

     [ https://issues.apache.org/jira/browse/CXF-260?page=com.atlassian.jira.plugin.system.issuetabpanels:all-tabpanel ]

Dan Diephouse closed CXF-260.
-----------------------------

    Resolution: Fixed

> Clean up Soap headers usage
> ---------------------------
>
>                 Key: CXF-260
>                 URL: https://issues.apache.org/jira/browse/CXF-260
>             Project: CXF
>          Issue Type: Improvement
>          Components: Core
>    Affects Versions: 2.0-M1
>            Reporter: Dan Diephouse
>         Assigned To: Daniel Kulp
>             Fix For: 2.0-RC
>
>
> Currently ReadHeadersInterceptor does:
> message.setHeaders(Element.class, element);
> message.put(Element.class, element);      
> (line 90)
> This should not happen. Only SoapMessage.headers should be set. 
> In addition SoapInPostInterceptor uses message.get(Element.class) when it should be using SoapMEssage.getHeaders(). The SoapInPostInterceptor should probably be renamed something more useful like HeaderDatabindingInterceptor.
> We should also rework SoapHeader.getHeaders() to only return an Element. I don't think getHeaders(Class type) is the right way to handle multiple header formats.

-- 
This message is automatically generated by JIRA.
-
You can reply to this email to add a comment to the issue online.