You are viewing a plain text version of this content. The canonical link for it is here.
Posted to user@zookeeper.apache.org by R Krishna <kr...@gmail.com> on 2017/02/11 00:54:28 UTC
Kafka 0.10 and ZK 3.4.8 dependency upgrade
We tested Kafka 0.9 with zookeeper_3.4.5+dfsg-1_all.deb on Ubuntu 14.04
Trusty and want to use stable release of kafka_2.11-0.10.1.1 (hope, this
has no critical issues) to avoid known producer issues, but, apparently
this needs an upgraded ZK 3.4.8+ https://kafka.apache.org/
documentation/#zkversion which is only available in Ubuntu 16.04 Xenial.
Manual installation of ZK 3.4.8 deb package in Trusty had dependency
failures.
Need help to understand why ZK upgrade is necessary?
http://zookeeper.apache.org/releases.html talks about
*"The release fixes a critical bug in 3.4.5 that could prevent a server
from joining an established ensemble. SeeZooKeeper 3.4.6 Release Notes
<http://zookeeper.apache.org/doc/r3.4.6/releasenotes.html> for details"*
http://packages.ubuntu.com/source/trusty/zookeeper
http://packages.ubuntu.com/xenial/zookeeper
https://tracker.debian.org/pkg/zookeeper
--
Krishna