You are viewing a plain text version of this content. The canonical link for it is here.
Posted to dev@avalon.apache.org by Leo Simons <le...@apache.org> on 2002/04/03 23:22:45 UTC
excalibur package naming (RE: [VOTE] Should Command be a sub of event?)
Most important *event* in medieval times:
joust
market
*Systems* used in medieval times:
nobility (duke),
monarchy (king),
sword (knight),
armor (platemail),
fortress (castle),
sorcery (morgana),
guild (peasanty),
...
*Components* in medieval, mythical england times:
spell (cantrip),
weapon (sword, lance),
...
*Component management*:
spellbook (arcana),
library (tome),
librarian (sage),
...
you could rename:
excalibur.event -> excalibur.joust,
excalibur.system -> excalibur.fortress,
excalibur.component -> excalibur.sage
if you want more, I used to be (still am, to
some extend) a big AD&D freak (me, I'm geek to
the bone :) so I can dig up a _lot_ more for
you if you have specific requests...you could
have excalibur.component named to
excalibur.sword and different component
imps and manager excalibur.broadsword,
excalibur.katana, excalibur.longsword, ...
note: if we ever do rename framework I think
"camelot" would be the term for it (even though
that used to be something else), as camelot
really was the core of Avalon =)
cheers,
- Leo
> -----Oorspronkelijk bericht-----
> Van: Berin Loritsch [mailto:bloritsch@apache.org]
> Verzonden: Wednesday, April 03, 2002 3:32 PM
> Aan: 'Avalon Developers List'
> Onderwerp: RE: [VOTE] Should Command be a sub of event?
>
>
> > -----Original Message-----
> > From: Peter Donald [mailto:peter@apache.org]
> >
> > So what if you can use the command pattern without events? We
> > are talking
> > about a specific implementation that is tied to directly to
> > events and the
> > event package ;) I definetly think it should be a subpackage.
>
>
> Cool, I can make it happen.
>
>
> > BTW Berin this is why I dislike generic names like command,
> > event and system
> > because it causes confuision not clarity ;) Codenames or
> > other abstract names
> > allow much easier understanding after initial learning curve.
> > They also make
> > it MUCH easier to have different implementations of same
> > style of component
> > or even different versions.
>
>
> I confess, my imagination is not good for coming up with abstract
> names. If you could help me out, I would appreciate it :)
>
> The benefit of *event* is that it conveys exactly what it is about:
> avent processing.
>
> However, your comments about .system and .component are well taken,
> and those names (at least .system) are placeholders until we come
> up with a name we like.
>
> Can someone help me with a name for .system?
>
> galahad (sp?) Sir Galahad, the green knight
> lancelot
> roundtable
>
>
>
> --
> To unsubscribe, e-mail:
<ma...@jakarta.apache.org>
For additional commands, e-mail: <ma...@jakarta.apache.org>
--
To unsubscribe, e-mail: <ma...@jakarta.apache.org>
For additional commands, e-mail: <ma...@jakarta.apache.org>
RE: excalibur package naming (RE: [VOTE] Should Command be a sub of event?)
Posted by Berin Loritsch <bl...@apache.org>.
Done
> -----Original Message-----
> From: Peter Donald [mailto:peter@apache.org]
> Sent: Wednesday, April 03, 2002 5:19 PM
> To: Avalon Developers List
> Subject: Re: excalibur package naming (RE: [VOTE] Should
> Command be a sub of event?)
>
>
> On Thu, 4 Apr 2002 07:42, Berin Loritsch wrote:
> > excalibur.system->excalibur.fortress
> >
> > I _really_ like that. Consider it a +1 from me.
>
> +1
>
> --
> Cheers,
>
> Pete
>
> "So long as the people do not care to exercise their
> freedom, those who wish to tyrannize will do so..." -
> Voltairine de Cleyre
>
> --
> To unsubscribe, e-mail:
> <mailto:avalon-dev-> unsubscribe@jakarta.apache.org>
> For
> additional commands,
> e-mail: <ma...@jakarta.apache.org>
>
--
To unsubscribe, e-mail: <ma...@jakarta.apache.org>
For additional commands, e-mail: <ma...@jakarta.apache.org>
Re: excalibur package naming (RE: [VOTE] Should Command be a sub of event?)
Posted by Peter Donald <pe...@apache.org>.
On Thu, 4 Apr 2002 07:42, Berin Loritsch wrote:
> excalibur.system->excalibur.fortress
>
> I _really_ like that. Consider it a +1 from me.
+1
--
Cheers,
Pete
"So long as the people do not care to exercise their freedom, those
who wish to tyrannize will do so..." - Voltairine de Cleyre
--
To unsubscribe, e-mail: <ma...@jakarta.apache.org>
For additional commands, e-mail: <ma...@jakarta.apache.org>
RE: excalibur package naming (RE: [VOTE] Should Command be a sub of event?)
Posted by Leo Sutic <le...@inspireinfrastructure.com>.
> From: Berin Loritsch [mailto:bloritsch@apache.org]
>
> sounds decent--but maybe we could do something better.
> Perhaps play on the messenger aspect (towncryer?)
>
> excalibur.system->excalibur.fortress
>
> I _really_ like that. Consider it a +1 from me.
>
-1
Still trying to figure out whether this is an April Fool's joke
that started two days ago, but I'd like to make a case for
boredom, three-piece suits (gray ones) propose:
excalibur.system -> excalibur.container
If people were bewildered by the size of Excalibur before it
was split up, just consider a newbie surfing in on the Avalon
site and shaving to pick a subproject between:
joust
robberbaron
fairmaiden
There is just no way that a newbie will be able to keep eveything
in their head:
"OK, so the Events in 'joust' go to the EventHandler that uses
the ComponentManager from... uh... <look in docs> 'fortress'..."
Repeat the above for the poor maintenance programmer. K3w1 names
are fine for entire projects where a descriptive name is either
unmanageable or ends up being not really descriptive due to the scope:
Excalibur -> LotsOfComponentsForAvalonFramework
But please do not extend this too far down the project hierarchy. It
makes the source code incomprehensible.
On another, more personal note, it will make it very difficult
for me to 'sell' Avalon internally: Having one cool codename is fine,
but if I were to list ten or more when briefing the CTO on what
I intend to do...
...I will be laughed out of the room.
...the Avalon project will get a 'geeks only' stamp on it.
/LS
--
To unsubscribe, e-mail: <ma...@jakarta.apache.org>
For additional commands, e-mail: <ma...@jakarta.apache.org>
RE: excalibur package naming (RE: [VOTE] Should Command be a sub of event?)
Posted by Berin Loritsch <bl...@apache.org>.
> -----Original Message-----
> From: Leo Simons [mailto:leosimons@apache.org]
>
> Most important *event* in medieval times:
> joust
> market
>
> *Systems* used in medieval times:
> nobility (duke),
> monarchy (king),
> sword (knight),
> armor (platemail),
> fortress (castle),
> sorcery (morgana),
> guild (peasanty),
> ...
Don't forget the barons :) (Those dirty scoundrels)
>
> *Components* in medieval, mythical england times:
> spell (cantrip),
> weapon (sword, lance),
> ...
>
> *Component management*:
> spellbook (arcana),
> library (tome),
> librarian (sage),
> ...
>
> you could rename:
> excalibur.event -> excalibur.joust,
> excalibur.system -> excalibur.fortress,
> excalibur.component -> excalibur.sage
excalibur.event -> excalibur.joust
sounds decent--but maybe we could do something better.
Perhaps play on the messenger aspect (towncryer?)
excalibur.system->excalibur.fortress
I _really_ like that. Consider it a +1 from me.
excalibur.component -> ****
We have to support the old package name because of
backwards compatibility. :(
> if you want more, I used to be (still am, to
> some extend) a big AD&D freak (me, I'm geek to
> the bone :) so I can dig up a _lot_ more for
> you if you have specific requests...you could
> have excalibur.component named to
> excalibur.sword and different component
> imps and manager excalibur.broadsword,
> excalibur.katana, excalibur.longsword, ...
>
> note: if we ever do rename framework I think
> "camelot" would be the term for it (even though
> that used to be something else), as camelot
> really was the core of Avalon =)
:)
--
To unsubscribe, e-mail: <ma...@jakarta.apache.org>
For additional commands, e-mail: <ma...@jakarta.apache.org>