You are viewing a plain text version of this content. The canonical link for it is here.
Posted to issues@trafodion.apache.org by "Rohit Jain (JIRA)" <ji...@apache.org> on 2016/02/26 20:44:18 UTC

[jira] [Updated] (TRAFODION-1855) Rename odb

     [ https://issues.apache.org/jira/browse/TRAFODION-1855?page=com.atlassian.jira.plugin.system.issuetabpanels:all-tabpanel ]

Rohit Jain updated TRAFODION-1855:
----------------------------------
    Issue Type: Improvement  (was: Bug)

> Rename odb
> ----------
>
>                 Key: TRAFODION-1855
>                 URL: https://issues.apache.org/jira/browse/TRAFODION-1855
>             Project: Apache Trafodion
>          Issue Type: Improvement
>          Components: db-utility-odb
>    Affects Versions: any
>            Reporter: Rohit Jain
>            Priority: Minor
>             Fix For: 2.0-incubating
>
>   Original Estimate: 24h
>  Remaining Estimate: 24h
>
> The name odb for the load utility has a history that is not relevant to its eventual evolution as a tool for loading and does not mean anything, or convey what it is, or is for.  Essentially it is a meaningless name that means something to developers but has no relevance to users.  So, I am proposing that we change the name.  We can change the name to "loadb" or "lodb" for brevity although pronounced the same way.  That keeps it close to its original name.
> The utility does a lot more than load.  It, among other things, can be used for extracts and moving data in parallel at very high speeds (since it just moves the ODBC buffers from the source to the target), from and to multiple databases, including Trafodion.  So one could go with a more elaborate name to encompass its capabilities.  Maybe the community could get involved in naming and choosing a name once its capabilities are shared with the community.  
> But certainly, we need to change it from odb to something else.  Sooner the better.



--
This message was sent by Atlassian JIRA
(v6.3.4#6332)