You are viewing a plain text version of this content. The canonical link for it is here.
Posted to dev@pivot.apache.org by "Michael Allman (JIRA)" <ji...@apache.org> on 2010/06/22 22:45:55 UTC

[jira] Updated: (PIVOT-540) Menu.java is missing some @Override annotations

     [ https://issues.apache.org/jira/browse/PIVOT-540?page=com.atlassian.jira.plugin.system.issuetabpanels:all-tabpanel ]

Michael Allman updated PIVOT-540:
---------------------------------

    Attachment: Menu_Overrides.patch

Patch file.  Apply with patch -p1 < Menu_Overrides.patch in the pivot trunk directory.

> Menu.java is missing some @Override annotations
> -----------------------------------------------
>
>                 Key: PIVOT-540
>                 URL: https://issues.apache.org/jira/browse/PIVOT-540
>             Project: Pivot
>          Issue Type: Bug
>          Components: wtk
>         Environment: Using Pivot svn trunk
>            Reporter: Michael Allman
>         Attachments: Menu_Overrides.patch
>
>
> wtk/src/org/apache/pivot/wtk/Menu.java is missing two @Override annotations.
> You can catch these easily if you configure your compiler to flag missing @Override annotations as errors.

-- 
This message is automatically generated by JIRA.
-
You can reply to this email to add a comment to the issue online.


Re: [jira] Updated: (PIVOT-540) Menu.java is missing some @Override annotations

Posted by Greg Brown <gk...@mac.com>.
OTOH, I suppose the "name" property in Menu could be changed to something else. Not sure what, though - any suggestions?

I suspect that renaming Component's "name" property to "ID" is probably best, but if we can come up with a better name for Menu's "name", that would be OK too.

On Jun 22, 2010, at 5:51 PM, Greg Brown wrote:

> Thanks for catching this. The reason these methods are missing @Override is because they were created before get/setName() was added to Component. They have a slightly different meaning in the context of a menu, so I am actually thinking that we should rename Component#getName() and setName() to getID() and setID(). Comments?
> 
> On Jun 22, 2010, at 4:45 PM, Michael Allman (JIRA) wrote:
> 
>> 
>>    [ https://issues.apache.org/jira/browse/PIVOT-540?page=com.atlassian.jira.plugin.system.issuetabpanels:all-tabpanel ]
>> 
>> Michael Allman updated PIVOT-540:
>> ---------------------------------
>> 
>>   Attachment: Menu_Overrides.patch
>> 
>> Patch file.  Apply with patch -p1 < Menu_Overrides.patch in the pivot trunk directory.
>> 
>>> Menu.java is missing some @Override annotations
>>> -----------------------------------------------
>>> 
>>>               Key: PIVOT-540
>>>               URL: https://issues.apache.org/jira/browse/PIVOT-540
>>>           Project: Pivot
>>>        Issue Type: Bug
>>>        Components: wtk
>>>       Environment: Using Pivot svn trunk
>>>          Reporter: Michael Allman
>>>       Attachments: Menu_Overrides.patch
>>> 
>>> 
>>> wtk/src/org/apache/pivot/wtk/Menu.java is missing two @Override annotations.
>>> You can catch these easily if you configure your compiler to flag missing @Override annotations as errors.
>> 
>> -- 
>> This message is automatically generated by JIRA.
>> -
>> You can reply to this email to add a comment to the issue online.
>> 
> 


Re: [jira] Updated: (PIVOT-540) Menu.java is missing some @Override annotations

Posted by Greg Brown <gk...@mac.com>.
Thanks for catching this. The reason these methods are missing @Override is because they were created before get/setName() was added to Component. They have a slightly different meaning in the context of a menu, so I am actually thinking that we should rename Component#getName() and setName() to getID() and setID(). Comments?

On Jun 22, 2010, at 4:45 PM, Michael Allman (JIRA) wrote:

> 
>     [ https://issues.apache.org/jira/browse/PIVOT-540?page=com.atlassian.jira.plugin.system.issuetabpanels:all-tabpanel ]
> 
> Michael Allman updated PIVOT-540:
> ---------------------------------
> 
>    Attachment: Menu_Overrides.patch
> 
> Patch file.  Apply with patch -p1 < Menu_Overrides.patch in the pivot trunk directory.
> 
>> Menu.java is missing some @Override annotations
>> -----------------------------------------------
>> 
>>                Key: PIVOT-540
>>                URL: https://issues.apache.org/jira/browse/PIVOT-540
>>            Project: Pivot
>>         Issue Type: Bug
>>         Components: wtk
>>        Environment: Using Pivot svn trunk
>>           Reporter: Michael Allman
>>        Attachments: Menu_Overrides.patch
>> 
>> 
>> wtk/src/org/apache/pivot/wtk/Menu.java is missing two @Override annotations.
>> You can catch these easily if you configure your compiler to flag missing @Override annotations as errors.
> 
> -- 
> This message is automatically generated by JIRA.
> -
> You can reply to this email to add a comment to the issue online.
>