You are viewing a plain text version of this content. The canonical link for it is here.
Posted to issues@spark.apache.org by "Xiao Li (JIRA)" <ji...@apache.org> on 2017/04/04 06:32:41 UTC

[jira] [Resolved] (SPARK-20067) Unify and Clean Up Desc Commands Using Catalog Interface

     [ https://issues.apache.org/jira/browse/SPARK-20067?page=com.atlassian.jira.plugin.system.issuetabpanels:all-tabpanel ]

Xiao Li resolved SPARK-20067.
-----------------------------
       Resolution: Fixed
    Fix Version/s: 2.2.0

> Unify and Clean Up Desc Commands Using Catalog Interface
> --------------------------------------------------------
>
>                 Key: SPARK-20067
>                 URL: https://issues.apache.org/jira/browse/SPARK-20067
>             Project: Spark
>          Issue Type: Improvement
>          Components: SQL
>    Affects Versions: 2.1.0
>            Reporter: Xiao Li
>            Assignee: Xiao Li
>             Fix For: 2.2.0
>
>
> We should unify and clean up the outputs of `DESC EXTENDED/FORMATTED` and `SHOW TABLE EXTENDED` by moving the logics into the Catalog interface. The output formats are improved. We also add the missing attributes. It impacts the DDL commands like `SHOW TABLE EXTENDED`, `DESC EXTENDED` and `DESC FORMATTED`.
> In addition, by following what we did in Dataset API `printSchema`, we can use `treeString` to show the schema in the more readable way. 



--
This message was sent by Atlassian JIRA
(v6.3.15#6346)

---------------------------------------------------------------------
To unsubscribe, e-mail: issues-unsubscribe@spark.apache.org
For additional commands, e-mail: issues-help@spark.apache.org