You are viewing a plain text version of this content. The canonical link for it is here.
Posted to issues@zookeeper.apache.org by "Sourabh Sarvotham Parkala (Jira)" <ji...@apache.org> on 2021/12/10 14:53:00 UTC
[jira] [Commented] (ZOOKEEPER-4272) Upgrade Netty library to > 4.1.60 due to security vulnerability CVE-2021-21295
[ https://issues.apache.org/jira/browse/ZOOKEEPER-4272?page=com.atlassian.jira.plugin.system.issuetabpanels:comment-tabpanel&focusedCommentId=17457185#comment-17457185 ]
Sourabh Sarvotham Parkala commented on ZOOKEEPER-4272:
------------------------------------------------------
Hello Team,
Thanks for the fix.
Is there a specific release date for 3.5.10?
Thanks
Sourabh
> Upgrade Netty library to > 4.1.60 due to security vulnerability CVE-2021-21295
> ------------------------------------------------------------------------------
>
> Key: ZOOKEEPER-4272
> URL: https://issues.apache.org/jira/browse/ZOOKEEPER-4272
> Project: ZooKeeper
> Issue Type: Bug
> Components: security
> Affects Versions: 3.6.2
> Reporter: Dominique Mongelli
> Assignee: Ayush Mantri
> Priority: Major
> Labels: pull-request-available
> Fix For: 3.5.10, 3.6.3, 3.8.0, 3.7.1
>
> Time Spent: 1.5h
> Remaining Estimate: 0h
>
> Our security tool raised the following security flaw on zookeeper 3.6.2: [https://nvd.nist.gov/vuln/detail/CVE-2021-21295]
> It is a vulnerability related to jar *netty-codec-4.1.50.Final.jar*.
> Based on netty issue tracker, the vulnerability is fixed in 4.1.60.Final: [https://github.com/netty/netty/security/advisories/GHSA-wm47-8v5p-wjpj]
--
This message was sent by Atlassian Jira
(v8.20.1#820001)