You are viewing a plain text version of this content. The canonical link for it is here.
Posted to dev@syncope.apache.org by Francesco Chicchiriccò <il...@apache.org> on 2026/09/14 08:46:32 UTC
CVE-2026-86460: Apache Syncope: Cypher Injection via FIQL Search on Neo4j Persistence
Severity: moderate
Affected versions:
- Apache Syncope (org.apache.syncope.core:syncope-core-persistence-neo4j) 3.0.0-M0 through 3.0.16
- Apache Syncope (org.apache.syncope.core:syncope-core-persistence-neo4j) 4.0.0-M0 through 4.0.7
- Apache Syncope (org.apache.syncope.core:syncope-core-persistence-neo4j) 4.1.0-M0 through 4.1.2
Description:
Cypher injection vulnerability in the Neo4j persistence layer when processing some FIQL search conditions.
This issue affects Apache Syncope: from 3.0.0-M0 through 3.0.16, from 4.0.0-M0 through 4.0.7, from 4.1.0-M0 through 4.1.2.
Users are recommended to upgrade to version 4.0.8 / 4.1.3, which fix this issue.
Credit:
CyberLeo (finder)
Ho1aAs (finder)
References:
https://syncope.apache.org/
https://www.cve.org/CVERecord?id=CVE-2026-86460