You are viewing a plain text version of this content. The canonical link for it is here.
Posted to hdfs-issues@hadoop.apache.org by "László Bence Nagy (JIRA)" <ji...@apache.org> on 2017/03/17 13:42:41 UTC

[jira] [Updated] (HDFS-11541) Call RawErasureEncoder and RawErasureDecoder release() methods

     [ https://issues.apache.org/jira/browse/HDFS-11541?page=com.atlassian.jira.plugin.system.issuetabpanels:all-tabpanel ]

László Bence Nagy updated HDFS-11541:
-------------------------------------
    Component/s:     (was: native)
        Summary: Call RawErasureEncoder and RawErasureDecoder release() methods  (was: RawErasureEncoder and RawErasureDecoder release() methods not called)

> Call RawErasureEncoder and RawErasureDecoder release() methods
> --------------------------------------------------------------
>
>                 Key: HDFS-11541
>                 URL: https://issues.apache.org/jira/browse/HDFS-11541
>             Project: Hadoop HDFS
>          Issue Type: Sub-task
>          Components: erasure-coding
>    Affects Versions: 3.0.0-alpha2
>            Reporter: László Bence Nagy
>
> The *RawErasureEncoder* and *RawErasureDecoder* classes have _release()_ methods which are not called from the source code. These methods should be called when an encoding or decoding operation is finished so that the dynamically allocated resources can be freed. Underlying native plugins can also rely on these functions to release their resources.



--
This message was sent by Atlassian JIRA
(v6.3.15#6346)

---------------------------------------------------------------------
To unsubscribe, e-mail: hdfs-issues-unsubscribe@hadoop.apache.org
For additional commands, e-mail: hdfs-issues-help@hadoop.apache.org