You are viewing a plain text version of this content. The canonical link for it is here.
Posted to jira@kafka.apache.org by "tony tang (Jira)" <ji...@apache.org> on 2026/06/05 18:00:00 UTC
[jira] [Updated] (KAFKA-20668) Add --checkpoint option to kafka-metadata-shell and deprecate --snapshot
[ https://issues.apache.org/jira/browse/KAFKA-20668?page=com.atlassian.jira.plugin.system.issuetabpanels:all-tabpanel ]
tony tang updated KAFKA-20668:
------------------------------
Description:
The kafka-metadata-shell tool exposes a option --snapshot to point at the file to read. The flag name is misleading: the metadata snapshot use the .checkpoint suffix, while kafka also has .snapshot files in every log directory which are producer snapshots. This leads users to pass the wrong file.
Propose adding a --checkpoint option and deprecating --snapshot (keeping it as an alias for backward compatibility).
was:
The kafka-metadata-shell tool exposes a option --snapshot to point at the file to read. The flag name is misleading: the metadata snapshot use the .checkpoint suffix, while kafka also has .snapshot files in every log directory which are producer snapshots. This leads users to pass the wrong file.
Propose adding a --checkpoint option and deprecating --snapshot (keeping it as an alias for backward compatibility, with removal targeted for 5.0).
> Add --checkpoint option to kafka-metadata-shell and deprecate --snapshot
> ------------------------------------------------------------------------
>
> Key: KAFKA-20668
> URL: https://issues.apache.org/jira/browse/KAFKA-20668
> Project: Kafka
> Issue Type: Improvement
> Reporter: tony tang
> Priority: Major
>
> The kafka-metadata-shell tool exposes a option --snapshot to point at the file to read. The flag name is misleading: the metadata snapshot use the .checkpoint suffix, while kafka also has .snapshot files in every log directory which are producer snapshots. This leads users to pass the wrong file.
> Propose adding a --checkpoint option and deprecating --snapshot (keeping it as an alias for backward compatibility).
--
This message was sent by Atlassian Jira
(v8.20.10#820010)