You are viewing a plain text version of this content. The canonical link for it is here.
Posted to dev@thrift.apache.org by "Jens Geyer (JIRA)" <ji...@apache.org> on 2019/01/04 22:40:00 UTC
[jira] [Updated] (THRIFT-4718) TClientTransport should be named
TTransport
[ https://issues.apache.org/jira/browse/THRIFT-4718?page=com.atlassian.jira.plugin.system.issuetabpanels:all-tabpanel ]
Jens Geyer updated THRIFT-4718:
-------------------------------
Description: TClientTransport should be named TTransport. At least we should have a suitable base class that is called that way. There is a reason why all language libraries look very similar. (was: TClientTransport and TServerTransport should have TTransport as the common base class, as it is in all other thrift libraries.)
> TClientTransport should be named TTransport
> -------------------------------------------
>
> Key: THRIFT-4718
> URL: https://issues.apache.org/jira/browse/THRIFT-4718
> Project: Thrift
> Issue Type: Bug
> Components: netcore - Library
> Reporter: Jens Geyer
> Priority: Major
>
> TClientTransport should be named TTransport. At least we should have a suitable base class that is called that way. There is a reason why all language libraries look very similar.
--
This message was sent by Atlassian JIRA
(v7.6.3#76005)