You are viewing a plain text version of this content. The canonical link for it is here.
Posted to dev@httpd.apache.org by Eric Covener <co...@apache.org> on 2026/06/08 12:51:02 UTC
CVE-2026-44185: Apache HTTP Server: Stack Buffer Over-Read in mod_ssl OCSP `send_request`
Severity: low
Affected versions:
- Apache HTTP Server 2.4.0 through 2.4.67
Description:
Buffer Over-read vulnerability in Apache HTTP Server via outbound OCSP requests to an attacker controlled OCSP server
This issue affects Apache HTTP Server: from 2.4.0 through 2.4.67.
Users are recommended to upgrade to version 2.4.68, which fixes the issue.
Credit:
Zhenpeng (Leo) Lin at depthfirst (finder)
References:
https://httpd.apache.org/security/vulnerabilities_24.html
https://httpd.apache.org/
https://www.cve.org/CVERecord?id=CVE-2026-44185
Timeline:
2026-04-27: reported
2026-06-03: fixed in 2.4.x by r1934919
2026-06-08: 2.4.68 released