You are viewing a plain text version of this content. The canonical link for it is here.
Posted to user@karaf.apache.org by Martin Lichtin <li...@yahoo.com> on 2016/05/15 10:46:12 UTC
Karaf 3.0.6 upgrading to latest ActiveMQ fails
In Karaf version 3.0.6, when trying to upgrade ActiveMQ to version 5.13.3, it fails with
ERROR: Bundle activemq-karaf [86] Error starting/stopping bundle. (org.osgi.framework.BundleException: Unresolved constraint in bundle activemq-karaf [86]: Unable to resolve 86.0: missing requirement [86.0] osgi.wiring.package; (&(osgi.wiring.package=org.osgi.framework)(version>=1.8.0)(!(version>=2.0.0))))
org.osgi.framework.BundleException: Unresolved constraint in bundle activemq-karaf [86]: Unable to resolve 86.0: missing requirement [86.0] osgi.wiring.package; (&(osgi.wiring.package=org.osgi.framework)(version>=1.8.0)(!(version>=2.0.0)))
It's baffling that activemq-karaf requires version 1.8.0 of "org.osgi.framework" (Karaf's bundle 0 exports only version 1.7.0).
Also activemq-karaf would work just fine in a Karaf 3.0.6 environment (it imports class BundleContext).
As I can't upgrade to Karaf 4 just yet, does anyone know a workaround/hack to satisfy this dependency in Karaf 3.0.6?
- Martin
Re: Karaf 3.0.6 upgrading to latest ActiveMQ fails
Posted by lichtin <li...@yahoo.com>.
Hi Krzysztof
ActiveMQ 5.13.3 works fine under Karaf 3.x, based on my tests.
It's just the activemq-karaf bundle that has an issue.
That bundle contains Karaf console commands - non-essential for the real
broker and client code.
- Martin
ksobkowiak wrote
> Hi Martin
>
> I think, ActiveMQ 5.13.x is not compatible with Karaf 3.x. You must
> upgrade to Karaf 4.x or stick with ActiveMQ 5.12.x.
>
> Regards
> Krzysztof
>
>
> On 15.05.2016 12:46, Martin Lichtin wrote:
>> In Karaf version 3.0.6, when trying to upgrade ActiveMQ to version
>> 5.13.3, it fails with
>>
>> ERROR: Bundle activemq-karaf [86] Error starting/stopping bundle.
>> (org.osgi.framework.BundleException: Unresolved constraint in bundle
>> activemq-karaf [86]: Unable to resolve 86.0: missing requirement [86.0]
>> osgi.wiring.package;
>> (&(osgi.wiring.package=org.osgi.framework)(version>=1.8.0)(!(version>=2.0.0))))
>> org.osgi.framework.BundleException: Unresolved constraint in bundle
>> activemq-karaf [86]: Unable to resolve 86.0: missing requirement [86.0]
>> osgi.wiring.package;
>> (&(osgi.wiring.package=org.osgi.framework)(version>=1.8.0)(!(version>=2.0.0)))
>>
>> It's baffling that activemq-karaf requires version 1.8.0 of
>> "org.osgi.framework" (Karaf's bundle 0 exports only version 1.7.0).
>> Also activemq-karaf would work just fine in a Karaf 3.0.6 environment (it
>> imports class BundleContext).
>>
>> As I can't upgrade to Karaf 4 just yet, does anyone know a
>> workaround/hack to satisfy this dependency in Karaf 3.0.6?
>>
>> - Martin
>>
>
> --
> Krzysztof Sobkowiak (@ksobkowiak)
>
> JEE & OSS Architect, Integration Architect
> Apache Software Foundation Member (http://apache.org/)
> Apache ServiceMix Committer & PMC Member (http://servicemix.apache.org/)
> Senior Solution Architect @ Capgemini SSC
> (http://www.capgeminisoftware.pl/)
--
View this message in context: http://karaf.922171.n3.nabble.com/Karaf-3-0-6-upgrading-to-latest-ActiveMQ-fails-tp4046639p4046641.html
Sent from the Karaf - User mailing list archive at Nabble.com.
Re: Karaf 3.0.6 upgrading to latest ActiveMQ fails
Posted by Krzysztof Sobkowiak <kr...@gmail.com>.
Hi Martin
I think, ActiveMQ 5.13.x is not compatible with Karaf 3.x. You must upgrade to Karaf 4.x or stick with ActiveMQ 5.12.x.
Regards
Krzysztof
On 15.05.2016 12:46, Martin Lichtin wrote:
> In Karaf version 3.0.6, when trying to upgrade ActiveMQ to version 5.13.3, it fails with
>
> ERROR: Bundle activemq-karaf [86] Error starting/stopping bundle. (org.osgi.framework.BundleException: Unresolved constraint in bundle activemq-karaf [86]: Unable to resolve 86.0: missing requirement [86.0] osgi.wiring.package; (&(osgi.wiring.package=org.osgi.framework)(version>=1.8.0)(!(version>=2.0.0))))
> org.osgi.framework.BundleException: Unresolved constraint in bundle activemq-karaf [86]: Unable to resolve 86.0: missing requirement [86.0] osgi.wiring.package; (&(osgi.wiring.package=org.osgi.framework)(version>=1.8.0)(!(version>=2.0.0)))
>
> It's baffling that activemq-karaf requires version 1.8.0 of "org.osgi.framework" (Karaf's bundle 0 exports only version 1.7.0).
> Also activemq-karaf would work just fine in a Karaf 3.0.6 environment (it imports class BundleContext).
>
> As I can't upgrade to Karaf 4 just yet, does anyone know a workaround/hack to satisfy this dependency in Karaf 3.0.6?
>
> - Martin
>
--
Krzysztof Sobkowiak (@ksobkowiak)
JEE & OSS Architect, Integration Architect
Apache Software Foundation Member (http://apache.org/)
Apache ServiceMix Committer & PMC Member (http://servicemix.apache.org/)
Senior Solution Architect @ Capgemini SSC (http://www.capgeminisoftware.pl/)