You are viewing a plain text version of this content. The canonical link for it is here.
Posted to issues@mesos.apache.org by "Mark Wang (JIRA)" <ji...@apache.org> on 2015/06/10 09:13:01 UTC

[jira] [Comment Edited] (MESOS-2800) Rename Option::get(const T& _t) to getOrElse() and refactor the original function

    [ https://issues.apache.org/jira/browse/MESOS-2800?page=com.atlassian.jira.plugin.system.issuetabpanels:comment-tabpanel&focusedCommentId=14580145#comment-14580145 ] 

Mark Wang edited comment on MESOS-2800 at 6/10/15 7:12 AM:
-----------------------------------------------------------

I think I miss lots of files that need to be addressed, here is a complete list: 
{noformat}
mesos:
  src/log/catchup.cpp
  src/master/main.cpp
  src/master/master.hpp
  src/slave/containerizer/containerizer.cpp
  src/tests/cluster.hpp
libprocess:
  3rdparty/libprocess/src/process.cpp
  3rdparty/libprocess/src/subprocess.cpp
stout:
  3rdparty/libprocess/3rdparty/stout/include/stout/option.hpp
  3rdparty/libprocess/3rdparty/stout/include/stout/os/osx.hpp
  3rdparty/libprocess/3rdparty/stout/tests/option_tests.cpp
{noformat}
by lines:
$ git diff HEAD~1 --numstat
{noformat}
1       1       3rdparty/libprocess/3rdparty/stout/include/stout/option.hpp
2       2       3rdparty/libprocess/3rdparty/stout/include/stout/os/osx.hpp
11      0       3rdparty/libprocess/3rdparty/stout/tests/option_tests.cpp
1       1       3rdparty/libprocess/src/process.cpp
1       1       3rdparty/libprocess/src/subprocess.cpp
6       3       src/cli/mesos-ps
1       1       src/log/catchup.cpp
2       2       src/master/main.cpp
2       2       src/master/master.hpp
5       5       src/slave/containerizer/containerizer.cpp
5       5       src/tests/cluster.hpp
{noformat}
So are we still go for the rename? If so, am I suppose to open issue in three projects?
What do you think [~jvanremoortere]? 


was (Author: balamark):
I think I miss lots of files that need to be addressed, here is a complete list: 
mesos:
{noformat}
  src/log/catchup.cpp
  src/master/main.cpp
  src/master/master.hpp
  src/slave/containerizer/containerizer.cpp
  src/tests/cluster.hpp
libprocess:
  3rdparty/libprocess/src/process.cpp
  3rdparty/libprocess/src/subprocess.cpp
stout:
  3rdparty/libprocess/3rdparty/stout/include/stout/option.hpp
  3rdparty/libprocess/3rdparty/stout/include/stout/os/osx.hpp
  3rdparty/libprocess/3rdparty/stout/tests/option_tests.cpp
{noformat}
by lines:
$ git diff HEAD~1 --numstat
{noformat}
1       1       3rdparty/libprocess/3rdparty/stout/include/stout/option.hpp
2       2       3rdparty/libprocess/3rdparty/stout/include/stout/os/osx.hpp
11      0       3rdparty/libprocess/3rdparty/stout/tests/option_tests.cpp
1       1       3rdparty/libprocess/src/process.cpp
1       1       3rdparty/libprocess/src/subprocess.cpp
6       3       src/cli/mesos-ps
1       1       src/log/catchup.cpp
2       2       src/master/main.cpp
2       2       src/master/master.hpp
5       5       src/slave/containerizer/containerizer.cpp
5       5       src/tests/cluster.hpp
{noformat}
So are we still go for the rename? If so, am I suppose to open issue in three projects?
What do you think [~jvanremoortere]? 

> Rename Option<T>::get(const T& _t) to getOrElse() and refactor the original function
> ------------------------------------------------------------------------------------
>
>                 Key: MESOS-2800
>                 URL: https://issues.apache.org/jira/browse/MESOS-2800
>             Project: Mesos
>          Issue Type: Improvement
>          Components: stout
>            Reporter: Mark Wang
>            Assignee: Mark Wang
>            Priority: Minor
>              Labels: newbie
>
> As suggested, if we want to change the name then we should refactor the original function as opposed to having 2 copies. 
> If we did have 2 versions of the same function, would it make more sense to delegate one of them to the other.
> As of today, there is only one file need to be refactor: 3rdparty/libprocess/3rdparty/stout/include/stout/os/osx.hpp at line 151, 161



--
This message was sent by Atlassian JIRA
(v6.3.4#6332)