You are viewing a plain text version of this content. The canonical link for it is here.
Posted to dev@subversion.apache.org by Arfrever Frehtes Taifersar Arahesis <ar...@gmail.com> on 2008/10/20 02:50:50 UTC

Re: svn commit: r33689 - in branches/fsfs-pack/subversion: include libsvn_fs libsvn_fs_base libsvn_fs_fs libsvn_repos svnadmin

2008-10-16 11:59:00 hwright@tigris.org napisał(a):
> Author: hwright
> Date: Thu Oct 16 02:59:00 2008
> New Revision: 33689
> 
> Log:
> On the fsfs-pack branch:
> Add cancellation support for fs packing.
> 
> * subversion/libsvn_fs/fs-loader.h
>   (fs_library_vtable_t.pack): Add cancel func/baton.
> 
> * subversion/libsvn_fs/fs-loader.c
>   (svn_fs_pack): Same.
> 
> * subversion/libsvn_fs_base/fs.c
>   (base_bdb_pack): Same.
> 
> * subversion/include/svn_fs.h
>   (svn_fs_pack): Same.

You should rename svn_fs_pack() to svn_fs_pack2() and restore older svn_fs_pack()
which should be marked as deprecated.

> * subversion/include/svn_repos.h,
>   subversion/libsvn_repos/fs-wrap.c
>   (svn_repos_fs_pack): Same.

You should rename svn_repos_fs_pack() to svn_repos_fs_pack2() and restore older
svn_repos_fs_pack() which should be marked as deprecated.

> * subversion/libsvn_fs_fs/fs_fs.h
>   (svn_fs_fs__pack): Same.
> 
> * subversion/libsvn_fs_fs/fs_fs.c
>   (packer_baton): Same.
>   (packer_func, pack_shard): Pass the cancellation func/baton to lower-level
>     APIs.
>   (svn_fs_fs__pack): Check cancellation between shard packing, and send the
>     cancellation func/baton to the lower-level APIs.
> 
> * subversion/svnadmin/main.c
>   (subcommand_pack): Use the standard svnadmin cancellation check.
> 
> Modified:
>    branches/fsfs-pack/subversion/include/svn_fs.h
>    branches/fsfs-pack/subversion/include/svn_repos.h
>    branches/fsfs-pack/subversion/libsvn_fs/fs-loader.c
>    branches/fsfs-pack/subversion/libsvn_fs/fs-loader.h
>    branches/fsfs-pack/subversion/libsvn_fs_base/fs.c
>    branches/fsfs-pack/subversion/libsvn_fs_fs/fs_fs.c
>    branches/fsfs-pack/subversion/libsvn_fs_fs/fs_fs.h
>    branches/fsfs-pack/subversion/libsvn_repos/fs-wrap.c
>    branches/fsfs-pack/subversion/svnadmin/main.c
> 
> Modified: branches/fsfs-pack/subversion/include/svn_fs.h
> URL: http://svn.collab.net/viewvc/svn/branches/fsfs-pack/subversion/include/svn_fs.h?pathrev=33689&r1=33688&r2=33689
> ==============================================================================
> --- branches/fsfs-pack/subversion/include/svn_fs.h	Thu Oct 16 02:41:58 2008	(r33688)
> +++ branches/fsfs-pack/subversion/include/svn_fs.h	Thu Oct 16 02:59:00 2008	(r33689)
> @@ -2023,6 +2023,8 @@ svn_fs_print_modules(svn_stringbuf_t *ou
>   */
>  svn_error_t *
>  svn_fs_pack(const char *db_path,
> +            svn_cancel_func_t cancel_func,
> +            void *cancel_baton,
>              apr_pool_t *pool);
>  
>  
> 
> Modified: branches/fsfs-pack/subversion/include/svn_repos.h
> URL: http://svn.collab.net/viewvc/svn/branches/fsfs-pack/subversion/include/svn_repos.h?pathrev=33689&r1=33688&r2=33689
> ==============================================================================
> --- branches/fsfs-pack/subversion/include/svn_repos.h	Thu Oct 16 02:41:58 2008	(r33688)
> +++ branches/fsfs-pack/subversion/include/svn_repos.h	Thu Oct 16 02:59:00 2008	(r33689)
> @@ -315,6 +315,8 @@ svn_repos_hotcopy(const char *src_path,
>   */
>  svn_error_t *
>  svn_repos_fs_pack(svn_repos_t *repos,
> +                  svn_cancel_func_t cancel_func,
> +                  void *cancel_baton,
>                    apr_pool_t *pool);
>  

-- 
Arfrever Frehtes Taifersar Arahesis

Re: svn commit: r33689 - in branches/fsfs-pack/subversion: include libsvn_fs libsvn_fs_base libsvn_fs_fs libsvn_repos svnadmin

Posted by Greg Stein <gs...@gmail.com>.
On Sun, Oct 19, 2008 at 7:50 PM, Arfrever Frehtes Taifersar Arahesis
<ar...@gmail.com> wrote:
> 2008-10-16 11:59:00 hwright@tigris.org napisał(a):
>> Author: hwright
>> Date: Thu Oct 16 02:59:00 2008
>> New Revision: 33689
>>
>> Log:
>> On the fsfs-pack branch:
>> Add cancellation support for fs packing.
>>
>> * subversion/libsvn_fs/fs-loader.h
>>   (fs_library_vtable_t.pack): Add cancel func/baton.
>>
>> * subversion/libsvn_fs/fs-loader.c
>>   (svn_fs_pack): Same.
>>
>> * subversion/libsvn_fs_base/fs.c
>>   (base_bdb_pack): Same.
>>
>> * subversion/include/svn_fs.h
>>   (svn_fs_pack): Same.
>
> You should rename svn_fs_pack() to svn_fs_pack2() and restore older svn_fs_pack()
> which should be marked as deprecated.
>
>> * subversion/include/svn_repos.h,
>>   subversion/libsvn_repos/fs-wrap.c
>>   (svn_repos_fs_pack): Same.
>
> You should rename svn_repos_fs_pack() to svn_repos_fs_pack2() and restore older
> svn_repos_fs_pack() which should be marked as deprecated.

No... all of this code is new. It can be changed at any time up until release.

Cheers,
-g