You are viewing a plain text version of this content. The canonical link for it is here.
Posted to issues@spark.apache.org by "Yadong Qi (JIRA)" <ji...@apache.org> on 2014/08/28 14:32:09 UTC
[jira] [Created] (SPARK-3285) Using values.sum is easier to
understand than using values.foldLeft(0)(_ + _)
Yadong Qi created SPARK-3285:
--------------------------------
Summary: Using values.sum is easier to understand than using values.foldLeft(0)(_ + _)
Key: SPARK-3285
URL: https://issues.apache.org/jira/browse/SPARK-3285
Project: Spark
Issue Type: Test
Components: Examples
Affects Versions: 1.0.2
Reporter: Yadong Qi
def sumB >: A: B = foldLeft(num.zero)(num.plus)
Using values.sum is easier to understand than using values.foldLeft(0)(_ + ), so we'd better use values.sum instead of values.foldLeft(0)( + _)
--
This message was sent by Atlassian JIRA
(v6.2#6252)
---------------------------------------------------------------------
To unsubscribe, e-mail: issues-unsubscribe@spark.apache.org
For additional commands, e-mail: issues-help@spark.apache.org