You are viewing a plain text version of this content. The canonical link for it is here.
Posted to issues@ignite.apache.org by "Konstantin Orlov (Jira)" <ji...@apache.org> on 2024/03/11 14:57:00 UTC
[jira] [Created] (IGNITE-21731) Sql. Split TableRowConverter#toBinaryRow on two methods
Konstantin Orlov created IGNITE-21731:
-----------------------------------------
Summary: Sql. Split TableRowConverter#toBinaryRow on two methods
Key: IGNITE-21731
URL: https://issues.apache.org/jira/browse/IGNITE-21731
Project: Ignite
Issue Type: Improvement
Components: sql
Reporter: Konstantin Orlov
Currently, method {{org.apache.ignite.internal.sql.engine.exec.TableRowConverter#toBinaryRow}} accepts boolean flag {{key}} and creates row with regard to this flag. Perhaps, the api will be cleaner if we split this method on two parts: {{toKeyRow}} and {{toFullRow}}.
--
This message was sent by Atlassian Jira
(v8.20.10#820010)