You are viewing a plain text version of this content. The canonical link for it is here.
Posted to dev@beehive.apache.org by "Jeremiah Johnson (JIRA)" <be...@incubator.apache.org> on 2004/12/10 00:16:18 UTC
[jira] Commented: (BEEHIVE-80) Page Flow Overview - simple actions versus complex actions
[ http://nagoya.apache.org/jira/browse/BEEHIVE-80?page=comments#action_56478 ]
Jeremiah Johnson commented on BEEHIVE-80:
-----------------------------------------
I think that the way the page is now is too confusing. The paragraph that was added saying that the method actions can be replaced doesn't give enough detail to be helpful, in my opinion. I would rather see the paragraph pulled out and a new section added to the documents about simple actions.
Rich suggested that maybe it would be better to start with simple actions rather than method actions. Without knowing details about simple actions, I think that the method actions are simple for people to grasp and best to use in the overview documentation.
- jeremiah
> Page Flow Overview - simple actions versus complex actions
> ----------------------------------------------------------
>
> Key: BEEHIVE-80
> URL: http://nagoya.apache.org/jira/browse/BEEHIVE-80
> Project: Beehive
> Type: Improvement
> Components: Documentation
> Versions: V1Alpha
> Reporter: Rich Feit
> Assignee: Steve Hanson
> Fix For: V1Alpha
>
> Using "simple actions" could reduce the size of the page flow being discussed, and it might make a clearer case for the method-based actions that come in the section entitled Conditional Forwards. Basically, you could replace code like this:
> @Jpf.Action(
> forwards = {
> @Jpf.Forward( name="success", path="signup.jsp" );
> }
> )
> public Forward signUp()
> {
> return new Forward( "success" );
> }
> @Jpf.Action(
> forwards = {
> @Jpf.Forward( name="success", path="login.jsp" );
> }
> )
> public Forward login()
> {
> return new Forward( "success" );
> }
> ...with this, at the class level:
> @Jpf.Controller(
> simpleActions={
> @Jpf.SimpleAction(name="signUp", path="signup.jsp"),
> @Jpf.SimpleAction(name="login", path="login.jsp")
> }
> )
> It's just a nice (new) feature that can reduce the size/complexity of a page flow class.
--
This message is automatically generated by JIRA.
-
If you think it was sent incorrectly contact one of the administrators:
http://nagoya.apache.org/jira/secure/Administrators.jspa
-
If you want more information on JIRA, or have a bug to report see:
http://www.atlassian.com/software/jira