You are viewing a plain text version of this content. The canonical link for it is here.
Posted to issues@hbase.apache.org by "Gary Helmling (JIRA)" <ji...@apache.org> on 2011/04/22 00:16:06 UTC

[jira] [Updated] (HBASE-3812) Tidy up naming consistency and documentation in coprocessor framework

     [ https://issues.apache.org/jira/browse/HBASE-3812?page=com.atlassian.jira.plugin.system.issuetabpanels:all-tabpanel ]

Gary Helmling updated HBASE-3812:
---------------------------------

    Priority: Critical  (was: Minor)

Bumping priority on Stack's recommendation.  Relatively minor changes, but important to get them done prior to 0.92.

> Tidy up naming consistency and documentation in coprocessor framework
> ---------------------------------------------------------------------
>
>                 Key: HBASE-3812
>                 URL: https://issues.apache.org/jira/browse/HBASE-3812
>             Project: HBase
>          Issue Type: Improvement
>          Components: coprocessors
>            Reporter: Gary Helmling
>            Priority: Critical
>             Fix For: 0.92.0
>
>
> We have a few naming inconsistencies in the coprocessor API and some stale javadocs that have been spotted by Lars George as he digs through it.  We should clean these up before we have an official release and are forced to go through a round of deprecation to make any changes.
> Current items on the list:
>  * rename BaseRegionObserverCoprocessor -> BaseRegionObserver
>  * in BaseMasterObserver, rename ObserverContext parameter variable from "env" to "c" or "ctx"
>  * unnecessary public modifier for methods in RegionObserver interface
> As part of this, we should take a pass through the javadocs and verify they are up to date with what is currently implemented.
> Please tack on other cosmetic changes or inconsistencies as you find them.

--
This message is automatically generated by JIRA.
For more information on JIRA, see: http://www.atlassian.com/software/jira