You are viewing a plain text version of this content. The canonical link for it is here.
Posted to dev@drill.apache.org by Daniel Barclay <db...@maprtech.com> on 2015/03/12 21:58:41 UTC

Review Request 31995: DRILL-2128 fix for DatabaseMetaData.getColumns's DATA_TYPE and TYPE_NAME (pt. 2--core fix)

-----------------------------------------------------------
This is an automatically generated e-mail. To reply, visit:
https://reviews.apache.org/r/31995/
-----------------------------------------------------------

Review request for drill and Parth Chandra.


Repository: drill-git


Description
-------

- Created basic test for DATA_TYPE and TYPE_NAME.
- Fixed DATA_TYPE:  Added mapping from type name/descriptor strings from
  INFORMATION_SCHEMA.COLUMNS.DATA_TYPE to java.sql.Types.* integer type codes
  for DatabaseMetaData.getColumns's DATA_TYPE.
- Fixed TYPE_NAME:  Added TYPE_NAME returning type name/descriptor strings
  from INFORMATION_SCHEMA.COLUMNS.DATA_TYPE
- Added FIXMEs for some missing/misnamed/wrong fields.  (See DRILL-2420.)

NOTE:  There are a number of unknowns noted in TODO comments.


Diffs
-----

  exec/jdbc/src/main/java/org/apache/drill/jdbc/MetaImpl.java 127751d 
  exec/jdbc/src/test/java/org/apache/drill/jdbc/test/Drill2128GetColumnsBugsTest.java PRE-CREATION 

Diff: https://reviews.apache.org/r/31995/diff/


Testing
-------

Ran new and existing tests.


Thanks,

Daniel Barclay


Re: Review Request 31995: DRILL-2128 fix for DatabaseMetaData.getColumns's DATA_TYPE and TYPE_NAME (pt. 2--core fix)

Posted by Daniel Barclay <db...@maprtech.com>.

> On March 13, 2015, 8:56 p.m., Parth Chandra wrote:
> > exec/jdbc/src/main/java/org/apache/drill/jdbc/MetaImpl.java, line 249
> > <https://reviews.apache.org/r/31995/diff/1/?file=892297#file892297line249>
> >
> >     Should we fix this and make it DECIMAL_DIGITS then?

Per offline discussion:  I'll be fixing that in the next batch of fixes for bugs in DRILL-2420.  (I was trying to limit this patch to just the bugs in DRILL-2128 itself.)


- Daniel


-----------------------------------------------------------
This is an automatically generated e-mail. To reply, visit:
https://reviews.apache.org/r/31995/#review76433
-----------------------------------------------------------


On March 12, 2015, 8:58 p.m., Daniel Barclay wrote:
> 
> -----------------------------------------------------------
> This is an automatically generated e-mail. To reply, visit:
> https://reviews.apache.org/r/31995/
> -----------------------------------------------------------
> 
> (Updated March 12, 2015, 8:58 p.m.)
> 
> 
> Review request for drill and Parth Chandra.
> 
> 
> Repository: drill-git
> 
> 
> Description
> -------
> 
> - Created basic test for DATA_TYPE and TYPE_NAME.
> - Fixed DATA_TYPE:  Added mapping from type name/descriptor strings from
>   INFORMATION_SCHEMA.COLUMNS.DATA_TYPE to java.sql.Types.* integer type codes
>   for DatabaseMetaData.getColumns's DATA_TYPE.
> - Fixed TYPE_NAME:  Added TYPE_NAME returning type name/descriptor strings
>   from INFORMATION_SCHEMA.COLUMNS.DATA_TYPE
> - Added FIXMEs for some missing/misnamed/wrong fields.  (See DRILL-2420.)
> 
> NOTE:  There are a number of unknowns noted in TODO comments.
> 
> 
> Diffs
> -----
> 
>   exec/jdbc/src/main/java/org/apache/drill/jdbc/MetaImpl.java 127751d 
>   exec/jdbc/src/test/java/org/apache/drill/jdbc/test/Drill2128GetColumnsBugsTest.java PRE-CREATION 
> 
> Diff: https://reviews.apache.org/r/31995/diff/
> 
> 
> Testing
> -------
> 
> Ran new and existing tests.
> 
> 
> Thanks,
> 
> Daniel Barclay
> 
>


Re: Review Request 31995: DRILL-2128 fix for DatabaseMetaData.getColumns's DATA_TYPE and TYPE_NAME (pt. 2--core fix)

Posted by Parth Chandra <pc...@maprtech.com>.
-----------------------------------------------------------
This is an automatically generated e-mail. To reply, visit:
https://reviews.apache.org/r/31995/#review76433
-----------------------------------------------------------



exec/jdbc/src/main/java/org/apache/drill/jdbc/MetaImpl.java
<https://reviews.apache.org/r/31995/#comment123976>

    Should we fix this and make it DECIMAL_DIGITS then?


- Parth Chandra


On March 12, 2015, 8:58 p.m., Daniel Barclay wrote:
> 
> -----------------------------------------------------------
> This is an automatically generated e-mail. To reply, visit:
> https://reviews.apache.org/r/31995/
> -----------------------------------------------------------
> 
> (Updated March 12, 2015, 8:58 p.m.)
> 
> 
> Review request for drill and Parth Chandra.
> 
> 
> Repository: drill-git
> 
> 
> Description
> -------
> 
> - Created basic test for DATA_TYPE and TYPE_NAME.
> - Fixed DATA_TYPE:  Added mapping from type name/descriptor strings from
>   INFORMATION_SCHEMA.COLUMNS.DATA_TYPE to java.sql.Types.* integer type codes
>   for DatabaseMetaData.getColumns's DATA_TYPE.
> - Fixed TYPE_NAME:  Added TYPE_NAME returning type name/descriptor strings
>   from INFORMATION_SCHEMA.COLUMNS.DATA_TYPE
> - Added FIXMEs for some missing/misnamed/wrong fields.  (See DRILL-2420.)
> 
> NOTE:  There are a number of unknowns noted in TODO comments.
> 
> 
> Diffs
> -----
> 
>   exec/jdbc/src/main/java/org/apache/drill/jdbc/MetaImpl.java 127751d 
>   exec/jdbc/src/test/java/org/apache/drill/jdbc/test/Drill2128GetColumnsBugsTest.java PRE-CREATION 
> 
> Diff: https://reviews.apache.org/r/31995/diff/
> 
> 
> Testing
> -------
> 
> Ran new and existing tests.
> 
> 
> Thanks,
> 
> Daniel Barclay
> 
>


Re: Review Request 31995: DRILL-2128 fix for DatabaseMetaData.getColumns's DATA_TYPE and TYPE_NAME (pt. 2--core fix)

Posted by Parth Chandra <pc...@maprtech.com>.
-----------------------------------------------------------
This is an automatically generated e-mail. To reply, visit:
https://reviews.apache.org/r/31995/#review76436
-----------------------------------------------------------

Ship it!


Ship It!

- Parth Chandra


On March 12, 2015, 8:58 p.m., Daniel Barclay wrote:
> 
> -----------------------------------------------------------
> This is an automatically generated e-mail. To reply, visit:
> https://reviews.apache.org/r/31995/
> -----------------------------------------------------------
> 
> (Updated March 12, 2015, 8:58 p.m.)
> 
> 
> Review request for drill and Parth Chandra.
> 
> 
> Repository: drill-git
> 
> 
> Description
> -------
> 
> - Created basic test for DATA_TYPE and TYPE_NAME.
> - Fixed DATA_TYPE:  Added mapping from type name/descriptor strings from
>   INFORMATION_SCHEMA.COLUMNS.DATA_TYPE to java.sql.Types.* integer type codes
>   for DatabaseMetaData.getColumns's DATA_TYPE.
> - Fixed TYPE_NAME:  Added TYPE_NAME returning type name/descriptor strings
>   from INFORMATION_SCHEMA.COLUMNS.DATA_TYPE
> - Added FIXMEs for some missing/misnamed/wrong fields.  (See DRILL-2420.)
> 
> NOTE:  There are a number of unknowns noted in TODO comments.
> 
> 
> Diffs
> -----
> 
>   exec/jdbc/src/main/java/org/apache/drill/jdbc/MetaImpl.java 127751d 
>   exec/jdbc/src/test/java/org/apache/drill/jdbc/test/Drill2128GetColumnsBugsTest.java PRE-CREATION 
> 
> Diff: https://reviews.apache.org/r/31995/diff/
> 
> 
> Testing
> -------
> 
> Ran new and existing tests.
> 
> 
> Thanks,
> 
> Daniel Barclay
> 
>