You are viewing a plain text version of this content. The canonical link for it is here.
Posted to commits@cassandra.apache.org by "Ekaterina Dimitrova (Jira)" <ji...@apache.org> on 2022/06/02 15:47:00 UTC

[jira] [Commented] (CASSANDRA-17221) Add Math functions

    [ https://issues.apache.org/jira/browse/CASSANDRA-17221?page=com.atlassian.jira.plugin.system.issuetabpanels:comment-tabpanel&focusedCommentId=17545524#comment-17545524 ] 

Ekaterina Dimitrova commented on CASSANDRA-17221:
-------------------------------------------------

Just submitted a full CI run in Jenkins and I will be getting back to the details of the patch itself later today. - https://jenkins-cm4.apache.org/job/Cassandra-devbranch/1752/

[~blerer], will you have time for review at some point or should I try to ask someone else from the community.

I think we will also have to hit the mailing list about the new library we are about to introduce. I will check again the details there first to ensure things are fine. 

> Add Math functions 
> -------------------
>
>                 Key: CASSANDRA-17221
>                 URL: https://issues.apache.org/jira/browse/CASSANDRA-17221
>             Project: Cassandra
>          Issue Type: Improvement
>          Components: CQL/Syntax
>            Reporter: Benjamin Lerer
>            Assignee: Simon Chess
>            Priority: Normal
>              Labels: AdventCalendar2021, lhf
>             Fix For: 4.x
>
>
> We should add native Maths functions for the most common operations:
> * {{abs\(x)}} returns the absolute value of the x
> * {{exp\(x)}} returns the value of e (the base of natural logarithms) raised to the power of x
> * {{log\(x)}} returns the natural logarithm (base e) of x
> * {{log10\(x)}} returns the base-10 logarithm of x
> * {{round\(x)}} returns the closest integer to x
> +Additional information for newcomers:+
> The new functions should be put in a new class {{MathFcts}} similar to {{TimeFcts}}.
> The {{MathsFcts.all()}} method should be called in {{SystemKeyspace.functions}}
> The unit tests for the functions should be put in a {{MathFctsTest}} similar to {{TimeFctsTest}} 



--
This message was sent by Atlassian Jira
(v8.20.7#820007)

---------------------------------------------------------------------
To unsubscribe, e-mail: commits-unsubscribe@cassandra.apache.org
For additional commands, e-mail: commits-help@cassandra.apache.org