You are viewing a plain text version of this content. The canonical link for it is here.
Posted to dev@hbase.apache.org by "BELUGA BEHR (JIRA)" <ji...@apache.org> on 2018/01/01 22:05:00 UTC

[jira] [Reopened] (HBASE-19678) HBase Admin security capabilities should be represented as a Set

     [ https://issues.apache.org/jira/browse/HBASE-19678?page=com.atlassian.jira.plugin.system.issuetabpanels:all-tabpanel ]

BELUGA BEHR reopened HBASE-19678:
---------------------------------

> HBase Admin security capabilities should be represented as a Set
> ----------------------------------------------------------------
>
>                 Key: HBASE-19678
>                 URL: https://issues.apache.org/jira/browse/HBASE-19678
>             Project: HBase
>          Issue Type: Improvement
>          Components: hbase
>    Affects Versions: 3.0.0
>            Reporter: BELUGA BEHR
>            Assignee: BELUGA BEHR
>            Priority: Minor
>             Fix For: 2.0.0-beta-2
>
>         Attachments: HBASE-19678.1.patch
>
>
> {code:title=org.apache.hadoop.hbase.client.Admin}
>   /**
>    * Return the set of supported security capabilities.
>    * @throws IOException
>    * @throws UnsupportedOperationException
>    */
>   List<SecurityCapability> getSecurityCapabilities() throws IOException;
> {code}
> The comment says a "set" but it returns a List.  A Set would be the most appropriate data structure here, an immutable one perhaps, because the code that interacts with it looks up information using the _contains_ method which would be served well by a Set.  Please change this interface to return a Set.



--
This message was sent by Atlassian JIRA
(v6.4.14#64029)