You are viewing a plain text version of this content. The canonical link for it is here.
Posted to dev@lucene.apache.org by "Yonik Seeley (JIRA)" <ji...@apache.org> on 2015/04/18 16:20:58 UTC

[jira] [Updated] (SOLR-7422) Flatter JSON Facet API structure

     [ https://issues.apache.org/jira/browse/SOLR-7422?page=com.atlassian.jira.plugin.system.issuetabpanels:all-tabpanel ]

Yonik Seeley updated SOLR-7422:
-------------------------------
    Attachment: SOLR-7422.patch

Here's a patch that implements the suggestion.
Both forms continue to work because
1. I didn't want to change *all* the tests
2. Some forms are more readable with the original form, for example the degenerate form of a query fact:
{code}
x : { query : "inStock:true" }
vs
x : { type : query, q : "inStock:true" }
{code}

> Flatter JSON Facet API structure
> --------------------------------
>
>                 Key: SOLR-7422
>                 URL: https://issues.apache.org/jira/browse/SOLR-7422
>             Project: Solr
>          Issue Type: Sub-task
>            Reporter: Yonik Seeley
>             Fix For: 5.2
>
>         Attachments: SOLR-7422.patch
>
>
> The current general form of a facet command is:
> top_authors : { terms : {
>   field : author,
>   limit : 5,
> }}
> We should allow a flatter structure:
> top_authors : {
>   type : terms,
>   field : author,
>   limit : 5
> }



--
This message was sent by Atlassian JIRA
(v6.3.4#6332)

---------------------------------------------------------------------
To unsubscribe, e-mail: dev-unsubscribe@lucene.apache.org
For additional commands, e-mail: dev-help@lucene.apache.org