You are viewing a plain text version of this content. The canonical link for it is here.
Posted to dev@chemistry.apache.org by "Stephan Klevenz (JIRA)" <ji...@apache.org> on 2010/05/05 14:41:04 UTC

[jira] Issue Comment Edited: (CMIS-200) PagingList refactor part 2

    [ https://issues.apache.org/jira/browse/CMIS-200?page=com.atlassian.jira.plugin.system.issuetabpanels:comment-tabpanel&focusedCommentId=12864315#action_12864315 ] 

Stephan Klevenz edited comment on CMIS-200 at 5/5/10 8:40 AM:
--------------------------------------------------------------

Collapse ItemIterator and ItemIterable interface

      was (Author: klevenzs):
    Colapse ItemIterator and ItemIterable interface
  
> PagingList refactor part 2
> --------------------------
>
>                 Key: CMIS-200
>                 URL: https://issues.apache.org/jira/browse/CMIS-200
>             Project: Chemistry
>          Issue Type: Bug
>          Components: opencmis-client
>            Reporter: David Caruana
>            Assignee: Stephan Klevenz
>
> - rename PagingIterable to the chosen name :-)  - candidates: SkipIterable, ItemIterable, ...
> - removes "maxItems" from the service calls
> - adds maxItems to OperationContext
> - adds a getPage(int maxItems)

-- 
This message is automatically generated by JIRA.
-
You can reply to this email to add a comment to the issue online.