You are viewing a plain text version of this content. The canonical link for it is here.
Posted to hdfs-issues@hadoop.apache.org by "Eli Collins (Created) (JIRA)" <ji...@apache.org> on 2012/04/05 23:42:26 UTC

[jira] [Created] (HDFS-3210) JsonUtil#toJsonMap for for a DatanodeInfo should use "ipAddr" instead of "name"

JsonUtil#toJsonMap for for a DatanodeInfo should use "ipAddr" instead of "name"
-------------------------------------------------------------------------------

                 Key: HDFS-3210
                 URL: https://issues.apache.org/jira/browse/HDFS-3210
             Project: Hadoop HDFS
          Issue Type: Bug
    Affects Versions: 2.0.0
            Reporter: Eli Collins
            Assignee: Eli Collins
         Attachments: hdfs-3210.txt

In HDFS-3144 I missed a spot when renaming the "name" field. Let's fix that and add a test.

--
This message is automatically generated by JIRA.
If you think it was sent incorrectly, please contact your JIRA administrators: https://issues.apache.org/jira/secure/ContactAdministrators!default.jspa
For more information on JIRA, see: http://www.atlassian.com/software/jira

        

[jira] [Updated] (HDFS-3210) JsonUtil#toJsonMap for for a DatanodeInfo should use "ipAddr" instead of "name"

Posted by "Eli Collins (Updated) (JIRA)" <ji...@apache.org>.
     [ https://issues.apache.org/jira/browse/HDFS-3210?page=com.atlassian.jira.plugin.system.issuetabpanels:all-tabpanel ]

Eli Collins updated HDFS-3210:
------------------------------

          Resolution: Fixed
       Fix Version/s: 2.0.0
    Target Version/s:   (was: 2.0.0)
        Hadoop Flags: Reviewed
              Status: Resolved  (was: Patch Available)

Thanks for the review ATM. I've committed this and merged to branch-2.
                
> JsonUtil#toJsonMap for for a DatanodeInfo should use "ipAddr" instead of "name"
> -------------------------------------------------------------------------------
>
>                 Key: HDFS-3210
>                 URL: https://issues.apache.org/jira/browse/HDFS-3210
>             Project: Hadoop HDFS
>          Issue Type: Bug
>    Affects Versions: 2.0.0
>            Reporter: Eli Collins
>            Assignee: Eli Collins
>             Fix For: 2.0.0
>
>         Attachments: hdfs-3210.txt
>
>
> In HDFS-3144 I missed a spot when renaming the "name" field. Let's fix that and add a test.

--
This message is automatically generated by JIRA.
If you think it was sent incorrectly, please contact your JIRA administrators: https://issues.apache.org/jira/secure/ContactAdministrators!default.jspa
For more information on JIRA, see: http://www.atlassian.com/software/jira

        

[jira] [Commented] (HDFS-3210) JsonUtil#toJsonMap for for a DatanodeInfo should use "ipAddr" instead of "name"

Posted by "Hudson (Commented) (JIRA)" <ji...@apache.org>.
    [ https://issues.apache.org/jira/browse/HDFS-3210?page=com.atlassian.jira.plugin.system.issuetabpanels:comment-tabpanel&focusedCommentId=13247882#comment-13247882 ] 

Hudson commented on HDFS-3210:
------------------------------

Integrated in Hadoop-Common-trunk-Commit #2010 (See [https://builds.apache.org/job/Hadoop-Common-trunk-Commit/2010/])
    HDFS-3210. JsonUtil#toJsonMap for for a DatanodeInfo should use "ipAddr" instead of "name". Contributed by Eli Collins (Revision 1310135)

     Result = SUCCESS
eli : http://svn.apache.org/viewcvs.cgi/?root=Apache-SVN&view=rev&rev=1310135
Files : 
* /hadoop/common/trunk/hadoop-hdfs-project/hadoop-hdfs/CHANGES.txt
* /hadoop/common/trunk/hadoop-hdfs-project/hadoop-hdfs/src/main/java/org/apache/hadoop/hdfs/protocol/DatanodeInfo.java
* /hadoop/common/trunk/hadoop-hdfs-project/hadoop-hdfs/src/main/java/org/apache/hadoop/hdfs/web/JsonUtil.java
* /hadoop/common/trunk/hadoop-hdfs-project/hadoop-hdfs/src/test/java/org/apache/hadoop/hdfs/web/TestWebHdfsFileSystemContract.java

                
> JsonUtil#toJsonMap for for a DatanodeInfo should use "ipAddr" instead of "name"
> -------------------------------------------------------------------------------
>
>                 Key: HDFS-3210
>                 URL: https://issues.apache.org/jira/browse/HDFS-3210
>             Project: Hadoop HDFS
>          Issue Type: Bug
>    Affects Versions: 2.0.0
>            Reporter: Eli Collins
>            Assignee: Eli Collins
>         Attachments: hdfs-3210.txt
>
>
> In HDFS-3144 I missed a spot when renaming the "name" field. Let's fix that and add a test.

--
This message is automatically generated by JIRA.
If you think it was sent incorrectly, please contact your JIRA administrators: https://issues.apache.org/jira/secure/ContactAdministrators!default.jspa
For more information on JIRA, see: http://www.atlassian.com/software/jira

        

[jira] [Commented] (HDFS-3210) JsonUtil#toJsonMap for for a DatanodeInfo should use "ipAddr" instead of "name"

Posted by "Hudson (Commented) (JIRA)" <ji...@apache.org>.
    [ https://issues.apache.org/jira/browse/HDFS-3210?page=com.atlassian.jira.plugin.system.issuetabpanels:comment-tabpanel&focusedCommentId=13247887#comment-13247887 ] 

Hudson commented on HDFS-3210:
------------------------------

Integrated in Hadoop-Hdfs-trunk-Commit #2085 (See [https://builds.apache.org/job/Hadoop-Hdfs-trunk-Commit/2085/])
    HDFS-3210. JsonUtil#toJsonMap for for a DatanodeInfo should use "ipAddr" instead of "name". Contributed by Eli Collins (Revision 1310135)

     Result = SUCCESS
eli : http://svn.apache.org/viewcvs.cgi/?root=Apache-SVN&view=rev&rev=1310135
Files : 
* /hadoop/common/trunk/hadoop-hdfs-project/hadoop-hdfs/CHANGES.txt
* /hadoop/common/trunk/hadoop-hdfs-project/hadoop-hdfs/src/main/java/org/apache/hadoop/hdfs/protocol/DatanodeInfo.java
* /hadoop/common/trunk/hadoop-hdfs-project/hadoop-hdfs/src/main/java/org/apache/hadoop/hdfs/web/JsonUtil.java
* /hadoop/common/trunk/hadoop-hdfs-project/hadoop-hdfs/src/test/java/org/apache/hadoop/hdfs/web/TestWebHdfsFileSystemContract.java

                
> JsonUtil#toJsonMap for for a DatanodeInfo should use "ipAddr" instead of "name"
> -------------------------------------------------------------------------------
>
>                 Key: HDFS-3210
>                 URL: https://issues.apache.org/jira/browse/HDFS-3210
>             Project: Hadoop HDFS
>          Issue Type: Bug
>    Affects Versions: 2.0.0
>            Reporter: Eli Collins
>            Assignee: Eli Collins
>             Fix For: 2.0.0
>
>         Attachments: hdfs-3210.txt
>
>
> In HDFS-3144 I missed a spot when renaming the "name" field. Let's fix that and add a test.

--
This message is automatically generated by JIRA.
If you think it was sent incorrectly, please contact your JIRA administrators: https://issues.apache.org/jira/secure/ContactAdministrators!default.jspa
For more information on JIRA, see: http://www.atlassian.com/software/jira

        

[jira] [Commented] (HDFS-3210) JsonUtil#toJsonMap for for a DatanodeInfo should use "ipAddr" instead of "name"

Posted by "Hadoop QA (Commented) (JIRA)" <ji...@apache.org>.
    [ https://issues.apache.org/jira/browse/HDFS-3210?page=com.atlassian.jira.plugin.system.issuetabpanels:comment-tabpanel&focusedCommentId=13247823#comment-13247823 ] 

Hadoop QA commented on HDFS-3210:
---------------------------------

+1 overall.  Here are the results of testing the latest attachment 
  http://issues.apache.org/jira/secure/attachment/12521585/hdfs-3210.txt
  against trunk revision .

    +1 @author.  The patch does not contain any @author tags.

    +1 tests included.  The patch appears to include 1 new or modified test files.

    +1 javadoc.  The javadoc tool did not generate any warning messages.

    +1 javac.  The applied patch does not increase the total number of javac compiler warnings.

    +1 eclipse:eclipse.  The patch built with eclipse:eclipse.

    +1 findbugs.  The patch does not introduce any new Findbugs (version 1.3.9) warnings.

    +1 release audit.  The applied patch does not increase the total number of release audit warnings.

    +1 core tests.  The patch passed unit tests in .

    +1 contrib tests.  The patch passed contrib unit tests.

Test results: https://builds.apache.org/job/PreCommit-HDFS-Build/2203//testReport/
Console output: https://builds.apache.org/job/PreCommit-HDFS-Build/2203//console

This message is automatically generated.
                
> JsonUtil#toJsonMap for for a DatanodeInfo should use "ipAddr" instead of "name"
> -------------------------------------------------------------------------------
>
>                 Key: HDFS-3210
>                 URL: https://issues.apache.org/jira/browse/HDFS-3210
>             Project: Hadoop HDFS
>          Issue Type: Bug
>    Affects Versions: 2.0.0
>            Reporter: Eli Collins
>            Assignee: Eli Collins
>         Attachments: hdfs-3210.txt
>
>
> In HDFS-3144 I missed a spot when renaming the "name" field. Let's fix that and add a test.

--
This message is automatically generated by JIRA.
If you think it was sent incorrectly, please contact your JIRA administrators: https://issues.apache.org/jira/secure/ContactAdministrators!default.jspa
For more information on JIRA, see: http://www.atlassian.com/software/jira

        

[jira] [Updated] (HDFS-3210) JsonUtil#toJsonMap for for a DatanodeInfo should use "ipAddr" instead of "name"

Posted by "Eli Collins (Updated) (JIRA)" <ji...@apache.org>.
     [ https://issues.apache.org/jira/browse/HDFS-3210?page=com.atlassian.jira.plugin.system.issuetabpanels:all-tabpanel ]

Eli Collins updated HDFS-3210:
------------------------------

    Status: Patch Available  (was: Open)
    
> JsonUtil#toJsonMap for for a DatanodeInfo should use "ipAddr" instead of "name"
> -------------------------------------------------------------------------------
>
>                 Key: HDFS-3210
>                 URL: https://issues.apache.org/jira/browse/HDFS-3210
>             Project: Hadoop HDFS
>          Issue Type: Bug
>    Affects Versions: 2.0.0
>            Reporter: Eli Collins
>            Assignee: Eli Collins
>         Attachments: hdfs-3210.txt
>
>
> In HDFS-3144 I missed a spot when renaming the "name" field. Let's fix that and add a test.

--
This message is automatically generated by JIRA.
If you think it was sent incorrectly, please contact your JIRA administrators: https://issues.apache.org/jira/secure/ContactAdministrators!default.jspa
For more information on JIRA, see: http://www.atlassian.com/software/jira

        

[jira] [Commented] (HDFS-3210) JsonUtil#toJsonMap for for a DatanodeInfo should use "ipAddr" instead of "name"

Posted by "Hudson (Commented) (JIRA)" <ji...@apache.org>.
    [ https://issues.apache.org/jira/browse/HDFS-3210?page=com.atlassian.jira.plugin.system.issuetabpanels:comment-tabpanel&focusedCommentId=13248313#comment-13248313 ] 

Hudson commented on HDFS-3210:
------------------------------

Integrated in Hadoop-Hdfs-trunk #1006 (See [https://builds.apache.org/job/Hadoop-Hdfs-trunk/1006/])
    HDFS-3210. JsonUtil#toJsonMap for for a DatanodeInfo should use "ipAddr" instead of "name". Contributed by Eli Collins (Revision 1310135)

     Result = FAILURE
eli : http://svn.apache.org/viewcvs.cgi/?root=Apache-SVN&view=rev&rev=1310135
Files : 
* /hadoop/common/trunk/hadoop-hdfs-project/hadoop-hdfs/CHANGES.txt
* /hadoop/common/trunk/hadoop-hdfs-project/hadoop-hdfs/src/main/java/org/apache/hadoop/hdfs/protocol/DatanodeInfo.java
* /hadoop/common/trunk/hadoop-hdfs-project/hadoop-hdfs/src/main/java/org/apache/hadoop/hdfs/web/JsonUtil.java
* /hadoop/common/trunk/hadoop-hdfs-project/hadoop-hdfs/src/test/java/org/apache/hadoop/hdfs/web/TestWebHdfsFileSystemContract.java

                
> JsonUtil#toJsonMap for for a DatanodeInfo should use "ipAddr" instead of "name"
> -------------------------------------------------------------------------------
>
>                 Key: HDFS-3210
>                 URL: https://issues.apache.org/jira/browse/HDFS-3210
>             Project: Hadoop HDFS
>          Issue Type: Bug
>    Affects Versions: 2.0.0
>            Reporter: Eli Collins
>            Assignee: Eli Collins
>             Fix For: 2.0.0
>
>         Attachments: hdfs-3210.txt
>
>
> In HDFS-3144 I missed a spot when renaming the "name" field. Let's fix that and add a test.

--
This message is automatically generated by JIRA.
If you think it was sent incorrectly, please contact your JIRA administrators: https://issues.apache.org/jira/secure/ContactAdministrators!default.jspa
For more information on JIRA, see: http://www.atlassian.com/software/jira

        

[jira] [Commented] (HDFS-3210) JsonUtil#toJsonMap for for a DatanodeInfo should use "ipAddr" instead of "name"

Posted by "Aaron T. Myers (Commented) (JIRA)" <ji...@apache.org>.
    [ https://issues.apache.org/jira/browse/HDFS-3210?page=com.atlassian.jira.plugin.system.issuetabpanels:comment-tabpanel&focusedCommentId=13247758#comment-13247758 ] 

Aaron T. Myers commented on HDFS-3210:
--------------------------------------

Patch looks good to me. +1 pending Jenkins.
                
> JsonUtil#toJsonMap for for a DatanodeInfo should use "ipAddr" instead of "name"
> -------------------------------------------------------------------------------
>
>                 Key: HDFS-3210
>                 URL: https://issues.apache.org/jira/browse/HDFS-3210
>             Project: Hadoop HDFS
>          Issue Type: Bug
>    Affects Versions: 2.0.0
>            Reporter: Eli Collins
>            Assignee: Eli Collins
>         Attachments: hdfs-3210.txt
>
>
> In HDFS-3144 I missed a spot when renaming the "name" field. Let's fix that and add a test.

--
This message is automatically generated by JIRA.
If you think it was sent incorrectly, please contact your JIRA administrators: https://issues.apache.org/jira/secure/ContactAdministrators!default.jspa
For more information on JIRA, see: http://www.atlassian.com/software/jira

        

[jira] [Commented] (HDFS-3210) JsonUtil#toJsonMap for for a DatanodeInfo should use "ipAddr" instead of "name"

Posted by "Hudson (Commented) (JIRA)" <ji...@apache.org>.
    [ https://issues.apache.org/jira/browse/HDFS-3210?page=com.atlassian.jira.plugin.system.issuetabpanels:comment-tabpanel&focusedCommentId=13247896#comment-13247896 ] 

Hudson commented on HDFS-3210:
------------------------------

Integrated in Hadoop-Mapreduce-trunk-Commit #2023 (See [https://builds.apache.org/job/Hadoop-Mapreduce-trunk-Commit/2023/])
    HDFS-3210. JsonUtil#toJsonMap for for a DatanodeInfo should use "ipAddr" instead of "name". Contributed by Eli Collins (Revision 1310135)

     Result = SUCCESS
eli : http://svn.apache.org/viewcvs.cgi/?root=Apache-SVN&view=rev&rev=1310135
Files : 
* /hadoop/common/trunk/hadoop-hdfs-project/hadoop-hdfs/CHANGES.txt
* /hadoop/common/trunk/hadoop-hdfs-project/hadoop-hdfs/src/main/java/org/apache/hadoop/hdfs/protocol/DatanodeInfo.java
* /hadoop/common/trunk/hadoop-hdfs-project/hadoop-hdfs/src/main/java/org/apache/hadoop/hdfs/web/JsonUtil.java
* /hadoop/common/trunk/hadoop-hdfs-project/hadoop-hdfs/src/test/java/org/apache/hadoop/hdfs/web/TestWebHdfsFileSystemContract.java

                
> JsonUtil#toJsonMap for for a DatanodeInfo should use "ipAddr" instead of "name"
> -------------------------------------------------------------------------------
>
>                 Key: HDFS-3210
>                 URL: https://issues.apache.org/jira/browse/HDFS-3210
>             Project: Hadoop HDFS
>          Issue Type: Bug
>    Affects Versions: 2.0.0
>            Reporter: Eli Collins
>            Assignee: Eli Collins
>             Fix For: 2.0.0
>
>         Attachments: hdfs-3210.txt
>
>
> In HDFS-3144 I missed a spot when renaming the "name" field. Let's fix that and add a test.

--
This message is automatically generated by JIRA.
If you think it was sent incorrectly, please contact your JIRA administrators: https://issues.apache.org/jira/secure/ContactAdministrators!default.jspa
For more information on JIRA, see: http://www.atlassian.com/software/jira

        

[jira] [Commented] (HDFS-3210) JsonUtil#toJsonMap for for a DatanodeInfo should use "ipAddr" instead of "name"

Posted by "Hudson (Commented) (JIRA)" <ji...@apache.org>.
    [ https://issues.apache.org/jira/browse/HDFS-3210?page=com.atlassian.jira.plugin.system.issuetabpanels:comment-tabpanel&focusedCommentId=13248368#comment-13248368 ] 

Hudson commented on HDFS-3210:
------------------------------

Integrated in Hadoop-Mapreduce-trunk #1041 (See [https://builds.apache.org/job/Hadoop-Mapreduce-trunk/1041/])
    HDFS-3210. JsonUtil#toJsonMap for for a DatanodeInfo should use "ipAddr" instead of "name". Contributed by Eli Collins (Revision 1310135)

     Result = SUCCESS
eli : http://svn.apache.org/viewcvs.cgi/?root=Apache-SVN&view=rev&rev=1310135
Files : 
* /hadoop/common/trunk/hadoop-hdfs-project/hadoop-hdfs/CHANGES.txt
* /hadoop/common/trunk/hadoop-hdfs-project/hadoop-hdfs/src/main/java/org/apache/hadoop/hdfs/protocol/DatanodeInfo.java
* /hadoop/common/trunk/hadoop-hdfs-project/hadoop-hdfs/src/main/java/org/apache/hadoop/hdfs/web/JsonUtil.java
* /hadoop/common/trunk/hadoop-hdfs-project/hadoop-hdfs/src/test/java/org/apache/hadoop/hdfs/web/TestWebHdfsFileSystemContract.java

                
> JsonUtil#toJsonMap for for a DatanodeInfo should use "ipAddr" instead of "name"
> -------------------------------------------------------------------------------
>
>                 Key: HDFS-3210
>                 URL: https://issues.apache.org/jira/browse/HDFS-3210
>             Project: Hadoop HDFS
>          Issue Type: Bug
>    Affects Versions: 2.0.0
>            Reporter: Eli Collins
>            Assignee: Eli Collins
>             Fix For: 2.0.0
>
>         Attachments: hdfs-3210.txt
>
>
> In HDFS-3144 I missed a spot when renaming the "name" field. Let's fix that and add a test.

--
This message is automatically generated by JIRA.
If you think it was sent incorrectly, please contact your JIRA administrators: https://issues.apache.org/jira/secure/ContactAdministrators!default.jspa
For more information on JIRA, see: http://www.atlassian.com/software/jira

        

[jira] [Updated] (HDFS-3210) JsonUtil#toJsonMap for for a DatanodeInfo should use "ipAddr" instead of "name"

Posted by "Eli Collins (Updated) (JIRA)" <ji...@apache.org>.
     [ https://issues.apache.org/jira/browse/HDFS-3210?page=com.atlassian.jira.plugin.system.issuetabpanels:all-tabpanel ]

Eli Collins updated HDFS-3210:
------------------------------

    Attachment: hdfs-3210.txt

Path attached.
                
> JsonUtil#toJsonMap for for a DatanodeInfo should use "ipAddr" instead of "name"
> -------------------------------------------------------------------------------
>
>                 Key: HDFS-3210
>                 URL: https://issues.apache.org/jira/browse/HDFS-3210
>             Project: Hadoop HDFS
>          Issue Type: Bug
>    Affects Versions: 2.0.0
>            Reporter: Eli Collins
>            Assignee: Eli Collins
>         Attachments: hdfs-3210.txt
>
>
> In HDFS-3144 I missed a spot when renaming the "name" field. Let's fix that and add a test.

--
This message is automatically generated by JIRA.
If you think it was sent incorrectly, please contact your JIRA administrators: https://issues.apache.org/jira/secure/ContactAdministrators!default.jspa
For more information on JIRA, see: http://www.atlassian.com/software/jira