You are viewing a plain text version of this content. The canonical link for it is here.
Posted to common-issues@hadoop.apache.org by "Suresh Srinivas (JIRA)" <ji...@apache.org> on 2009/12/01 00:38:20 UTC

[jira] Commented: (HADOOP-6394) Helper class for FileContext tests

    [ https://issues.apache.org/jira/browse/HADOOP-6394?page=com.atlassian.jira.plugin.system.issuetabpanels:comment-tabpanel&focusedCommentId=12783942#action_12783942 ] 

Suresh Srinivas commented on HADOOP-6394:
-----------------------------------------

Preliminary comments:
# No need to have many variants of createFile. Just one with all the params should suffice. Callers should call create with appropriate args. Otherwise we will have too many createFile methods one for each usecase.
# Changes are required in tests to use this helper class to remove duplicated code.

> Helper class for FileContext tests
> ----------------------------------
>
>                 Key: HADOOP-6394
>                 URL: https://issues.apache.org/jira/browse/HADOOP-6394
>             Project: Hadoop Common
>          Issue Type: Improvement
>            Reporter: Jitendra Nath Pandey
>            Assignee: Jitendra Nath Pandey
>         Attachments: HADOOP-6394.1.patch
>
>
>     A helper class for FileContext tests should contain common methods which can be used in many unit tests, so that every unit test doesn't have to re-implement these functionality.
> Examples of such methods:
>   createFile(FileContext fc, Path path, int numBlocks, int blockSize)  //To create a file with number of blocks and block-size passed.
>   getTestRootPath(FileContext fc)

-- 
This message is automatically generated by JIRA.
-
You can reply to this email to add a comment to the issue online.