You are viewing a plain text version of this content. The canonical link for it is here.
Posted to issues@nifi.apache.org by "marco polo (JIRA)" <ji...@apache.org> on 2017/10/18 19:28:00 UTC
[jira] [Commented] (MINIFICPP-259) Readability and optimization
improvement for GetTCP processor
[ https://issues.apache.org/jira/browse/MINIFICPP-259?page=com.atlassian.jira.plugin.system.issuetabpanels:comment-tabpanel&focusedCommentId=16209876#comment-16209876 ]
marco polo commented on MINIFICPP-259:
--------------------------------------
[~stevenimle] Thanks for the ticket. Unfortunately I think I did this since I had more complex logic there and left the conditional when I removed the other expressions during a merge in a large feature branch for C2.
Would you be willing to cut your teeth on MiNiFi. If you would like to submit a PR I'd be more than happy to review it. If not, no worries...still appreciate the ticket
> Readability and optimization improvement for GetTCP processor
> -------------------------------------------------------------
>
> Key: MINIFICPP-259
> URL: https://issues.apache.org/jira/browse/MINIFICPP-259
> Project: NiFi MiNiFi C++
> Issue Type: Improvement
> Affects Versions: 0.3.0
> Reporter: Steven Imle
> Labels: easyfix
> Original Estimate: 1h
> Remaining Estimate: 1h
>
> Should use one line return statement in `SocketAfterExecute::isCancelled`.
> Code is functionally correct but may compile down to something less efficient than intended.
--
This message was sent by Atlassian JIRA
(v6.4.14#64029)