You are viewing a plain text version of this content. The canonical link for it is here.
Posted to dev@camel.apache.org by Ramon Buckland <ra...@thebuckland.com> on 2009/01/23 08:15:01 UTC
Question : Naming conventions Abstract and Interfaces
Hi Guys,
What is the naming comvention in use for Abstract and Interfaces.
I am used to Abstract* .. and sometimes *Iface.
What is camel's preference ?
r.
Re: Question : Naming conventions Abstract and Interfaces
Posted by Claus Ibsen <cl...@gmail.com>.
Hi
I am not master of bash (yet) but I did a little count on Camel 2.0
davsclaus:(svn)camel[trunk:736917]/camel-core$ find . -name *.java | wc -l
895
davsclaus:(svn)camel[trunk:736917]/camel-core$ find . -name
*Abstra*.java | wc -l
0
davsclaus:(svn)camel[trunk:736917]/camel-core$ find . -name
*Support*.java | wc -l
27
davsclaus:(svn)camel[trunk:736917]/camel-core$ find . -name *Utils*.java | wc -l
0
davsclaus:(svn)camel[trunk:736917]/camel-core$ find . -name *Utils.java | wc -l
0
davsclaus:(svn)camel[trunk:736917]/camel-core$ find . -name *Util*.java | wc -l
2
davsclaus:(svn)camel[trunk:736917]/camel-core$ find . -name
*Helper*.java | wc -l
18
On Fri, Jan 23, 2009 at 5:24 PM, Hadrian Zbarcea <hz...@gmail.com> wrote:
> Yeah :)
>
> On Jan 23, 2009, at 11:11 AM, William Tam wrote:
>
>> What about static Helper/Utils class? I notice both XxxHelper and
>> XxxUtils names are used?
>>
>> On Fri, Jan 23, 2009 at 10:01 AM, Hadrian Zbarcea <hz...@gmail.com>
>> wrote:
>>>
>>> No particular one. We use Abstract* many times. For interfaces, just
>>> something suggestive.
>>>
>>> Cheers
>>> Hadrian
>>>
>>> On Jan 23, 2009, at 2:15 AM, Ramon Buckland wrote:
>>>
>>>> Hi Guys,
>>>>
>>>> What is the naming comvention in use for Abstract and Interfaces.
>>>> I am used to Abstract* .. and sometimes *Iface.
>>>>
>>>> What is camel's preference ?
>>>>
>>>> r.
>>>
>>>
>
>
--
Claus Ibsen
Apache Camel Committer
Open Source Integration: http://fusesource.com
Blog: http://davsclaus.blogspot.com/
Re: Question : Naming conventions Abstract and Interfaces
Posted by Hadrian Zbarcea <hz...@gmail.com>.
Yeah :)
On Jan 23, 2009, at 11:11 AM, William Tam wrote:
> What about static Helper/Utils class? I notice both XxxHelper and
> XxxUtils names are used?
>
> On Fri, Jan 23, 2009 at 10:01 AM, Hadrian Zbarcea
> <hz...@gmail.com> wrote:
>> No particular one. We use Abstract* many times. For interfaces,
>> just
>> something suggestive.
>>
>> Cheers
>> Hadrian
>>
>> On Jan 23, 2009, at 2:15 AM, Ramon Buckland wrote:
>>
>>> Hi Guys,
>>>
>>> What is the naming comvention in use for Abstract and Interfaces.
>>> I am used to Abstract* .. and sometimes *Iface.
>>>
>>> What is camel's preference ?
>>>
>>> r.
>>
>>
Re: Question : Naming conventions Abstract and Interfaces
Posted by William Tam <em...@gmail.com>.
What about static Helper/Utils class? I notice both XxxHelper and
XxxUtils names are used?
On Fri, Jan 23, 2009 at 10:01 AM, Hadrian Zbarcea <hz...@gmail.com> wrote:
> No particular one. We use Abstract* many times. For interfaces, just
> something suggestive.
>
> Cheers
> Hadrian
>
> On Jan 23, 2009, at 2:15 AM, Ramon Buckland wrote:
>
>> Hi Guys,
>>
>> What is the naming comvention in use for Abstract and Interfaces.
>> I am used to Abstract* .. and sometimes *Iface.
>>
>> What is camel's preference ?
>>
>> r.
>
>
Re: Question : Naming conventions Abstract and Interfaces
Posted by Hadrian Zbarcea <hz...@gmail.com>.
No particular one. We use Abstract* many times. For interfaces, just
something suggestive.
Cheers
Hadrian
On Jan 23, 2009, at 2:15 AM, Ramon Buckland wrote:
> Hi Guys,
>
> What is the naming comvention in use for Abstract and Interfaces.
> I am used to Abstract* .. and sometimes *Iface.
>
> What is camel's preference ?
>
> r.
Re: Question : Naming conventions Abstract and Interfaces
Posted by Claus Ibsen <cl...@gmail.com>.
On Fri, Jan 23, 2009 at 8:15 AM, Ramon Buckland <ra...@thebuckland.com> wrote:
> Hi Guys,
>
> What is the naming comvention in use for Abstract and Interfaces.
> I am used to Abstract* .. and sometimes *Iface.
>
> What is camel's preference ?
>
> r.
>
We do not use I as prefix for interface.
We do not use xxxImpl for implementing the interface
We use DefaultXXX for the default implementation of an interface
I dont think AbstractXXX is what we use. We kinda not use AbstractXXX
since many times we use DefaultXXX also for abstract classes as well.
In fact we only have one Abstract in camel-core
We kinda also use the Spring convention with its xxxSupport for
abstract classes.
So its usually either DefaultXXX or XXXSupport
In fact the AbstractSimpleLanguage we have should be renamed to
SimpleLangugeSupport to follow the convention.
--
Claus Ibsen
Apache Camel Committer
Open Source Integration: http://fusesource.com
Blog: http://davsclaus.blogspot.com/