You are viewing a plain text version of this content. The canonical link for it is here.
Posted to dev@tinkerpop.apache.org by Stephen Mallette <sp...@gmail.com> on 2016/09/07 11:02:33 UTC

[CANCEL][VOTE] TinkerPop 3.2.2 Release

This VOTE is cancelled - we have to scrap this build. Weak.

Kuppitz has a bug fix under test right now. On top of his fix, I will
officially correct the "bad link" to GLVs that Robert found (thanks for
reviewing/voting btw). Expect a new VOTE thread later today once this is
all settled.

Note that 3.1.4 did not have this problem so that VOTE can stay open - i
just tested that out to be sure:

gremlin> g.V(ids).as("a").
gremlin>
 repeat(bothE().otherV().simplePath()).times(5).emit(hasId(within(ids))).as("b").
gremlin> filter(select(last,"a","b").by(id).where("a", lt("b"))).
gremlin>  path().by().by(label)
==>[v[2], knows, v[1], knows, v[4]]
==>[v[2], knows, v[1], created, v[3], created, v[4]]
==>[v[2], knows, v[1], created, v[3], created, v[6]]
==>[v[2], knows, v[1], knows, v[4], created, v[3], created, v[6]]
==>[v[4], created, v[3], created, v[6]]
==>[v[4], knows, v[1], created, v[3], created, v[6]]




On Tue, Sep 6, 2016 at 6:47 PM, Stephen Mallette <sp...@gmail.com>
wrote:

> Kuppitz saw a problem in one of the recipes - note the second example:
>
> http://tinkerpop.apache.org/docs/3.2.2/recipes/
>
> no results and this was working in 3.2.1:
>
> http://tinkerpop.apache.org/docs/3.2.1/recipes/
>
> His gremlin session shows:
>
> gremlin> g.V().hasId(1)
> ==>v[1]
> gremlin> g.V().hasId(within(1,2))
> gremlin>
>
> so damn - i guess we need to scrap this release and fix that problem - i
> guess i'm -1 based on that..........anyone have a clue as to what changed
> to cause that problem?
>
>
> On Tue, Sep 6, 2016 at 6:12 PM, Daniel Kuppitz <me...@gremlin.guru> wrote:
>
>> Validation looks good:
>>
>> $ bin/validate-distribution.sh 3.2.2
>>
>> Validating binary distributions
>>
>> * downloading Apache TinkerPop Gremlin
>> (apache-tinkerpop-gremlin-console-3.2.2-bin.zip)... OK
>> * validating signatures and checksums ...
>>   * PGP signature ... OK
>>   * MD5 checksum ... OK
>>   * SHA1 checksum ... OK
>> * unzipping Apache TinkerPop Gremlin ... OK
>> * validating Apache TinkerPop Gremlin's docs ... OK
>> * validating Apache TinkerPop Gremlin's binaries ... OK
>> * validating Apache TinkerPop Gremlin's legal files ...
>>   * LICENSE ... OK
>>   * NOTICE ... OK
>> * validating Apache TinkerPop Gremlin's plugin directory ... OK
>> * validating Apache TinkerPop Gremlin's lib directory ... OK
>> * testing script evaluation ... OK
>>
>> * downloading Apache TinkerPop Gremlin
>> (apache-tinkerpop-gremlin-server-3.2.2-bin.zip)... OK
>> * validating signatures and checksums ...
>>   * PGP signature ... OK
>>   * MD5 checksum ... OK
>>   * SHA1 checksum ... OK
>> * unzipping Apache TinkerPop Gremlin ... OK
>> * validating Apache TinkerPop Gremlin's docs ... OK
>> * validating Apache TinkerPop Gremlin's binaries ... OK
>> * validating Apache TinkerPop Gremlin's legal files ...
>>   * LICENSE ... OK
>>   * NOTICE ... OK
>> * validating Apache TinkerPop Gremlin's plugin directory ... OK
>> * validating Apache TinkerPop Gremlin's lib directory ... OK
>>
>> Validating source distribution
>>
>> * downloading Apache TinkerPop 3.2.2 (apache-tinkerpop-3.2.2-src.zip)...
>> OK
>> * validating signatures and checksums ...
>>   * PGP signature ... OK
>>   * MD5 checksum ... OK
>>   * SHA1 checksum ... OK
>> * unzipping Apache TinkerPop 3.2.2 ... OK
>> OK
>>
>> The docs seem to be correct, but I don't like how we now have the numbered
>> indents, e.g:
>>
>> gremlin> g.V().hasLabel("person").groupCount().by(values("age").choose(
>> ......1>   is(lt(28)),constant("young"),
>> ......2>   choose(is(lt(30)),
>> ......3>          constant("old"),
>> ......4>          constant("very old"))))
>> ==>[young:1,old:1,very old:2]
>>
>>
>> This is bad, since our snippets are now no longer copy+pastable. I will
>> fix
>> that for the next release.
>>
>> All in all: VOTE: +1
>>
>> Cheers,
>> Daniel
>>
>>
>>
>> On Tue, Sep 6, 2016 at 10:05 PM, Stephen Mallette <sp...@gmail.com>
>> wrote:
>>
>> > Hello,
>> >
>> > We are happy to announce that TinkerPop 3.2.2 is ready for release.
>> >
>> > The release artifacts can be found at this location:
>> > https://dist.apache.org/repos/dist/dev/tinkerpop/3.2.2/
>> >
>> > The source distribution is provided by:
>> > apache-tinkerpop-3.2.2-src.zip
>> >
>> > Two binary distributions are provided for user convenience:
>> > apache-tinkerpop-gremlin-console-3.2.2-bin.zip
>> > apache-tinkerpop-gremlin-server-3.2.2-bin.zip
>> >
>> > The GPG key used to sign the release artifacts is available at:
>> >     https://dist.apache.org/repos/dist/dev/tinkerpop/KEYS
>> >
>> > The online docs can be found here:
>> > http://tinkerpop.apache.org/docs/3.2.2/ (user docs)
>> > http://tinkerpop.apache.org/docs/3.2.2/upgrade/ (upgrade docs)
>> > http://tinkerpop.apache.org/javadocs/3.2.2/core/ (core javadoc)
>> > http://tinkerpop.apache.org/javadocs/3.2.2/full/ (full javadoc)
>> >
>> > The tag in Apache Git can be found here:
>> > https://git-wip-us.apache.org/repos/asf?p=tinkerpop.git;a=tag;h=
>> > 16d28c16ea43c678a18061506b4f0dc6a384fa1e
>> >
>> > The release notes are available here:
>> > https://github.com/apache/tinkerpop/blob/3.2.2/
>> > CHANGELOG.asciidoc#tinkerpop-322-release-date-september-9-2016
>> >
>> > The [VOTE] will be open for the next 72 hours --- closing Friday
>> (September
>> > 9, 2016) at 4pm.
>> >
>> > My vote is +1.
>> >
>> > Thank you very much,
>> >
>> > Stephen
>> >
>>
>
>

Re: [CANCEL][VOTE] TinkerPop 3.2.2 Release

Posted by Stephen Mallette <sp...@gmail.com>.
Just to close the loop on this thread, the new VOTE thread is here:

https://lists.apache.org/thread.html/3182f5995f5e5ab0cb210553124501d1544bfffbf3d4109242da988a@%3Cdev.tinkerpop.apache.org%3E

On Wed, Sep 7, 2016 at 7:20 PM, Daniel Kuppitz <me...@gremlin.guru> wrote:

> >
> > The moral of the story: Use this (carefully) when you hear someone say
> > "we" and you need to count yourself out.
>
>
> I don't need to count myself out, since I was just waiting for you, so I
> can rebase and merge the other fixes ;)
>
> https://github.com/apache/tinkerpop/commits/master
>
>
>
>
>
> On Thu, Sep 8, 2016 at 1:00 AM, Marko Rodriguez <ok...@gmail.com>
> wrote:
>
> > Who is this “we” kemosabe?
> >         http://c2.com/cgi/wiki?WhoDoYouMeanWeKemoSabe <
> > http://c2.com/cgi/wiki?WhoDoYouMeanWeKemoSabe>
> >
> > Marko.
> >
> >
> >
> > > On Sep 7, 2016, at 3:53 PM, Daniel Kuppitz <me...@gremlin.guru> wrote:
> > >
> > > The last issue just got fixed in master/. Damn, we can be so fast &
> > > effective :).
> > >
> > > On Wed, Sep 7, 2016 at 11:35 PM, Daniel Kuppitz <me...@gremlin.guru>
> wrote:
> > >
> > >> The aforementioned issues are fixed, but now we've just found another
> > bug:
> > >>
> > >> gremlin> g.withBulk(false).withSack(1.0f,sum).V(1).local(outE('knows'
> > >> ).barrier(normSack).inV()).in('knows').barrier().sack() //*(6)*
> > >> ==>1.0
> > >> ==>1.0
> > >> ==>1.0
> > >> ...
> > >>
> > >>
> > >> The 1.0's go on and on. Unfortunately one more reason to delay the
> 3.2.2
> > >> release.
> > >>
> > >>
> > >> On Wed, Sep 7, 2016 at 1:02 PM, Stephen Mallette <
> spmallette@gmail.com>
> > >> wrote:
> > >>
> > >>> This VOTE is cancelled - we have to scrap this build. Weak.
> > >>>
> > >>> Kuppitz has a bug fix under test right now. On top of his fix, I will
> > >>> officially correct the "bad link" to GLVs that Robert found (thanks
> for
> > >>> reviewing/voting btw). Expect a new VOTE thread later today once this
> > is
> > >>> all settled.
> > >>>
> > >>> Note that 3.1.4 did not have this problem so that VOTE can stay open
> -
> > i
> > >>> just tested that out to be sure:
> > >>>
> > >>> gremlin> g.V(ids).as("a").
> > >>> gremlin>
> > >>> repeat(bothE().otherV().simplePath()).times(5).emit(hasId(
> > >>> within(ids))).as("b").
> > >>> gremlin> filter(select(last,"a","b").by(id).where("a", lt("b"))).
> > >>> gremlin>  path().by().by(label)
> > >>> ==>[v[2], knows, v[1], knows, v[4]]
> > >>> ==>[v[2], knows, v[1], created, v[3], created, v[4]]
> > >>> ==>[v[2], knows, v[1], created, v[3], created, v[6]]
> > >>> ==>[v[2], knows, v[1], knows, v[4], created, v[3], created, v[6]]
> > >>> ==>[v[4], created, v[3], created, v[6]]
> > >>> ==>[v[4], knows, v[1], created, v[3], created, v[6]]
> > >>>
> > >>>
> > >>>
> > >>>
> > >>> On Tue, Sep 6, 2016 at 6:47 PM, Stephen Mallette <
> spmallette@gmail.com
> > >
> > >>> wrote:
> > >>>
> > >>>> Kuppitz saw a problem in one of the recipes - note the second
> example:
> > >>>>
> > >>>> http://tinkerpop.apache.org/docs/3.2.2/recipes/
> > >>>>
> > >>>> no results and this was working in 3.2.1:
> > >>>>
> > >>>> http://tinkerpop.apache.org/docs/3.2.1/recipes/
> > >>>>
> > >>>> His gremlin session shows:
> > >>>>
> > >>>> gremlin> g.V().hasId(1)
> > >>>> ==>v[1]
> > >>>> gremlin> g.V().hasId(within(1,2))
> > >>>> gremlin>
> > >>>>
> > >>>> so damn - i guess we need to scrap this release and fix that problem
> > - i
> > >>>> guess i'm -1 based on that..........anyone have a clue as to what
> > >>> changed
> > >>>> to cause that problem?
> > >>>>
> > >>>>
> > >>>> On Tue, Sep 6, 2016 at 6:12 PM, Daniel Kuppitz <me...@gremlin.guru>
> > wrote:
> > >>>>
> > >>>>> Validation looks good:
> > >>>>>
> > >>>>> $ bin/validate-distribution.sh 3.2.2
> > >>>>>
> > >>>>> Validating binary distributions
> > >>>>>
> > >>>>> * downloading Apache TinkerPop Gremlin
> > >>>>> (apache-tinkerpop-gremlin-console-3.2.2-bin.zip)... OK
> > >>>>> * validating signatures and checksums ...
> > >>>>>  * PGP signature ... OK
> > >>>>>  * MD5 checksum ... OK
> > >>>>>  * SHA1 checksum ... OK
> > >>>>> * unzipping Apache TinkerPop Gremlin ... OK
> > >>>>> * validating Apache TinkerPop Gremlin's docs ... OK
> > >>>>> * validating Apache TinkerPop Gremlin's binaries ... OK
> > >>>>> * validating Apache TinkerPop Gremlin's legal files ...
> > >>>>>  * LICENSE ... OK
> > >>>>>  * NOTICE ... OK
> > >>>>> * validating Apache TinkerPop Gremlin's plugin directory ... OK
> > >>>>> * validating Apache TinkerPop Gremlin's lib directory ... OK
> > >>>>> * testing script evaluation ... OK
> > >>>>>
> > >>>>> * downloading Apache TinkerPop Gremlin
> > >>>>> (apache-tinkerpop-gremlin-server-3.2.2-bin.zip)... OK
> > >>>>> * validating signatures and checksums ...
> > >>>>>  * PGP signature ... OK
> > >>>>>  * MD5 checksum ... OK
> > >>>>>  * SHA1 checksum ... OK
> > >>>>> * unzipping Apache TinkerPop Gremlin ... OK
> > >>>>> * validating Apache TinkerPop Gremlin's docs ... OK
> > >>>>> * validating Apache TinkerPop Gremlin's binaries ... OK
> > >>>>> * validating Apache TinkerPop Gremlin's legal files ...
> > >>>>>  * LICENSE ... OK
> > >>>>>  * NOTICE ... OK
> > >>>>> * validating Apache TinkerPop Gremlin's plugin directory ... OK
> > >>>>> * validating Apache TinkerPop Gremlin's lib directory ... OK
> > >>>>>
> > >>>>> Validating source distribution
> > >>>>>
> > >>>>> * downloading Apache TinkerPop 3.2.2 (apache-tinkerpop-3.2.2-src.zi
> > >>> p)...
> > >>>>> OK
> > >>>>> * validating signatures and checksums ...
> > >>>>>  * PGP signature ... OK
> > >>>>>  * MD5 checksum ... OK
> > >>>>>  * SHA1 checksum ... OK
> > >>>>> * unzipping Apache TinkerPop 3.2.2 ... OK
> > >>>>> OK
> > >>>>>
> > >>>>> The docs seem to be correct, but I don't like how we now have the
> > >>> numbered
> > >>>>> indents, e.g:
> > >>>>>
> > >>>>> gremlin> g.V().hasLabel("person").groupCount().by(values("age").
> > choos
> > >>> e(
> > >>>>> ......1>   is(lt(28)),constant("young"),
> > >>>>> ......2>   choose(is(lt(30)),
> > >>>>> ......3>          constant("old"),
> > >>>>> ......4>          constant("very old"))))
> > >>>>> ==>[young:1,old:1,very old:2]
> > >>>>>
> > >>>>>
> > >>>>> This is bad, since our snippets are now no longer copy+pastable. I
> > will
> > >>>>> fix
> > >>>>> that for the next release.
> > >>>>>
> > >>>>> All in all: VOTE: +1
> > >>>>>
> > >>>>> Cheers,
> > >>>>> Daniel
> > >>>>>
> > >>>>>
> > >>>>>
> > >>>>> On Tue, Sep 6, 2016 at 10:05 PM, Stephen Mallette <
> > >>> spmallette@gmail.com>
> > >>>>> wrote:
> > >>>>>
> > >>>>>> Hello,
> > >>>>>>
> > >>>>>> We are happy to announce that TinkerPop 3.2.2 is ready for
> release.
> > >>>>>>
> > >>>>>> The release artifacts can be found at this location:
> > >>>>>> https://dist.apache.org/repos/dist/dev/tinkerpop/3.2.2/
> > >>>>>>
> > >>>>>> The source distribution is provided by:
> > >>>>>> apache-tinkerpop-3.2.2-src.zip
> > >>>>>>
> > >>>>>> Two binary distributions are provided for user convenience:
> > >>>>>> apache-tinkerpop-gremlin-console-3.2.2-bin.zip
> > >>>>>> apache-tinkerpop-gremlin-server-3.2.2-bin.zip
> > >>>>>>
> > >>>>>> The GPG key used to sign the release artifacts is available at:
> > >>>>>>    https://dist.apache.org/repos/dist/dev/tinkerpop/KEYS
> > >>>>>>
> > >>>>>> The online docs can be found here:
> > >>>>>> http://tinkerpop.apache.org/docs/3.2.2/ (user docs)
> > >>>>>> http://tinkerpop.apache.org/docs/3.2.2/upgrade/ (upgrade docs)
> > >>>>>> http://tinkerpop.apache.org/javadocs/3.2.2/core/ (core javadoc)
> > >>>>>> http://tinkerpop.apache.org/javadocs/3.2.2/full/ (full javadoc)
> > >>>>>>
> > >>>>>> The tag in Apache Git can be found here:
> > >>>>>> https://git-wip-us.apache.org/repos/asf?p=tinkerpop.git;a=tag;h=
> > >>>>>> 16d28c16ea43c678a18061506b4f0dc6a384fa1e
> > >>>>>>
> > >>>>>> The release notes are available here:
> > >>>>>> https://github.com/apache/tinkerpop/blob/3.2.2/
> > >>>>>> CHANGELOG.asciidoc#tinkerpop-322-release-date-september-9-2016
> > >>>>>>
> > >>>>>> The [VOTE] will be open for the next 72 hours --- closing Friday
> > >>>>> (September
> > >>>>>> 9, 2016) at 4pm.
> > >>>>>>
> > >>>>>> My vote is +1.
> > >>>>>>
> > >>>>>> Thank you very much,
> > >>>>>>
> > >>>>>> Stephen
> > >>>>>>
> > >>>>>
> > >>>>
> > >>>>
> > >>>
> > >>
> > >>
> >
> >
>

Re: [CANCEL][VOTE] TinkerPop 3.2.2 Release

Posted by Daniel Kuppitz <me...@gremlin.guru>.
>
> The moral of the story: Use this (carefully) when you hear someone say
> "we" and you need to count yourself out.


I don't need to count myself out, since I was just waiting for you, so I
can rebase and merge the other fixes ;)

https://github.com/apache/tinkerpop/commits/master





On Thu, Sep 8, 2016 at 1:00 AM, Marko Rodriguez <ok...@gmail.com>
wrote:

> Who is this “we” kemosabe?
>         http://c2.com/cgi/wiki?WhoDoYouMeanWeKemoSabe <
> http://c2.com/cgi/wiki?WhoDoYouMeanWeKemoSabe>
>
> Marko.
>
>
>
> > On Sep 7, 2016, at 3:53 PM, Daniel Kuppitz <me...@gremlin.guru> wrote:
> >
> > The last issue just got fixed in master/. Damn, we can be so fast &
> > effective :).
> >
> > On Wed, Sep 7, 2016 at 11:35 PM, Daniel Kuppitz <me...@gremlin.guru> wrote:
> >
> >> The aforementioned issues are fixed, but now we've just found another
> bug:
> >>
> >> gremlin> g.withBulk(false).withSack(1.0f,sum).V(1).local(outE('knows'
> >> ).barrier(normSack).inV()).in('knows').barrier().sack() //*(6)*
> >> ==>1.0
> >> ==>1.0
> >> ==>1.0
> >> ...
> >>
> >>
> >> The 1.0's go on and on. Unfortunately one more reason to delay the 3.2.2
> >> release.
> >>
> >>
> >> On Wed, Sep 7, 2016 at 1:02 PM, Stephen Mallette <sp...@gmail.com>
> >> wrote:
> >>
> >>> This VOTE is cancelled - we have to scrap this build. Weak.
> >>>
> >>> Kuppitz has a bug fix under test right now. On top of his fix, I will
> >>> officially correct the "bad link" to GLVs that Robert found (thanks for
> >>> reviewing/voting btw). Expect a new VOTE thread later today once this
> is
> >>> all settled.
> >>>
> >>> Note that 3.1.4 did not have this problem so that VOTE can stay open -
> i
> >>> just tested that out to be sure:
> >>>
> >>> gremlin> g.V(ids).as("a").
> >>> gremlin>
> >>> repeat(bothE().otherV().simplePath()).times(5).emit(hasId(
> >>> within(ids))).as("b").
> >>> gremlin> filter(select(last,"a","b").by(id).where("a", lt("b"))).
> >>> gremlin>  path().by().by(label)
> >>> ==>[v[2], knows, v[1], knows, v[4]]
> >>> ==>[v[2], knows, v[1], created, v[3], created, v[4]]
> >>> ==>[v[2], knows, v[1], created, v[3], created, v[6]]
> >>> ==>[v[2], knows, v[1], knows, v[4], created, v[3], created, v[6]]
> >>> ==>[v[4], created, v[3], created, v[6]]
> >>> ==>[v[4], knows, v[1], created, v[3], created, v[6]]
> >>>
> >>>
> >>>
> >>>
> >>> On Tue, Sep 6, 2016 at 6:47 PM, Stephen Mallette <spmallette@gmail.com
> >
> >>> wrote:
> >>>
> >>>> Kuppitz saw a problem in one of the recipes - note the second example:
> >>>>
> >>>> http://tinkerpop.apache.org/docs/3.2.2/recipes/
> >>>>
> >>>> no results and this was working in 3.2.1:
> >>>>
> >>>> http://tinkerpop.apache.org/docs/3.2.1/recipes/
> >>>>
> >>>> His gremlin session shows:
> >>>>
> >>>> gremlin> g.V().hasId(1)
> >>>> ==>v[1]
> >>>> gremlin> g.V().hasId(within(1,2))
> >>>> gremlin>
> >>>>
> >>>> so damn - i guess we need to scrap this release and fix that problem
> - i
> >>>> guess i'm -1 based on that..........anyone have a clue as to what
> >>> changed
> >>>> to cause that problem?
> >>>>
> >>>>
> >>>> On Tue, Sep 6, 2016 at 6:12 PM, Daniel Kuppitz <me...@gremlin.guru>
> wrote:
> >>>>
> >>>>> Validation looks good:
> >>>>>
> >>>>> $ bin/validate-distribution.sh 3.2.2
> >>>>>
> >>>>> Validating binary distributions
> >>>>>
> >>>>> * downloading Apache TinkerPop Gremlin
> >>>>> (apache-tinkerpop-gremlin-console-3.2.2-bin.zip)... OK
> >>>>> * validating signatures and checksums ...
> >>>>>  * PGP signature ... OK
> >>>>>  * MD5 checksum ... OK
> >>>>>  * SHA1 checksum ... OK
> >>>>> * unzipping Apache TinkerPop Gremlin ... OK
> >>>>> * validating Apache TinkerPop Gremlin's docs ... OK
> >>>>> * validating Apache TinkerPop Gremlin's binaries ... OK
> >>>>> * validating Apache TinkerPop Gremlin's legal files ...
> >>>>>  * LICENSE ... OK
> >>>>>  * NOTICE ... OK
> >>>>> * validating Apache TinkerPop Gremlin's plugin directory ... OK
> >>>>> * validating Apache TinkerPop Gremlin's lib directory ... OK
> >>>>> * testing script evaluation ... OK
> >>>>>
> >>>>> * downloading Apache TinkerPop Gremlin
> >>>>> (apache-tinkerpop-gremlin-server-3.2.2-bin.zip)... OK
> >>>>> * validating signatures and checksums ...
> >>>>>  * PGP signature ... OK
> >>>>>  * MD5 checksum ... OK
> >>>>>  * SHA1 checksum ... OK
> >>>>> * unzipping Apache TinkerPop Gremlin ... OK
> >>>>> * validating Apache TinkerPop Gremlin's docs ... OK
> >>>>> * validating Apache TinkerPop Gremlin's binaries ... OK
> >>>>> * validating Apache TinkerPop Gremlin's legal files ...
> >>>>>  * LICENSE ... OK
> >>>>>  * NOTICE ... OK
> >>>>> * validating Apache TinkerPop Gremlin's plugin directory ... OK
> >>>>> * validating Apache TinkerPop Gremlin's lib directory ... OK
> >>>>>
> >>>>> Validating source distribution
> >>>>>
> >>>>> * downloading Apache TinkerPop 3.2.2 (apache-tinkerpop-3.2.2-src.zi
> >>> p)...
> >>>>> OK
> >>>>> * validating signatures and checksums ...
> >>>>>  * PGP signature ... OK
> >>>>>  * MD5 checksum ... OK
> >>>>>  * SHA1 checksum ... OK
> >>>>> * unzipping Apache TinkerPop 3.2.2 ... OK
> >>>>> OK
> >>>>>
> >>>>> The docs seem to be correct, but I don't like how we now have the
> >>> numbered
> >>>>> indents, e.g:
> >>>>>
> >>>>> gremlin> g.V().hasLabel("person").groupCount().by(values("age").
> choos
> >>> e(
> >>>>> ......1>   is(lt(28)),constant("young"),
> >>>>> ......2>   choose(is(lt(30)),
> >>>>> ......3>          constant("old"),
> >>>>> ......4>          constant("very old"))))
> >>>>> ==>[young:1,old:1,very old:2]
> >>>>>
> >>>>>
> >>>>> This is bad, since our snippets are now no longer copy+pastable. I
> will
> >>>>> fix
> >>>>> that for the next release.
> >>>>>
> >>>>> All in all: VOTE: +1
> >>>>>
> >>>>> Cheers,
> >>>>> Daniel
> >>>>>
> >>>>>
> >>>>>
> >>>>> On Tue, Sep 6, 2016 at 10:05 PM, Stephen Mallette <
> >>> spmallette@gmail.com>
> >>>>> wrote:
> >>>>>
> >>>>>> Hello,
> >>>>>>
> >>>>>> We are happy to announce that TinkerPop 3.2.2 is ready for release.
> >>>>>>
> >>>>>> The release artifacts can be found at this location:
> >>>>>> https://dist.apache.org/repos/dist/dev/tinkerpop/3.2.2/
> >>>>>>
> >>>>>> The source distribution is provided by:
> >>>>>> apache-tinkerpop-3.2.2-src.zip
> >>>>>>
> >>>>>> Two binary distributions are provided for user convenience:
> >>>>>> apache-tinkerpop-gremlin-console-3.2.2-bin.zip
> >>>>>> apache-tinkerpop-gremlin-server-3.2.2-bin.zip
> >>>>>>
> >>>>>> The GPG key used to sign the release artifacts is available at:
> >>>>>>    https://dist.apache.org/repos/dist/dev/tinkerpop/KEYS
> >>>>>>
> >>>>>> The online docs can be found here:
> >>>>>> http://tinkerpop.apache.org/docs/3.2.2/ (user docs)
> >>>>>> http://tinkerpop.apache.org/docs/3.2.2/upgrade/ (upgrade docs)
> >>>>>> http://tinkerpop.apache.org/javadocs/3.2.2/core/ (core javadoc)
> >>>>>> http://tinkerpop.apache.org/javadocs/3.2.2/full/ (full javadoc)
> >>>>>>
> >>>>>> The tag in Apache Git can be found here:
> >>>>>> https://git-wip-us.apache.org/repos/asf?p=tinkerpop.git;a=tag;h=
> >>>>>> 16d28c16ea43c678a18061506b4f0dc6a384fa1e
> >>>>>>
> >>>>>> The release notes are available here:
> >>>>>> https://github.com/apache/tinkerpop/blob/3.2.2/
> >>>>>> CHANGELOG.asciidoc#tinkerpop-322-release-date-september-9-2016
> >>>>>>
> >>>>>> The [VOTE] will be open for the next 72 hours --- closing Friday
> >>>>> (September
> >>>>>> 9, 2016) at 4pm.
> >>>>>>
> >>>>>> My vote is +1.
> >>>>>>
> >>>>>> Thank you very much,
> >>>>>>
> >>>>>> Stephen
> >>>>>>
> >>>>>
> >>>>
> >>>>
> >>>
> >>
> >>
>
>

Re: [CANCEL][VOTE] TinkerPop 3.2.2 Release

Posted by Marko Rodriguez <ok...@gmail.com>.
Who is this “we” kemosabe?
	http://c2.com/cgi/wiki?WhoDoYouMeanWeKemoSabe <http://c2.com/cgi/wiki?WhoDoYouMeanWeKemoSabe>

Marko.



> On Sep 7, 2016, at 3:53 PM, Daniel Kuppitz <me...@gremlin.guru> wrote:
> 
> The last issue just got fixed in master/. Damn, we can be so fast &
> effective :).
> 
> On Wed, Sep 7, 2016 at 11:35 PM, Daniel Kuppitz <me...@gremlin.guru> wrote:
> 
>> The aforementioned issues are fixed, but now we've just found another bug:
>> 
>> gremlin> g.withBulk(false).withSack(1.0f,sum).V(1).local(outE('knows'
>> ).barrier(normSack).inV()).in('knows').barrier().sack() //*(6)*
>> ==>1.0
>> ==>1.0
>> ==>1.0
>> ...
>> 
>> 
>> The 1.0's go on and on. Unfortunately one more reason to delay the 3.2.2
>> release.
>> 
>> 
>> On Wed, Sep 7, 2016 at 1:02 PM, Stephen Mallette <sp...@gmail.com>
>> wrote:
>> 
>>> This VOTE is cancelled - we have to scrap this build. Weak.
>>> 
>>> Kuppitz has a bug fix under test right now. On top of his fix, I will
>>> officially correct the "bad link" to GLVs that Robert found (thanks for
>>> reviewing/voting btw). Expect a new VOTE thread later today once this is
>>> all settled.
>>> 
>>> Note that 3.1.4 did not have this problem so that VOTE can stay open - i
>>> just tested that out to be sure:
>>> 
>>> gremlin> g.V(ids).as("a").
>>> gremlin>
>>> repeat(bothE().otherV().simplePath()).times(5).emit(hasId(
>>> within(ids))).as("b").
>>> gremlin> filter(select(last,"a","b").by(id).where("a", lt("b"))).
>>> gremlin>  path().by().by(label)
>>> ==>[v[2], knows, v[1], knows, v[4]]
>>> ==>[v[2], knows, v[1], created, v[3], created, v[4]]
>>> ==>[v[2], knows, v[1], created, v[3], created, v[6]]
>>> ==>[v[2], knows, v[1], knows, v[4], created, v[3], created, v[6]]
>>> ==>[v[4], created, v[3], created, v[6]]
>>> ==>[v[4], knows, v[1], created, v[3], created, v[6]]
>>> 
>>> 
>>> 
>>> 
>>> On Tue, Sep 6, 2016 at 6:47 PM, Stephen Mallette <sp...@gmail.com>
>>> wrote:
>>> 
>>>> Kuppitz saw a problem in one of the recipes - note the second example:
>>>> 
>>>> http://tinkerpop.apache.org/docs/3.2.2/recipes/
>>>> 
>>>> no results and this was working in 3.2.1:
>>>> 
>>>> http://tinkerpop.apache.org/docs/3.2.1/recipes/
>>>> 
>>>> His gremlin session shows:
>>>> 
>>>> gremlin> g.V().hasId(1)
>>>> ==>v[1]
>>>> gremlin> g.V().hasId(within(1,2))
>>>> gremlin>
>>>> 
>>>> so damn - i guess we need to scrap this release and fix that problem - i
>>>> guess i'm -1 based on that..........anyone have a clue as to what
>>> changed
>>>> to cause that problem?
>>>> 
>>>> 
>>>> On Tue, Sep 6, 2016 at 6:12 PM, Daniel Kuppitz <me...@gremlin.guru> wrote:
>>>> 
>>>>> Validation looks good:
>>>>> 
>>>>> $ bin/validate-distribution.sh 3.2.2
>>>>> 
>>>>> Validating binary distributions
>>>>> 
>>>>> * downloading Apache TinkerPop Gremlin
>>>>> (apache-tinkerpop-gremlin-console-3.2.2-bin.zip)... OK
>>>>> * validating signatures and checksums ...
>>>>>  * PGP signature ... OK
>>>>>  * MD5 checksum ... OK
>>>>>  * SHA1 checksum ... OK
>>>>> * unzipping Apache TinkerPop Gremlin ... OK
>>>>> * validating Apache TinkerPop Gremlin's docs ... OK
>>>>> * validating Apache TinkerPop Gremlin's binaries ... OK
>>>>> * validating Apache TinkerPop Gremlin's legal files ...
>>>>>  * LICENSE ... OK
>>>>>  * NOTICE ... OK
>>>>> * validating Apache TinkerPop Gremlin's plugin directory ... OK
>>>>> * validating Apache TinkerPop Gremlin's lib directory ... OK
>>>>> * testing script evaluation ... OK
>>>>> 
>>>>> * downloading Apache TinkerPop Gremlin
>>>>> (apache-tinkerpop-gremlin-server-3.2.2-bin.zip)... OK
>>>>> * validating signatures and checksums ...
>>>>>  * PGP signature ... OK
>>>>>  * MD5 checksum ... OK
>>>>>  * SHA1 checksum ... OK
>>>>> * unzipping Apache TinkerPop Gremlin ... OK
>>>>> * validating Apache TinkerPop Gremlin's docs ... OK
>>>>> * validating Apache TinkerPop Gremlin's binaries ... OK
>>>>> * validating Apache TinkerPop Gremlin's legal files ...
>>>>>  * LICENSE ... OK
>>>>>  * NOTICE ... OK
>>>>> * validating Apache TinkerPop Gremlin's plugin directory ... OK
>>>>> * validating Apache TinkerPop Gremlin's lib directory ... OK
>>>>> 
>>>>> Validating source distribution
>>>>> 
>>>>> * downloading Apache TinkerPop 3.2.2 (apache-tinkerpop-3.2.2-src.zi
>>> p)...
>>>>> OK
>>>>> * validating signatures and checksums ...
>>>>>  * PGP signature ... OK
>>>>>  * MD5 checksum ... OK
>>>>>  * SHA1 checksum ... OK
>>>>> * unzipping Apache TinkerPop 3.2.2 ... OK
>>>>> OK
>>>>> 
>>>>> The docs seem to be correct, but I don't like how we now have the
>>> numbered
>>>>> indents, e.g:
>>>>> 
>>>>> gremlin> g.V().hasLabel("person").groupCount().by(values("age").choos
>>> e(
>>>>> ......1>   is(lt(28)),constant("young"),
>>>>> ......2>   choose(is(lt(30)),
>>>>> ......3>          constant("old"),
>>>>> ......4>          constant("very old"))))
>>>>> ==>[young:1,old:1,very old:2]
>>>>> 
>>>>> 
>>>>> This is bad, since our snippets are now no longer copy+pastable. I will
>>>>> fix
>>>>> that for the next release.
>>>>> 
>>>>> All in all: VOTE: +1
>>>>> 
>>>>> Cheers,
>>>>> Daniel
>>>>> 
>>>>> 
>>>>> 
>>>>> On Tue, Sep 6, 2016 at 10:05 PM, Stephen Mallette <
>>> spmallette@gmail.com>
>>>>> wrote:
>>>>> 
>>>>>> Hello,
>>>>>> 
>>>>>> We are happy to announce that TinkerPop 3.2.2 is ready for release.
>>>>>> 
>>>>>> The release artifacts can be found at this location:
>>>>>> https://dist.apache.org/repos/dist/dev/tinkerpop/3.2.2/
>>>>>> 
>>>>>> The source distribution is provided by:
>>>>>> apache-tinkerpop-3.2.2-src.zip
>>>>>> 
>>>>>> Two binary distributions are provided for user convenience:
>>>>>> apache-tinkerpop-gremlin-console-3.2.2-bin.zip
>>>>>> apache-tinkerpop-gremlin-server-3.2.2-bin.zip
>>>>>> 
>>>>>> The GPG key used to sign the release artifacts is available at:
>>>>>>    https://dist.apache.org/repos/dist/dev/tinkerpop/KEYS
>>>>>> 
>>>>>> The online docs can be found here:
>>>>>> http://tinkerpop.apache.org/docs/3.2.2/ (user docs)
>>>>>> http://tinkerpop.apache.org/docs/3.2.2/upgrade/ (upgrade docs)
>>>>>> http://tinkerpop.apache.org/javadocs/3.2.2/core/ (core javadoc)
>>>>>> http://tinkerpop.apache.org/javadocs/3.2.2/full/ (full javadoc)
>>>>>> 
>>>>>> The tag in Apache Git can be found here:
>>>>>> https://git-wip-us.apache.org/repos/asf?p=tinkerpop.git;a=tag;h=
>>>>>> 16d28c16ea43c678a18061506b4f0dc6a384fa1e
>>>>>> 
>>>>>> The release notes are available here:
>>>>>> https://github.com/apache/tinkerpop/blob/3.2.2/
>>>>>> CHANGELOG.asciidoc#tinkerpop-322-release-date-september-9-2016
>>>>>> 
>>>>>> The [VOTE] will be open for the next 72 hours --- closing Friday
>>>>> (September
>>>>>> 9, 2016) at 4pm.
>>>>>> 
>>>>>> My vote is +1.
>>>>>> 
>>>>>> Thank you very much,
>>>>>> 
>>>>>> Stephen
>>>>>> 
>>>>> 
>>>> 
>>>> 
>>> 
>> 
>> 


Re: [CANCEL][VOTE] TinkerPop 3.2.2 Release

Posted by Daniel Kuppitz <me...@gremlin.guru>.
The last issue just got fixed in master/. Damn, we can be so fast &
effective :).

On Wed, Sep 7, 2016 at 11:35 PM, Daniel Kuppitz <me...@gremlin.guru> wrote:

> The aforementioned issues are fixed, but now we've just found another bug:
>
> gremlin> g.withBulk(false).withSack(1.0f,sum).V(1).local(outE('knows'
> ).barrier(normSack).inV()).in('knows').barrier().sack() //*(6)*
> ==>1.0
> ==>1.0
> ==>1.0
> ...
>
>
> The 1.0's go on and on. Unfortunately one more reason to delay the 3.2.2
> release.
>
>
> On Wed, Sep 7, 2016 at 1:02 PM, Stephen Mallette <sp...@gmail.com>
> wrote:
>
>> This VOTE is cancelled - we have to scrap this build. Weak.
>>
>> Kuppitz has a bug fix under test right now. On top of his fix, I will
>> officially correct the "bad link" to GLVs that Robert found (thanks for
>> reviewing/voting btw). Expect a new VOTE thread later today once this is
>> all settled.
>>
>> Note that 3.1.4 did not have this problem so that VOTE can stay open - i
>> just tested that out to be sure:
>>
>> gremlin> g.V(ids).as("a").
>> gremlin>
>>  repeat(bothE().otherV().simplePath()).times(5).emit(hasId(
>> within(ids))).as("b").
>> gremlin> filter(select(last,"a","b").by(id).where("a", lt("b"))).
>> gremlin>  path().by().by(label)
>> ==>[v[2], knows, v[1], knows, v[4]]
>> ==>[v[2], knows, v[1], created, v[3], created, v[4]]
>> ==>[v[2], knows, v[1], created, v[3], created, v[6]]
>> ==>[v[2], knows, v[1], knows, v[4], created, v[3], created, v[6]]
>> ==>[v[4], created, v[3], created, v[6]]
>> ==>[v[4], knows, v[1], created, v[3], created, v[6]]
>>
>>
>>
>>
>> On Tue, Sep 6, 2016 at 6:47 PM, Stephen Mallette <sp...@gmail.com>
>> wrote:
>>
>> > Kuppitz saw a problem in one of the recipes - note the second example:
>> >
>> > http://tinkerpop.apache.org/docs/3.2.2/recipes/
>> >
>> > no results and this was working in 3.2.1:
>> >
>> > http://tinkerpop.apache.org/docs/3.2.1/recipes/
>> >
>> > His gremlin session shows:
>> >
>> > gremlin> g.V().hasId(1)
>> > ==>v[1]
>> > gremlin> g.V().hasId(within(1,2))
>> > gremlin>
>> >
>> > so damn - i guess we need to scrap this release and fix that problem - i
>> > guess i'm -1 based on that..........anyone have a clue as to what
>> changed
>> > to cause that problem?
>> >
>> >
>> > On Tue, Sep 6, 2016 at 6:12 PM, Daniel Kuppitz <me...@gremlin.guru> wrote:
>> >
>> >> Validation looks good:
>> >>
>> >> $ bin/validate-distribution.sh 3.2.2
>> >>
>> >> Validating binary distributions
>> >>
>> >> * downloading Apache TinkerPop Gremlin
>> >> (apache-tinkerpop-gremlin-console-3.2.2-bin.zip)... OK
>> >> * validating signatures and checksums ...
>> >>   * PGP signature ... OK
>> >>   * MD5 checksum ... OK
>> >>   * SHA1 checksum ... OK
>> >> * unzipping Apache TinkerPop Gremlin ... OK
>> >> * validating Apache TinkerPop Gremlin's docs ... OK
>> >> * validating Apache TinkerPop Gremlin's binaries ... OK
>> >> * validating Apache TinkerPop Gremlin's legal files ...
>> >>   * LICENSE ... OK
>> >>   * NOTICE ... OK
>> >> * validating Apache TinkerPop Gremlin's plugin directory ... OK
>> >> * validating Apache TinkerPop Gremlin's lib directory ... OK
>> >> * testing script evaluation ... OK
>> >>
>> >> * downloading Apache TinkerPop Gremlin
>> >> (apache-tinkerpop-gremlin-server-3.2.2-bin.zip)... OK
>> >> * validating signatures and checksums ...
>> >>   * PGP signature ... OK
>> >>   * MD5 checksum ... OK
>> >>   * SHA1 checksum ... OK
>> >> * unzipping Apache TinkerPop Gremlin ... OK
>> >> * validating Apache TinkerPop Gremlin's docs ... OK
>> >> * validating Apache TinkerPop Gremlin's binaries ... OK
>> >> * validating Apache TinkerPop Gremlin's legal files ...
>> >>   * LICENSE ... OK
>> >>   * NOTICE ... OK
>> >> * validating Apache TinkerPop Gremlin's plugin directory ... OK
>> >> * validating Apache TinkerPop Gremlin's lib directory ... OK
>> >>
>> >> Validating source distribution
>> >>
>> >> * downloading Apache TinkerPop 3.2.2 (apache-tinkerpop-3.2.2-src.zi
>> p)...
>> >> OK
>> >> * validating signatures and checksums ...
>> >>   * PGP signature ... OK
>> >>   * MD5 checksum ... OK
>> >>   * SHA1 checksum ... OK
>> >> * unzipping Apache TinkerPop 3.2.2 ... OK
>> >> OK
>> >>
>> >> The docs seem to be correct, but I don't like how we now have the
>> numbered
>> >> indents, e.g:
>> >>
>> >> gremlin> g.V().hasLabel("person").groupCount().by(values("age").choos
>> e(
>> >> ......1>   is(lt(28)),constant("young"),
>> >> ......2>   choose(is(lt(30)),
>> >> ......3>          constant("old"),
>> >> ......4>          constant("very old"))))
>> >> ==>[young:1,old:1,very old:2]
>> >>
>> >>
>> >> This is bad, since our snippets are now no longer copy+pastable. I will
>> >> fix
>> >> that for the next release.
>> >>
>> >> All in all: VOTE: +1
>> >>
>> >> Cheers,
>> >> Daniel
>> >>
>> >>
>> >>
>> >> On Tue, Sep 6, 2016 at 10:05 PM, Stephen Mallette <
>> spmallette@gmail.com>
>> >> wrote:
>> >>
>> >> > Hello,
>> >> >
>> >> > We are happy to announce that TinkerPop 3.2.2 is ready for release.
>> >> >
>> >> > The release artifacts can be found at this location:
>> >> > https://dist.apache.org/repos/dist/dev/tinkerpop/3.2.2/
>> >> >
>> >> > The source distribution is provided by:
>> >> > apache-tinkerpop-3.2.2-src.zip
>> >> >
>> >> > Two binary distributions are provided for user convenience:
>> >> > apache-tinkerpop-gremlin-console-3.2.2-bin.zip
>> >> > apache-tinkerpop-gremlin-server-3.2.2-bin.zip
>> >> >
>> >> > The GPG key used to sign the release artifacts is available at:
>> >> >     https://dist.apache.org/repos/dist/dev/tinkerpop/KEYS
>> >> >
>> >> > The online docs can be found here:
>> >> > http://tinkerpop.apache.org/docs/3.2.2/ (user docs)
>> >> > http://tinkerpop.apache.org/docs/3.2.2/upgrade/ (upgrade docs)
>> >> > http://tinkerpop.apache.org/javadocs/3.2.2/core/ (core javadoc)
>> >> > http://tinkerpop.apache.org/javadocs/3.2.2/full/ (full javadoc)
>> >> >
>> >> > The tag in Apache Git can be found here:
>> >> > https://git-wip-us.apache.org/repos/asf?p=tinkerpop.git;a=tag;h=
>> >> > 16d28c16ea43c678a18061506b4f0dc6a384fa1e
>> >> >
>> >> > The release notes are available here:
>> >> > https://github.com/apache/tinkerpop/blob/3.2.2/
>> >> > CHANGELOG.asciidoc#tinkerpop-322-release-date-september-9-2016
>> >> >
>> >> > The [VOTE] will be open for the next 72 hours --- closing Friday
>> >> (September
>> >> > 9, 2016) at 4pm.
>> >> >
>> >> > My vote is +1.
>> >> >
>> >> > Thank you very much,
>> >> >
>> >> > Stephen
>> >> >
>> >>
>> >
>> >
>>
>
>

Re: [CANCEL][VOTE] TinkerPop 3.2.2 Release

Posted by Daniel Kuppitz <me...@gremlin.guru>.
The aforementioned issues are fixed, but now we've just found another bug:

gremlin> g.withBulk(false).withSack(1.0f,sum).V(1).local(outE('knows'
).barrier(normSack).inV()).in('knows').barrier().sack() //*(6)*
==>1.0
==>1.0
==>1.0
...


The 1.0's go on and on. Unfortunately one more reason to delay the 3.2.2
release.


On Wed, Sep 7, 2016 at 1:02 PM, Stephen Mallette <sp...@gmail.com>
wrote:

> This VOTE is cancelled - we have to scrap this build. Weak.
>
> Kuppitz has a bug fix under test right now. On top of his fix, I will
> officially correct the "bad link" to GLVs that Robert found (thanks for
> reviewing/voting btw). Expect a new VOTE thread later today once this is
> all settled.
>
> Note that 3.1.4 did not have this problem so that VOTE can stay open - i
> just tested that out to be sure:
>
> gremlin> g.V(ids).as("a").
> gremlin>
>  repeat(bothE().otherV().simplePath()).times(5).emit(
> hasId(within(ids))).as("b").
> gremlin> filter(select(last,"a","b").by(id).where("a", lt("b"))).
> gremlin>  path().by().by(label)
> ==>[v[2], knows, v[1], knows, v[4]]
> ==>[v[2], knows, v[1], created, v[3], created, v[4]]
> ==>[v[2], knows, v[1], created, v[3], created, v[6]]
> ==>[v[2], knows, v[1], knows, v[4], created, v[3], created, v[6]]
> ==>[v[4], created, v[3], created, v[6]]
> ==>[v[4], knows, v[1], created, v[3], created, v[6]]
>
>
>
>
> On Tue, Sep 6, 2016 at 6:47 PM, Stephen Mallette <sp...@gmail.com>
> wrote:
>
> > Kuppitz saw a problem in one of the recipes - note the second example:
> >
> > http://tinkerpop.apache.org/docs/3.2.2/recipes/
> >
> > no results and this was working in 3.2.1:
> >
> > http://tinkerpop.apache.org/docs/3.2.1/recipes/
> >
> > His gremlin session shows:
> >
> > gremlin> g.V().hasId(1)
> > ==>v[1]
> > gremlin> g.V().hasId(within(1,2))
> > gremlin>
> >
> > so damn - i guess we need to scrap this release and fix that problem - i
> > guess i'm -1 based on that..........anyone have a clue as to what changed
> > to cause that problem?
> >
> >
> > On Tue, Sep 6, 2016 at 6:12 PM, Daniel Kuppitz <me...@gremlin.guru> wrote:
> >
> >> Validation looks good:
> >>
> >> $ bin/validate-distribution.sh 3.2.2
> >>
> >> Validating binary distributions
> >>
> >> * downloading Apache TinkerPop Gremlin
> >> (apache-tinkerpop-gremlin-console-3.2.2-bin.zip)... OK
> >> * validating signatures and checksums ...
> >>   * PGP signature ... OK
> >>   * MD5 checksum ... OK
> >>   * SHA1 checksum ... OK
> >> * unzipping Apache TinkerPop Gremlin ... OK
> >> * validating Apache TinkerPop Gremlin's docs ... OK
> >> * validating Apache TinkerPop Gremlin's binaries ... OK
> >> * validating Apache TinkerPop Gremlin's legal files ...
> >>   * LICENSE ... OK
> >>   * NOTICE ... OK
> >> * validating Apache TinkerPop Gremlin's plugin directory ... OK
> >> * validating Apache TinkerPop Gremlin's lib directory ... OK
> >> * testing script evaluation ... OK
> >>
> >> * downloading Apache TinkerPop Gremlin
> >> (apache-tinkerpop-gremlin-server-3.2.2-bin.zip)... OK
> >> * validating signatures and checksums ...
> >>   * PGP signature ... OK
> >>   * MD5 checksum ... OK
> >>   * SHA1 checksum ... OK
> >> * unzipping Apache TinkerPop Gremlin ... OK
> >> * validating Apache TinkerPop Gremlin's docs ... OK
> >> * validating Apache TinkerPop Gremlin's binaries ... OK
> >> * validating Apache TinkerPop Gremlin's legal files ...
> >>   * LICENSE ... OK
> >>   * NOTICE ... OK
> >> * validating Apache TinkerPop Gremlin's plugin directory ... OK
> >> * validating Apache TinkerPop Gremlin's lib directory ... OK
> >>
> >> Validating source distribution
> >>
> >> * downloading Apache TinkerPop 3.2.2 (apache-tinkerpop-3.2.2-src.
> zip)...
> >> OK
> >> * validating signatures and checksums ...
> >>   * PGP signature ... OK
> >>   * MD5 checksum ... OK
> >>   * SHA1 checksum ... OK
> >> * unzipping Apache TinkerPop 3.2.2 ... OK
> >> OK
> >>
> >> The docs seem to be correct, but I don't like how we now have the
> numbered
> >> indents, e.g:
> >>
> >> gremlin> g.V().hasLabel("person").groupCount().by(values("age").choose(
> >> ......1>   is(lt(28)),constant("young"),
> >> ......2>   choose(is(lt(30)),
> >> ......3>          constant("old"),
> >> ......4>          constant("very old"))))
> >> ==>[young:1,old:1,very old:2]
> >>
> >>
> >> This is bad, since our snippets are now no longer copy+pastable. I will
> >> fix
> >> that for the next release.
> >>
> >> All in all: VOTE: +1
> >>
> >> Cheers,
> >> Daniel
> >>
> >>
> >>
> >> On Tue, Sep 6, 2016 at 10:05 PM, Stephen Mallette <spmallette@gmail.com
> >
> >> wrote:
> >>
> >> > Hello,
> >> >
> >> > We are happy to announce that TinkerPop 3.2.2 is ready for release.
> >> >
> >> > The release artifacts can be found at this location:
> >> > https://dist.apache.org/repos/dist/dev/tinkerpop/3.2.2/
> >> >
> >> > The source distribution is provided by:
> >> > apache-tinkerpop-3.2.2-src.zip
> >> >
> >> > Two binary distributions are provided for user convenience:
> >> > apache-tinkerpop-gremlin-console-3.2.2-bin.zip
> >> > apache-tinkerpop-gremlin-server-3.2.2-bin.zip
> >> >
> >> > The GPG key used to sign the release artifacts is available at:
> >> >     https://dist.apache.org/repos/dist/dev/tinkerpop/KEYS
> >> >
> >> > The online docs can be found here:
> >> > http://tinkerpop.apache.org/docs/3.2.2/ (user docs)
> >> > http://tinkerpop.apache.org/docs/3.2.2/upgrade/ (upgrade docs)
> >> > http://tinkerpop.apache.org/javadocs/3.2.2/core/ (core javadoc)
> >> > http://tinkerpop.apache.org/javadocs/3.2.2/full/ (full javadoc)
> >> >
> >> > The tag in Apache Git can be found here:
> >> > https://git-wip-us.apache.org/repos/asf?p=tinkerpop.git;a=tag;h=
> >> > 16d28c16ea43c678a18061506b4f0dc6a384fa1e
> >> >
> >> > The release notes are available here:
> >> > https://github.com/apache/tinkerpop/blob/3.2.2/
> >> > CHANGELOG.asciidoc#tinkerpop-322-release-date-september-9-2016
> >> >
> >> > The [VOTE] will be open for the next 72 hours --- closing Friday
> >> (September
> >> > 9, 2016) at 4pm.
> >> >
> >> > My vote is +1.
> >> >
> >> > Thank you very much,
> >> >
> >> > Stephen
> >> >
> >>
> >
> >
>

Re: [CANCEL][VOTE] TinkerPop 3.2.2 Release

Posted by Stephen Mallette <sp...@gmail.com>.
Yes - thanks for that reminder - i will do that too.

On Wed, Sep 7, 2016 at 7:25 AM, Robert Dale <ro...@gmail.com> wrote:

> Stephen, did you see the other pull request to fix the 'option' section?
> It would be great if you could pull that in if you are also rebuilding the
> docs.
>
> On Wednesday, September 7, 2016, Stephen Mallette <sp...@gmail.com>
> wrote:
>
> > This VOTE is cancelled - we have to scrap this build. Weak.
> >
> > Kuppitz has a bug fix under test right now. On top of his fix, I will
> > officially correct the "bad link" to GLVs that Robert found (thanks for
> > reviewing/voting btw). Expect a new VOTE thread later today once this is
> > all settled.
> >
> > Note that 3.1.4 did not have this problem so that VOTE can stay open - i
> > just tested that out to be sure:
> >
> > gremlin> g.V(ids).as("a").
> > gremlin>
> >  repeat(bothE().otherV().simplePath()).times(5).emit(
> > hasId(within(ids))).as("b").
> > gremlin> filter(select(last,"a","b").by(id).where("a", lt("b"))).
> > gremlin>  path().by().by(label)
> > ==>[v[2], knows, v[1], knows, v[4]]
> > ==>[v[2], knows, v[1], created, v[3], created, v[4]]
> > ==>[v[2], knows, v[1], created, v[3], created, v[6]]
> > ==>[v[2], knows, v[1], knows, v[4], created, v[3], created, v[6]]
> > ==>[v[4], created, v[3], created, v[6]]
> > ==>[v[4], knows, v[1], created, v[3], created, v[6]]
> >
> >
> >
> >
> > On Tue, Sep 6, 2016 at 6:47 PM, Stephen Mallette <spmallette@gmail.com
> > <javascript:;>>
> > wrote:
> >
> > > Kuppitz saw a problem in one of the recipes - note the second example:
> > >
> > > http://tinkerpop.apache.org/docs/3.2.2/recipes/
> > >
> > > no results and this was working in 3.2.1:
> > >
> > > http://tinkerpop.apache.org/docs/3.2.1/recipes/
> > >
> > > His gremlin session shows:
> > >
> > > gremlin> g.V().hasId(1)
> > > ==>v[1]
> > > gremlin> g.V().hasId(within(1,2))
> > > gremlin>
> > >
> > > so damn - i guess we need to scrap this release and fix that problem -
> i
> > > guess i'm -1 based on that..........anyone have a clue as to what
> changed
> > > to cause that problem?
> > >
> > >
> > > On Tue, Sep 6, 2016 at 6:12 PM, Daniel Kuppitz <me...@gremlin.guru>
> wrote:
> > >
> > >> Validation looks good:
> > >>
> > >> $ bin/validate-distribution.sh 3.2.2
> > >>
> > >> Validating binary distributions
> > >>
> > >> * downloading Apache TinkerPop Gremlin
> > >> (apache-tinkerpop-gremlin-console-3.2.2-bin.zip)... OK
> > >> * validating signatures and checksums ...
> > >>   * PGP signature ... OK
> > >>   * MD5 checksum ... OK
> > >>   * SHA1 checksum ... OK
> > >> * unzipping Apache TinkerPop Gremlin ... OK
> > >> * validating Apache TinkerPop Gremlin's docs ... OK
> > >> * validating Apache TinkerPop Gremlin's binaries ... OK
> > >> * validating Apache TinkerPop Gremlin's legal files ...
> > >>   * LICENSE ... OK
> > >>   * NOTICE ... OK
> > >> * validating Apache TinkerPop Gremlin's plugin directory ... OK
> > >> * validating Apache TinkerPop Gremlin's lib directory ... OK
> > >> * testing script evaluation ... OK
> > >>
> > >> * downloading Apache TinkerPop Gremlin
> > >> (apache-tinkerpop-gremlin-server-3.2.2-bin.zip)... OK
> > >> * validating signatures and checksums ...
> > >>   * PGP signature ... OK
> > >>   * MD5 checksum ... OK
> > >>   * SHA1 checksum ... OK
> > >> * unzipping Apache TinkerPop Gremlin ... OK
> > >> * validating Apache TinkerPop Gremlin's docs ... OK
> > >> * validating Apache TinkerPop Gremlin's binaries ... OK
> > >> * validating Apache TinkerPop Gremlin's legal files ...
> > >>   * LICENSE ... OK
> > >>   * NOTICE ... OK
> > >> * validating Apache TinkerPop Gremlin's plugin directory ... OK
> > >> * validating Apache TinkerPop Gremlin's lib directory ... OK
> > >>
> > >> Validating source distribution
> > >>
> > >> * downloading Apache TinkerPop 3.2.2 (apache-tinkerpop-3.2.2-src.
> > zip)...
> > >> OK
> > >> * validating signatures and checksums ...
> > >>   * PGP signature ... OK
> > >>   * MD5 checksum ... OK
> > >>   * SHA1 checksum ... OK
> > >> * unzipping Apache TinkerPop 3.2.2 ... OK
> > >> OK
> > >>
> > >> The docs seem to be correct, but I don't like how we now have the
> > numbered
> > >> indents, e.g:
> > >>
> > >> gremlin> g.V().hasLabel("person").groupCount().by(values("age").
> choose(
> > >> ......1>   is(lt(28)),constant("young"),
> > >> ......2>   choose(is(lt(30)),
> > >> ......3>          constant("old"),
> > >> ......4>          constant("very old"))))
> > >> ==>[young:1,old:1,very old:2]
> > >>
> > >>
> > >> This is bad, since our snippets are now no longer copy+pastable. I
> will
> > >> fix
> > >> that for the next release.
> > >>
> > >> All in all: VOTE: +1
> > >>
> > >> Cheers,
> > >> Daniel
> > >>
> > >>
> > >>
> > >> On Tue, Sep 6, 2016 at 10:05 PM, Stephen Mallette <
> spmallette@gmail.com
> > <javascript:;>>
> > >> wrote:
> > >>
> > >> > Hello,
> > >> >
> > >> > We are happy to announce that TinkerPop 3.2.2 is ready for release.
> > >> >
> > >> > The release artifacts can be found at this location:
> > >> > https://dist.apache.org/repos/dist/dev/tinkerpop/3.2.2/
> > >> >
> > >> > The source distribution is provided by:
> > >> > apache-tinkerpop-3.2.2-src.zip
> > >> >
> > >> > Two binary distributions are provided for user convenience:
> > >> > apache-tinkerpop-gremlin-console-3.2.2-bin.zip
> > >> > apache-tinkerpop-gremlin-server-3.2.2-bin.zip
> > >> >
> > >> > The GPG key used to sign the release artifacts is available at:
> > >> >     https://dist.apache.org/repos/dist/dev/tinkerpop/KEYS
> > >> >
> > >> > The online docs can be found here:
> > >> > http://tinkerpop.apache.org/docs/3.2.2/ (user docs)
> > >> > http://tinkerpop.apache.org/docs/3.2.2/upgrade/ (upgrade docs)
> > >> > http://tinkerpop.apache.org/javadocs/3.2.2/core/ (core javadoc)
> > >> > http://tinkerpop.apache.org/javadocs/3.2.2/full/ (full javadoc)
> > >> >
> > >> > The tag in Apache Git can be found here:
> > >> > https://git-wip-us.apache.org/repos/asf?p=tinkerpop.git;a=tag;h=
> > >> > 16d28c16ea43c678a18061506b4f0dc6a384fa1e
> > >> >
> > >> > The release notes are available here:
> > >> > https://github.com/apache/tinkerpop/blob/3.2.2/
> > >> > CHANGELOG.asciidoc#tinkerpop-322-release-date-september-9-2016
> > >> >
> > >> > The [VOTE] will be open for the next 72 hours --- closing Friday
> > >> (September
> > >> > 9, 2016) at 4pm.
> > >> >
> > >> > My vote is +1.
> > >> >
> > >> > Thank you very much,
> > >> >
> > >> > Stephen
> > >> >
> > >>
> > >
> > >
> >
>
>
> --
> null
>

Re: [CANCEL][VOTE] TinkerPop 3.2.2 Release

Posted by Robert Dale <ro...@gmail.com>.
Stephen, did you see the other pull request to fix the 'option' section?
It would be great if you could pull that in if you are also rebuilding the
docs.

On Wednesday, September 7, 2016, Stephen Mallette <sp...@gmail.com>
wrote:

> This VOTE is cancelled - we have to scrap this build. Weak.
>
> Kuppitz has a bug fix under test right now. On top of his fix, I will
> officially correct the "bad link" to GLVs that Robert found (thanks for
> reviewing/voting btw). Expect a new VOTE thread later today once this is
> all settled.
>
> Note that 3.1.4 did not have this problem so that VOTE can stay open - i
> just tested that out to be sure:
>
> gremlin> g.V(ids).as("a").
> gremlin>
>  repeat(bothE().otherV().simplePath()).times(5).emit(
> hasId(within(ids))).as("b").
> gremlin> filter(select(last,"a","b").by(id).where("a", lt("b"))).
> gremlin>  path().by().by(label)
> ==>[v[2], knows, v[1], knows, v[4]]
> ==>[v[2], knows, v[1], created, v[3], created, v[4]]
> ==>[v[2], knows, v[1], created, v[3], created, v[6]]
> ==>[v[2], knows, v[1], knows, v[4], created, v[3], created, v[6]]
> ==>[v[4], created, v[3], created, v[6]]
> ==>[v[4], knows, v[1], created, v[3], created, v[6]]
>
>
>
>
> On Tue, Sep 6, 2016 at 6:47 PM, Stephen Mallette <spmallette@gmail.com
> <javascript:;>>
> wrote:
>
> > Kuppitz saw a problem in one of the recipes - note the second example:
> >
> > http://tinkerpop.apache.org/docs/3.2.2/recipes/
> >
> > no results and this was working in 3.2.1:
> >
> > http://tinkerpop.apache.org/docs/3.2.1/recipes/
> >
> > His gremlin session shows:
> >
> > gremlin> g.V().hasId(1)
> > ==>v[1]
> > gremlin> g.V().hasId(within(1,2))
> > gremlin>
> >
> > so damn - i guess we need to scrap this release and fix that problem - i
> > guess i'm -1 based on that..........anyone have a clue as to what changed
> > to cause that problem?
> >
> >
> > On Tue, Sep 6, 2016 at 6:12 PM, Daniel Kuppitz <me...@gremlin.guru> wrote:
> >
> >> Validation looks good:
> >>
> >> $ bin/validate-distribution.sh 3.2.2
> >>
> >> Validating binary distributions
> >>
> >> * downloading Apache TinkerPop Gremlin
> >> (apache-tinkerpop-gremlin-console-3.2.2-bin.zip)... OK
> >> * validating signatures and checksums ...
> >>   * PGP signature ... OK
> >>   * MD5 checksum ... OK
> >>   * SHA1 checksum ... OK
> >> * unzipping Apache TinkerPop Gremlin ... OK
> >> * validating Apache TinkerPop Gremlin's docs ... OK
> >> * validating Apache TinkerPop Gremlin's binaries ... OK
> >> * validating Apache TinkerPop Gremlin's legal files ...
> >>   * LICENSE ... OK
> >>   * NOTICE ... OK
> >> * validating Apache TinkerPop Gremlin's plugin directory ... OK
> >> * validating Apache TinkerPop Gremlin's lib directory ... OK
> >> * testing script evaluation ... OK
> >>
> >> * downloading Apache TinkerPop Gremlin
> >> (apache-tinkerpop-gremlin-server-3.2.2-bin.zip)... OK
> >> * validating signatures and checksums ...
> >>   * PGP signature ... OK
> >>   * MD5 checksum ... OK
> >>   * SHA1 checksum ... OK
> >> * unzipping Apache TinkerPop Gremlin ... OK
> >> * validating Apache TinkerPop Gremlin's docs ... OK
> >> * validating Apache TinkerPop Gremlin's binaries ... OK
> >> * validating Apache TinkerPop Gremlin's legal files ...
> >>   * LICENSE ... OK
> >>   * NOTICE ... OK
> >> * validating Apache TinkerPop Gremlin's plugin directory ... OK
> >> * validating Apache TinkerPop Gremlin's lib directory ... OK
> >>
> >> Validating source distribution
> >>
> >> * downloading Apache TinkerPop 3.2.2 (apache-tinkerpop-3.2.2-src.
> zip)...
> >> OK
> >> * validating signatures and checksums ...
> >>   * PGP signature ... OK
> >>   * MD5 checksum ... OK
> >>   * SHA1 checksum ... OK
> >> * unzipping Apache TinkerPop 3.2.2 ... OK
> >> OK
> >>
> >> The docs seem to be correct, but I don't like how we now have the
> numbered
> >> indents, e.g:
> >>
> >> gremlin> g.V().hasLabel("person").groupCount().by(values("age").choose(
> >> ......1>   is(lt(28)),constant("young"),
> >> ......2>   choose(is(lt(30)),
> >> ......3>          constant("old"),
> >> ......4>          constant("very old"))))
> >> ==>[young:1,old:1,very old:2]
> >>
> >>
> >> This is bad, since our snippets are now no longer copy+pastable. I will
> >> fix
> >> that for the next release.
> >>
> >> All in all: VOTE: +1
> >>
> >> Cheers,
> >> Daniel
> >>
> >>
> >>
> >> On Tue, Sep 6, 2016 at 10:05 PM, Stephen Mallette <spmallette@gmail.com
> <javascript:;>>
> >> wrote:
> >>
> >> > Hello,
> >> >
> >> > We are happy to announce that TinkerPop 3.2.2 is ready for release.
> >> >
> >> > The release artifacts can be found at this location:
> >> > https://dist.apache.org/repos/dist/dev/tinkerpop/3.2.2/
> >> >
> >> > The source distribution is provided by:
> >> > apache-tinkerpop-3.2.2-src.zip
> >> >
> >> > Two binary distributions are provided for user convenience:
> >> > apache-tinkerpop-gremlin-console-3.2.2-bin.zip
> >> > apache-tinkerpop-gremlin-server-3.2.2-bin.zip
> >> >
> >> > The GPG key used to sign the release artifacts is available at:
> >> >     https://dist.apache.org/repos/dist/dev/tinkerpop/KEYS
> >> >
> >> > The online docs can be found here:
> >> > http://tinkerpop.apache.org/docs/3.2.2/ (user docs)
> >> > http://tinkerpop.apache.org/docs/3.2.2/upgrade/ (upgrade docs)
> >> > http://tinkerpop.apache.org/javadocs/3.2.2/core/ (core javadoc)
> >> > http://tinkerpop.apache.org/javadocs/3.2.2/full/ (full javadoc)
> >> >
> >> > The tag in Apache Git can be found here:
> >> > https://git-wip-us.apache.org/repos/asf?p=tinkerpop.git;a=tag;h=
> >> > 16d28c16ea43c678a18061506b4f0dc6a384fa1e
> >> >
> >> > The release notes are available here:
> >> > https://github.com/apache/tinkerpop/blob/3.2.2/
> >> > CHANGELOG.asciidoc#tinkerpop-322-release-date-september-9-2016
> >> >
> >> > The [VOTE] will be open for the next 72 hours --- closing Friday
> >> (September
> >> > 9, 2016) at 4pm.
> >> >
> >> > My vote is +1.
> >> >
> >> > Thank you very much,
> >> >
> >> > Stephen
> >> >
> >>
> >
> >
>


-- 
null