You are viewing a plain text version of this content. The canonical link for it is here.
Posted to dev@mesos.apache.org by Benjamin Hindman <be...@berkeley.edu> on 2014/12/02 23:12:58 UTC

Re: Review Request 28316: Reorganize clock event callback functions.

-----------------------------------------------------------
This is an automatically generated e-mail. To reply, visit:
https://reviews.apache.org/r/28316/#review63588
-----------------------------------------------------------



3rdparty/libprocess/include/process/clock.hpp
<https://reviews.apache.org/r/28316/#comment105862>

    Going back to an idea Niklas had before, how about calling this Clock::tick() (to differentiate from the internal 'handle_timeouts' functions) and then use 'EventLoop::delay(computeNextTimeout(), &Clock::tick))' in the implementation.


- Benjamin Hindman


On Nov. 26, 2014, 5:32 a.m., Joris Van Remoortere wrote:
> 
> -----------------------------------------------------------
> This is an automatically generated e-mail. To reply, visit:
> https://reviews.apache.org/r/28316/
> -----------------------------------------------------------
> 
> (Updated Nov. 26, 2014, 5:32 a.m.)
> 
> 
> Review request for mesos, Benjamin Hindman and Niklas Nielsen.
> 
> 
> Repository: mesos-git
> 
> 
> Description
> -------
> 
> By putting the libevent callback into a class we can protect access to the computeNextTimeout function correctly.
> 
> 
> Diffs
> -----
> 
>   3rdparty/libprocess/include/process/clock.hpp 1fd418b31133fd5a5444095ac887c77ee9375b2d 
>   3rdparty/libprocess/src/clock.cpp dfe9ced2415b8567abb8c137ab73d90b59164d67 
> 
> Diff: https://reviews.apache.org/r/28316/diff/
> 
> 
> Testing
> -------
> 
> 
> Thanks,
> 
> Joris Van Remoortere
> 
>