You are viewing a plain text version of this content. The canonical link for it is here.
Posted to java-dev@axis.apache.org by David Illsley <da...@gmail.com> on 2007/02/16 17:25:51 UTC

The WSDL11ToAxisServiceBuilder mess

I've just fixed up the WSDL11ToAxisServiceBuilder action processing
because the code which was there had been totally bypassed. As is a
large swathe of other code in there. It appears that the 'merge' of
the WSDL20 branch back totally ignored all the work that occurred in
that class while WSDL20 development happened on a branch.

Could someone involved with the WSDL20 branch please do an analysis of
the current code in WSDL11ToAxisServiceBuilder and do an intelligent
merge, removing the methods which are subsequently no longer used and
requesting clarification of code they're unsure about (rather than
just bypassing it).

Thanks,
David

-- 
David Illsley - IBM Web Services Development

---------------------------------------------------------------------
To unsubscribe, e-mail: axis-dev-unsubscribe@ws.apache.org
For additional commands, e-mail: axis-dev-help@ws.apache.org


Re: The WSDL11ToAxisServiceBuilder mess

Posted by Amila Suriarachchi <am...@gmail.com>.
On 2/21/07, David Illsley <da...@gmail.com> wrote:
>
> OK,
> I've done the refactoring to remove the redundant code.


+1. I hope you have tested properly every thing you have refactored.
I agree with you that there are some places to be refactored. but this code
worked properly with axis2-1-1-1 release.

I still think
> the class is overlarge and addresses 2 separate concerns. Firstly, to
> add the wrapped operation schema stuff to the wsdl4j definition and
> second to process the wsdl4j model.


Here is the reason to generate the wrappable schema.

Basically soap binding have two styles namely doucment and rpc. In rpc style
we have to generate the actual element type (send in the soap body) by
wrapping the each message parts from an element having its part name and
finally whole message parts from an element having the operation name.
The elementQname in the Axis message refers to an xsd element. Therefore if
the binding we have chosen is in rpc stype, then we set the above generated
element type as the message element Qname.
This setting is done in addQNameReference method. Actally there are some
issues with the logic used here and I will fix them shortly.

Now as you can see, generating the wrapping elements is also a part of
building the AxisService building. (since it creates the correct
elementQname for axis message)


I don't really understand the wrapped operation schema stuff but would
> otherwise like to factor it out into a separate class so that the
> builder can focus on the second concern which I believe is the main
> reason for the class. If we could separate them out I think the class
> would be a lot more maintainable. Does anyone have the knowledge and
> inclination to do this?
>
> David
>
>
>


-- 
Amila Suriarachchi,
WSO2 Inc.

Re: The WSDL11ToAxisServiceBuilder mess

Posted by David Illsley <da...@gmail.com>.
OK,
I've done the refactoring to remove the redundant code. I still think
the class is overlarge and addresses 2 separate concerns. Firstly, to
add the wrapped operation schema stuff to the wsdl4j definition and
second to process the wsdl4j model.

I don't really understand the wrapped operation schema stuff but would
otherwise like to factor it out into a separate class so that the
builder can focus on the second concern which I believe is the main
reason for the class. If we could separate them out I think the class
would be a lot more maintainable. Does anyone have the knowledge and
inclination to do this?

David

On 20/02/07, David Illsley <da...@gmail.com> wrote:
> Thanks. The addressing related parts look ok... but that's not all I
> care about. There's still a bunch of redundant code in the file. I've
> started a refactor which I'll try to do in a number of stages to keep
> it easy to do and to review.
>
> David
>
> On 19/02/07, Amila Suriarachchi <am...@gmail.com> wrote:
> > hi,
> > I reviewed the code once and fixed some bugs. specially with the
> > copyingextensibility elements.
> > it seems that I have missed the populate operation method. if you could,
> > David can you please have a review for addressing related parts? I reviewed
> > and tested for soap binding and related wsdl parts.
> >
> > --
> > Amila Suriarachchi,
> > WSO2 Inc.
>
>
> --
> David Illsley - IBM Web Services Development
>


-- 
David Illsley - IBM Web Services Development

---------------------------------------------------------------------
To unsubscribe, e-mail: axis-dev-unsubscribe@ws.apache.org
For additional commands, e-mail: axis-dev-help@ws.apache.org


Re: The WSDL11ToAxisServiceBuilder mess

Posted by David Illsley <da...@gmail.com>.
Thanks. The addressing related parts look ok... but that's not all I
care about. There's still a bunch of redundant code in the file. I've
started a refactor which I'll try to do in a number of stages to keep
it easy to do and to review.

David

On 19/02/07, Amila Suriarachchi <am...@gmail.com> wrote:
> hi,
> I reviewed the code once and fixed some bugs. specially with the
> copyingextensibility elements.
> it seems that I have missed the populate operation method. if you could,
> David can you please have a review for addressing related parts? I reviewed
> and tested for soap binding and related wsdl parts.
>
> --
> Amila Suriarachchi,
> WSO2 Inc.


-- 
David Illsley - IBM Web Services Development

---------------------------------------------------------------------
To unsubscribe, e-mail: axis-dev-unsubscribe@ws.apache.org
For additional commands, e-mail: axis-dev-help@ws.apache.org


Re: The WSDL11ToAxisServiceBuilder mess

Posted by Amila Suriarachchi <am...@gmail.com>.
hi,
I reviewed the code once and fixed some bugs. specially with the
copyingextensibility elements.
it seems that I have missed the populate operation method. if you could,
David can you please have a review for addressing related parts? I reviewed
and tested for soap binding and related wsdl parts.

-- 
Amila Suriarachchi,
WSO2 Inc.

Re: The WSDL11ToAxisServiceBuilder mess

Posted by Davanum Srinivas <da...@gmail.com>.
Keith,

Please review the code changes for the time between the fork for
wsdl20 branch and merge and make sure all the changes get reflected in
trunk.

thanks,
dims

On 2/16/07, David Illsley <da...@gmail.com> wrote:
> I've just fixed up the WSDL11ToAxisServiceBuilder action processing
> because the code which was there had been totally bypassed. As is a
> large swathe of other code in there. It appears that the 'merge' of
> the WSDL20 branch back totally ignored all the work that occurred in
> that class while WSDL20 development happened on a branch.
>
> Could someone involved with the WSDL20 branch please do an analysis of
> the current code in WSDL11ToAxisServiceBuilder and do an intelligent
> merge, removing the methods which are subsequently no longer used and
> requesting clarification of code they're unsure about (rather than
> just bypassing it).
>
> Thanks,
> David
>
> --
> David Illsley - IBM Web Services Development
>
> ---------------------------------------------------------------------
> To unsubscribe, e-mail: axis-dev-unsubscribe@ws.apache.org
> For additional commands, e-mail: axis-dev-help@ws.apache.org
>
>


-- 
Davanum Srinivas :: http://wso2.org/ :: Oxygen for Web Services Developers

---------------------------------------------------------------------
To unsubscribe, e-mail: axis-dev-unsubscribe@ws.apache.org
For additional commands, e-mail: axis-dev-help@ws.apache.org