You are viewing a plain text version of this content. The canonical link for it is here.
Posted to commits@cassandra.apache.org by "Blake Eggleston (JIRA)" <ji...@apache.org> on 2018/08/03 21:31:00 UTC

[jira] [Created] (CASSANDRA-14621) Refactor CompactionStrategyManager

Blake Eggleston created CASSANDRA-14621:
-------------------------------------------

             Summary: Refactor CompactionStrategyManager
                 Key: CASSANDRA-14621
                 URL: https://issues.apache.org/jira/browse/CASSANDRA-14621
             Project: Cassandra
          Issue Type: Improvement
          Components: Compaction
            Reporter: Blake Eggleston
            Assignee: Blake Eggleston
             Fix For: 4.0


CompactionStrategyManager grew a decent amount of duplicated code as part of CASSANDRA-91423, which added pendingRepairs alongside the repaired and unrepaired buckets. At this point, the logic that routes sstables between the different buckets, and the different partition range divisions has gotten a little complex, and editing it is tedious and error prone. With transient replication requiring yet another bucket for, this seems like a good time to split some of the functionality of CSM into other classes, and make sstable routing a bit more generalized.



--
This message was sent by Atlassian JIRA
(v7.6.3#76005)

---------------------------------------------------------------------
To unsubscribe, e-mail: commits-unsubscribe@cassandra.apache.org
For additional commands, e-mail: commits-help@cassandra.apache.org