You are viewing a plain text version of this content. The canonical link for it is here.
Posted to issues@hbase.apache.org by "Bryan Baugher (JIRA)" <ji...@apache.org> on 2013/01/04 20:48:14 UTC

[jira] [Updated] (HBASE-3996) Support multiple tables and scanners as input to the mapper in map/reduce jobs

     [ https://issues.apache.org/jira/browse/HBASE-3996?page=com.atlassian.jira.plugin.system.issuetabpanels:all-tabpanel ]

Bryan Baugher updated HBASE-3996:
---------------------------------

    Attachment: 3996-v8.txt

I would like to offer to finish this issue. If you would rather close this issue or start a new one that is fine just let me know.

Here is what I have done from the previous version,

* Removed random formatting changes
* Removed table.close() in TableRecordReaderImpl
* Replaced MultiTableInputCollection with List<Scan>
* Brought up to date with trunk
 
Remaining questions,

* Since most of enum Version code is copied, we may want to factor the base enum to its own class. Would org.apache.hadoop.hbase.util be a good namespace for the enum class ?
* The changes to TableSplit would not allow a new version of it to be deserialized by an old server. Is that OK for a M/R job?
* It has been mentioned to scope this to scans (of a single table) rather then multiple tables.

I can't seem to get the tests to run for me (getting OOM errors) but I would imagine most everything still works.

                
> Support multiple tables and scanners as input to the mapper in map/reduce jobs
> ------------------------------------------------------------------------------
>
>                 Key: HBASE-3996
>                 URL: https://issues.apache.org/jira/browse/HBASE-3996
>             Project: HBase
>          Issue Type: Improvement
>          Components: mapreduce
>            Reporter: Eran Kutner
>            Assignee: Lars Hofhansl
>             Fix For: 0.96.0, 0.94.5
>
>         Attachments: 3996-v2.txt, 3996-v3.txt, 3996-v4.txt, 3996-v5.txt, 3996-v6.txt, 3996-v7.txt, 3996-v8.txt, HBase-3996.patch
>
>
> It seems that in many cases feeding data from multiple tables or multiple scanners on a single table can save a lot of time when running map/reduce jobs.
> I propose a new MultiTableInputFormat class that would allow doing this.

--
This message is automatically generated by JIRA.
If you think it was sent incorrectly, please contact your JIRA administrators
For more information on JIRA, see: http://www.atlassian.com/software/jira